]> git.pld-linux.org Git - packages/adobe-flash.git/blame - adobe-flash.spec
- consistent filenames regardless of arch
[packages/adobe-flash.git] / adobe-flash.spec
CommitLineData
e9cc6da3 1#
aa3cbbce 2# Conditional build:
3%bcond_with license_agreement # generates package
19d7e29f 4
84bf8124
ER
5%define ver32 10.3.181.34
6%define ver64 10.3.162.29
7
e6d2385a 8%ifarch %{ix86}
84bf8124 9%define version %{ver32}
e6d2385a
ER
10%define libmark %{nil}
11%endif
e0aacdca 12%ifarch %{x8664}
84bf8124 13%define version %{ver64}
e6d2385a 14%define libmark ()(64bit)
b18d4034 15%endif
19d7e29f 16
fdeb48aa 17%define base_name adobe-flash
0422b44b 18%define rel 1
53f15d83 19Summary: Flash plugin for Netscape-compatible WWW browsers
989db712 20Summary(pl.UTF-8): Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
aa3cbbce 21%if %{with license_agreement}
22Name: %{base_name}
23%else
24Name: %{base_name}-installer
25%endif
84bf8124 26Version: %{version}
5e11dd18 27Release: %{rel}%{?with_license_agreement:wla}
4ec0200b 28Epoch: 1
53f15d83 29License: Free to use, non-distributable
01b5e1fb 30Group: X11/Applications/Multimedia
aa3cbbce 31%if %{with license_agreement}
28b6a6b0 32#Source0: http://download.macromedia.com/pub/labs/flashplatformruntimes/flashplayer10-3/flashplayer10-3_rc1_lin_042011.tar.gz
84bf8124 33Source0: http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz#/%{name}-%{ver32}.tgz
c4cbb2ec 34# NoSource0-md5: 26770108412158b710e633b06a71ca25
364b3cd0 35NoSource: 0
f4a110d9 36##Source1: http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
84bf8124 37Source1: http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz#/%{name}64-%{ver64}.tgz
35b7834e 38# NoSource1-md5: 49b55c7eb8044453e5f6f2e4b3cb4084
e0aacdca 39NoSource: 1
63f88470 40Source2: mms.cfg
18284157 41%else
63f88470
ER
42Source3: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
43# Source3-md5: 329c25f457fea66ec502b7ef70cb9ede
aa3cbbce 44%endif
d6511d55 45Source4: memcpy-to-memmove.sh
ba9bcac5 46URL: http://www.adobe.com/products/flashplayer/
b68eb59b 47%if %{with license_agreement}
df79ad5e 48BuildRequires: rpmbuild(macros) >= 1.357
5f855dbc 49BuildRequires: sed >= 4.0
df79ad5e 50Requires: browser-plugins >= 2.0
15b3da69 51# dlopened by player
b18d4034
AM
52Requires: libasound.so.2%{libmark}
53Requires: libcurl.so.4%{libmark}
94ae04b2 54%else
1fe695bf 55Requires: rpm-build-tools >= 4.4.37
9377eeca 56Requires: rpmbuild(macros) >= 1.544
533db319 57%endif
bcccd50e 58Provides: browser(flash)
5f855dbc 59Provides: macromedia-flash
533db319 60Obsoletes: flash-plugin
533db319 61Obsoletes: konqueror-plugin-macromedia-flash
5891b1a0 62Obsoletes: macromedia-flash
a00d2cc2
ER
63Obsoletes: mozilla-firefox-plugin-macromedia-flash
64Obsoletes: mozilla-plugin-macromedia-flash
e0aacdca 65ExclusiveArch: %{ix86} %{x8664}
01b5e1fb
PG
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
ed1085d2
ER
68%define _sysconfdir /etc/adobe
69
0fa08e0e
ER
70# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
71%define _noautoreqdep libstdc++.so.6
72
1fe30e9c
ER
73# No debuginfo to be stored
74%define _enable_debug_packages 0
75
01b5e1fb 76%description
65fff478 77Adobe(R) Flash(R) Player for Linux - the next-generation client
e338620c 78runtime for engaging with Flash content and applications on Linux.
53f15d83 79
5f2286aa
JR
80%description -l pl.UTF-8
81Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
82treści i aplikacji we Flashu pod Linuksem.
53f15d83 83
01b5e1fb 84%prep
aa3cbbce 85%if %{with license_agreement}
b18d4034
AM
86%ifarch %{x8664}
87%setup -q -T -c -b 1
88%else
3170126a 89%setup -q -T -c -b 0
b18d4034 90%endif
d4052f7c
ER
91
92%build
e6d2385a 93s=$(echo 'LNX %{version}' | tr . ,)
7673fff0 94v=$(strings libflashplayer.so | grep '^LNX ')
d4052f7c
ER
95if [ "$v" != "$s" ]; then
96 : wrong version
97 exit 1
98fi
d6511d55
AM
99
100%ifarch %{x8664}
101# Bug #354073: Patch binary to use memmove instead of memcpy from
102# Redhat's bug https://bugzilla.redhat.com/show_bug.cgi?id=638477#c94
103cp libflashplayer.so libflashplayer.so.orig
104/bin/bash %{SOURCE4} libflashplayer.so \
105|| (echo "memcpy-to-memmove.sh failed" && exit 1)
106%endif
aa3cbbce 107%endif
01b5e1fb
PG
108
109%install
110rm -rf $RPM_BUILD_ROOT
ed1085d2 111%if %{without license_agreement}
aa3cbbce 112install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
113
18284157
ER
114sed -e '
115 s/@BASE_NAME@/%{base_name}/g
116 s/@TARGET_CPU@/%{_target_cpu}/g
117 s-@VERSION@-%{version}-g
118 s-@RELEASE@-%{release}-g
119 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
03482652 120 s,@DATADIR@,%{_datadir}/%{base_name},g
63f88470 121' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
aa3cbbce 122
63f88470 123cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
aa3cbbce 124
125%else
126
ed1085d2 127install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
63f88470
ER
128cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
129install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
aa3cbbce 130%endif
131
01b5e1fb
PG
132%clean
133rm -rf $RPM_BUILD_ROOT
134
df79ad5e 135%if %{without license_agreement}
ae33c71b 136%post
18284157 137%{_bindir}/%{base_name}.install
533db319 138%else
df79ad5e
ER
139%post
140%update_browser_plugins
533db319 141
df79ad5e
ER
142%postun
143if [ "$1" = 0 ]; then
144 %update_browser_plugins
145fi
533db319
ER
146%endif
147
aa3cbbce 148%files
149%defattr(644,root,root,755)
df79ad5e 150%if %{without license_agreement}
aa3cbbce 151%attr(755,root,root) %{_bindir}/%{base_name}.install
152%{_datadir}/%{base_name}
aa3cbbce 153%else
ed1085d2
ER
154%dir %{_sysconfdir}
155%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
df79ad5e 156%attr(755,root,root) %{_browserpluginsdir}/*.so
aa3cbbce 157%endif
This page took 0.050518 seconds and 4 git commands to generate.