]> git.pld-linux.org Git - packages/VirtualBox.git/blame - VirtualBox.spec
- desc cosmetics, BR updates from vbox.spec
[packages/VirtualBox.git] / VirtualBox.spec
CommitLineData
48363591 1#
2# TODO:
3# - Doesn't compile without /usr/src/linux/include/linux/autoconf.h so one must
4# symlink it before building package. This is because during compilation kernel
5# module is being build. Since we are building kernel modules later
6# sources/makefiles probably needs some hacking to drop this requirement.
7# - Home page says that some addons should be compiled, I don't see any except.
8# vboxaddon kernel module and {vboxmouse,vboxvideo)_drv.so. Are they required?
9# - BR list was a quickie so it may be incomplete or too big.
10# - R list probably required.
11# - .desktop file, some wrapper to launch VirtualBox (LD_LIBRARY_PATH must include
12# %{_libdir}/VirtualBox), maybe some init script to launch VBoxSVC.
13# - Devel stuff is not packaged yet.
eba4b2aa
JB
14# - Now its EA ix86 x8664, but looking into autogenerated env.sh suggests that
15# code may be compiled exclusively for i686.
48363591 16#
17# Conditional build:
18%bcond_without dist_kernel # without distribution kernel
19%bcond_without smp # without SMP kernel modules
20#
21%define _snap 20070116
22Summary: VirtualBox
23Summary(pl): VirtualBox
24Name: VirtualBox
25Version: 1.3.3
26Release: 0.1
27License: GPL v2
28Group: Applications/Emulators
29Source0: %{name}-%{version}_%{_snap}.tar.bz2
30# Source0-md5: 8554cf552c3ad07b2ae5229c3f8825dc
31Patch0: %{name}-configure.patch
32Patch1: %{name}-qt-paths.patch
33URL: http://www.virtualbox.org/
34BuildRequires: SDL-devel
e5aaadde 35BuildRequires: bash
48363591 36BuildRequires: bcc
37BuildRequires: bin86
eba4b2aa 38BuildRequires: gcc >= 5:3.2.3
48363591 39BuildRequires: iasl
40%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
41BuildRequires: libIDL-devel
42BuildRequires: libuuid-devel
e5aaadde 43BuildRequires: libxslt-progs
44BuildRequires: qt-devel >= 6:3.3.6
48363591 45BuildRequires: rpmbuild(macros) >= 1.329
e5aaadde 46BuildRequires: xalan-c-devel >= 1.10.0
eba4b2aa 47#BuildRequires: xcursor-devel
e5aaadde 48BuildRequires: xerces-c-devel >= 2.6.0
eba4b2aa 49BuildRequires: xorg-lib-libXcursor-devel
e5aaadde 50BuildRequires: zlib-devel >= 1.2.1
eba4b2aa 51ExclusiveArch: %{ix86} %{x8664}
48363591 52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
eba4b2aa 54%ifarch %{x8664}
5088674d 55%define _outdir amd64
56%else
57%define _outdir x86
58%endif
59
48363591 60%description
61InnoTek VirtualBox is a general-purpose full virtualizer for x86
62hardware. Targeted at server, desktop and embedded use, it is now the
63only professional-quality virtualization solution that is also Open
64Source Software.
65
66Some of the features of VirtualBox are:
67
68Modularity: VirtualBox has an extremely modular design with
69well-defined internal programming interfaces and a client/server
70design. This makes it easy to control it from several interfaces at
71once: for example, you can start a virtual machine in a typical
72virtual machine GUI and then control that machine from the command
73line. VirtualBox also comes with a full Software Development Kit: even
74though it is Open Source Software, you don't have to hack the source
75to write a new interface for VirtualBox.
76
77Virtual machine descriptions in XML: the configuration settings of
78virtual machines are stored entirely in XML and are independent of the
79local machines. Virtual machine definitions can therefore easily be
80ported to other computers.
81
82%description -l pl
70bcd77e 83