]> git.pld-linux.org Git - packages/VirtualBox.git/blame - VirtualBox.spec
- merged BRs from vbox.spec, added some versions based on ./configure
[packages/VirtualBox.git] / VirtualBox.spec
CommitLineData
48363591 1#
2# TODO:
3# - Doesn't compile without /usr/src/linux/include/linux/autoconf.h so one must
4# symlink it before building package. This is because during compilation kernel
5# module is being build. Since we are building kernel modules later
6# sources/makefiles probably needs some hacking to drop this requirement.
7# - Home page says that some addons should be compiled, I don't see any except.
8# vboxaddon kernel module and {vboxmouse,vboxvideo)_drv.so. Are they required?
9# - BR list was a quickie so it may be incomplete or too big.
10# - R list probably required.
11# - .desktop file, some wrapper to launch VirtualBox (LD_LIBRARY_PATH must include
12# %{_libdir}/VirtualBox), maybe some init script to launch VBoxSVC.
13# - Devel stuff is not packaged yet.
14# - Now its EA ix86 amd64, but looking into autogenerated env.sh suggests that
15# code may be compiled exclusively for i686. Probably x86_64 must be put in EA for Th.
16#
17# Conditional build:
18%bcond_without dist_kernel # without distribution kernel
19%bcond_without smp # without SMP kernel modules
20#
21%define _snap 20070116
22Summary: VirtualBox
23Summary(pl): VirtualBox
24Name: VirtualBox
25Version: 1.3.3
26Release: 0.1
27License: GPL v2
28Group: Applications/Emulators
29Source0: %{name}-%{version}_%{_snap}.tar.bz2
30# Source0-md5: 8554cf552c3ad07b2ae5229c3f8825dc
31Patch0: %{name}-configure.patch
32Patch1: %{name}-qt-paths.patch
33URL: http://www.virtualbox.org/
34BuildRequires: SDL-devel
e5aaadde 35BuildRequires: bash
48363591 36BuildRequires: bcc
37BuildRequires: bin86
38BuildRequires: gcc >= 3.2.3
39BuildRequires: iasl
40%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
41BuildRequires: libIDL-devel
42BuildRequires: libuuid-devel
e5aaadde 43BuildRequires: libxslt-progs
44BuildRequires: qt-devel >= 6:3.3.6
48363591 45BuildRequires: rpmbuild(macros) >= 1.329
e5aaadde 46BuildRequires: xalan-c-devel >= 1.10.0
48363591 47BuildRequires: xcursor-devel
e5aaadde 48BuildRequires: xerces-c-devel >= 2.6.0
49BuildRequires: zlib-devel >= 1.2.1
48363591 50ExclusiveArch: %{ix86} amd64
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
5088674d 53%ifarch amd64
54%define _outdir amd64
55%else
56%define _outdir x86
57%endif
58
48363591 59%description
60InnoTek VirtualBox is a general-purpose full virtualizer for x86
61hardware. Targeted at server, desktop and embedded use, it is now the
62only professional-quality virtualization solution that is also Open
63Source Software.
64
65Some of the features of VirtualBox are:
66
67Modularity: VirtualBox has an extremely modular design with
68well-defined internal programming interfaces and a client/server
69design. This makes it easy to control it from several interfaces at
70once: for example, you can start a virtual machine in a typical
71virtual machine GUI and then control that machine from the command
72line. VirtualBox also comes with a full Software Development Kit: even
73though it is Open Source Software, you don't have to hack the source
74to write a new interface for VirtualBox.
75
76Virtual machine descriptions in XML: the configuration settings of
77virtual machines are stored entirely in XML and are independent of the
78local machines. Virtual machine definitions can therefore easily be
79ported to other computers.
80
81%description -l pl
82