]> git.pld-linux.org Git - packages/PyCXX.git/blame - PyCXX.spec
- Release 2. Added memleak fix by Barry Scott.
[packages/PyCXX.git] / PyCXX.spec
CommitLineData
bbf2b16f
MK
1# TODO: Find out authors idea behind installing it properly and try implement it
2# Propably it shoud be library thus not marked as noarch.
3
4Summary: Set of classes to help create extensions of Python in the C++ language
5Summary(pl.UTF-8): Klasy C++ pomocne przy tworzeniu modułów Pythona
6Name: PyCXX
7Version: 6.2.3
247d005a 8Release: 2
bbf2b16f
MK
9License: BSD
10Group: Development/Libraries
11# http://prdownloads.sourceforge.net/cxx/pycxx-6.2.3.tar.gz
12Source0: http://downloads.sourceforge.net/cxx/pycxx-%{version}.tar.gz
13# Source0-md5: 4e545ad225df9c14a3b344b1e6224661
247d005a 14Patch0: %{name}-memleak_fix.patch
bbf2b16f
MK
15URL: http://cxx.sourceforge.net/
16BuildRequires: python-modules
17Requires: libstdc++-devel
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21PyCXX is a set of classes to help create extensions of Python in the
22C++ language. The first part encapsulates the Python C API taking care
23of exceptions and ref counting. The second part supports the building
24of Python extension modules in C++.
25
26%description -l pl.UTF-8
27PyCXX jest zbiorem klas pomagających tworzorzyć moduły rozszerzeń
28Pythona w języku C++. Pierwsza część hermetyzuje interfejs C Pythona
29dbając o wyjątki i zliczanie refrencji. Druga wspiera budowanie
30modułów rozszerzeń Pythona.
31
32%prep
33%setup -q -n pycxx-%{version}
247d005a 34%patch0 -p1
bbf2b16f
MK
35
36%build
37
38%install
39rm -rf $RPM_BUILD_ROOT
40
41install -d $RPM_BUILD_ROOT%{_includedir}/
42cp -r CXX $RPM_BUILD_ROOT%{_includedir}/
43install -d $RPM_BUILD_ROOT%{_includedir}/CXX/Src
44install Src/IndirectPythonInterface.cxx $RPM_BUILD_ROOT%{_includedir}/CXX/Src
45install Src/Python2/* $RPM_BUILD_ROOT%{_includedir}/CXX/Src
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
52%defattr(644,root,root,755)
53%{_includedir}/CXX
This page took 0.11839 seconds and 5 git commands to generate.