]> git.pld-linux.org Git - packages/Perlbal.git/blame - Perlbal.spec
- release 2: added -test_15_webserver.patch
[packages/Perlbal.git] / Perlbal.spec
CommitLineData
8c9f6f7a 1#
2# Conditional build:
3%bcond_without autodeps # don't BR packages needed only for resolving deps
4%bcond_without tests # do not perform "make test"
5#
6%include /usr/lib/rpm/macros.perl
7Summary: Perlbal - Reverse-proxy load balancer and webserver
8#Summary(pl.UTF-8):
9Name: Perlbal
10Version: 1.59
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/B/BR/BRADFITZ/Perlbal-%{version}.tar.gz
16# Source0-md5: 7d098abd4434b70f13638cdff3e2383a
17Source1: perlbal.init
18Source2: perlbal.sysconfig
19Patch0: %{name}-no_use_lib.patch
1f59218b 20Patch1: %{name}-test_15_webserver.patch
8c9f6f7a 21URL: http://www.danga.com/perlbal/
22Requires(post,preun): /sbin/chkconfig
23BuildRequires: rpmbuild(macros) >= 1.228
24BuildRequires: perl-devel >= 1:5.8.0
25BuildRequires: rpm-perlprov >= 4.1-13
26%if %{with autodeps} || %{with tests}
27BuildRequires: perl-BSD-Resource
28BuildRequires: perl-Danga-Socket >= 1.44
29BuildRequires: perl-Sys-Syscall
30BuildRequires: perl-libwww
31%endif
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%define _noautoreq 'perl(Perlbal.*)'
36
37%description
38Perlbal is a single-threaded event-based server supporting HTTP load
39balancing, web serving, and a mix of the two.
40
41One of the defining things about Perlbal is that almost everything can
42be configured or reconfigured on the fly without needing to restart
43the software. A basic configuration file containing a management
44port enables you to easily perform operations on a running instance
45of Perlbal.
46
47# %description -l pl.UTF-8
48# TODO
49
50%prep
51%setup -q
52%patch0 -p1
1f59218b 53%patch1 -p1
8c9f6f7a 54
55%build
56%{__perl} Makefile.PL \
57 INSTALLDIRS=vendor
58%{__make}
59
60%{?with_tests:%{__make} test}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65%{__make} pure_install \
66 DESTDIR=$RPM_BUILD_ROOT
67
68install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/perlbal
69install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/perlbal
70cp -r conf $RPM_BUILD_ROOT%{_sysconfdir}/perlbal
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%post
76/sbin/chkconfig --add perlbal
77%service perlbal restart
78
79%preun
80if [ "$1" = "0" ]; then
81 %service -q perlbal stop
82 /sbin/chkconfig --del perlbal
83fi
84
85%files
86%defattr(644,root,root,755)
87%doc CHANGES doc conf
88%{perl_vendorlib}/*.pm
89%{perl_vendorlib}/Perlbal/
90%attr(755,root,root) %{_bindir}/*
91%{_mandir}/man?/*
92%attr(754,root,root) /etc/rc.d/init.d/perlbal
93%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/perlbal
94%dir %{_sysconfdir}/perlbal
95%attr(740,root,root) %{_sysconfdir}/perlbal/*
This page took 0.062897 seconds and 4 git commands to generate.