]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
- added pc patch (support absolute CMAKE_INSTALL_*DIR); release 2
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
f2c99d8a 3%bcond_without alsa # ALSA backend
b5f2479e 4%bcond_without jack # JACK backend
f2c99d8a
JB
5%bcond_without portaudio # PortAudio backend
6%bcond_without pulseaudio # PulseAudio backend
bd9b58be
JB
7%bcond_with sdl # SDL2 backend
8%bcond_with sse # force use of SSE instructions (x86)
9%bcond_with sse2 # force use of SSE2 instructions (x86)
f2c99d8a 10%bcond_without gui # alsoft-config GUI
99cf5ae3 11%bcond_with qt4 # Qt 4 instead of Qt 5 for GUI
a26f1dac 12#
bd9b58be
JB
13%ifarch pentium3 pentium4
14%define with_sse 1
15%endif
16%ifarch pentium4
17%define with_sse2 1
18%endif
d451b59a 19Summary: Open Audio Library
8be14136 20Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 21Name: OpenAL
bd9b58be 22Version: 1.19.1
60781cc7 23Release: 2
65437b48 24License: LGPL v2+
68071dbf 25Group: Libraries
bd9b58be
JB
26Source0: http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
27# Source0-md5: af6f148c342276a51ea9c33ebd303f78
60781cc7 28Patch0: %{name}-pc.patch
827050d4 29URL: http://www.openal.org/
bd9b58be 30%{?with_sdl:BuildRequires: SDL2-devel >= 2}
e62907a5 31%{?with_alsa:BuildRequires: alsa-lib-devel}
99cf5ae3 32BuildRequires: cmake >= 3.0.2
b5f2479e 33%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
89d1fa49 34BuildRequires: pkgconfig
7e80d8dd 35%{?with_portaudio:BuildRequires: portaudio-devel}
f953b352 36%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
60652dc3 37BuildRequires: rpmbuild(macros) >= 1.605
f2c99d8a 38%if %{with gui}
99cf5ae3 39%if %{with qt4}
f2c99d8a
JB
40BuildRequires: QtCore-devel >= 4.8.0
41BuildRequires: QtGui-devel >= 4.8.0
42BuildRequires: qt4-build >= 4.8.0
99cf5ae3
JB
43%else
44BuildRequires: Qt5Core-devel >= 5
45BuildRequires: Qt5Gui-devel >= 5
46BuildRequires: Qt5Widgets-devel >= 5
47BuildRequires: qt5-build >= 5
48%endif
f2c99d8a 49%endif
6a3db3d8 50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
6a3db3d8 52%description
53OpenAL, the Open Audio Library, is a joint effort to create an open,
54vendor-neutral, cross-platform API for interactive, primarily
55spatialized audio. OpenAL's primary audience are application
56developers and desktop users that rely on portable standards like
57OpenGL, for games and other multimedia applications. OpenAL is already
58supported by a number of hardware vendors and developers.
59
a4959810
JR
60%description -l pl.UTF-8
61OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
62stworzenia otwartego, niezależnego od producentów, międzyplatformowego
63interfejsu projektowania aplikacji w części obsługi dźwięku.
64Biblioteka adresowana jest do twórców aplikacji i użytkowników,
65którzy wybierają przenośne standardy, jak OpenGL, w grach i
66aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
67dostarczycieli sprzętu i programistów.
d451b59a 68
6a3db3d8 69%package devel
d451b59a 70Summary: Headers for OpenAL
8be14136 71Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 72Group: Development/Libraries
e62907a5 73Requires: %{name} = %{version}-%{release}
6a3db3d8 74
75%description devel
d451b59a 76Header files for OpenAL-based programs.
6a3db3d8 77
a4959810
JR
78%description devel -l pl.UTF-8
79Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 80OpenAL.
81
f2c99d8a
JB
82%package gui
83Summary: OpenAL configuration GUI
84Summary(pl.UTF-8): Graficzny interfejs do konfiguracji biblioteki OpenAL
85Group: X11/Applications/Sound
86Requires: %{name} = %{version}-%{release}
87Requires: QtCore >= 4.8.0
88Requires: QtGui >= 4.8.0
89
90%description gui
91OpenAL configuration GUI.
92
93%description gui -l pl.UTF-8
94Graficzny interfejs do konfiguracji biblioteki OpenAL.
95
6a3db3d8 96%prep
7e80d8dd 97%setup -q -n openal-soft-%{version}
60781cc7 98%patch0 -p1
68071dbf 99
6a3db3d8 100%build
99cf5ae3
JB
101cd build
102%cmake .. \
b5f2479e
JB
103 %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
104 %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
105 %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
99cf5ae3 106 %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
bd9b58be
JB
107 %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
108 %{!?with_sse:-DALSOFT_ENABLE_SSE_CODEGEN=OFF} \
109 %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
99cf5ae3
JB
110 -DALSOFT_EXAMPLES=OFF \
111 %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
112 %{?with_qt4:-DALSOFT_NO_QT5=ON} \
65437b48 113
7e80d8dd 114%{__make}
6a3db3d8 115
116%install
117rm -rf $RPM_BUILD_ROOT
6ce9e958 118install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
d451b59a 119
99cf5ae3 120%{__make} -C build install \
68071dbf 121 DESTDIR=$RPM_BUILD_ROOT
d451b59a 122
c06f4ed0 123install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
6ce9e958 124
b5f2479e 125# these look not really useful
96987817 126%{__rm} $RPM_BUILD_ROOT%{_bindir}/altonegen
b5f2479e 127
6a3db3d8 128%clean
129rm -rf $RPM_BUILD_ROOT
130
404a1bc6
JB
131%post -p /sbin/ldconfig
132%postun -p /sbin/ldconfig
133
6a3db3d8 134%files
3f81b215 135%defattr(644,root,root,755)
6ce9e958 136%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
ce19b7ae 137%attr(755,root,root) %{_bindir}/makehrtf
65437b48 138%attr(755,root,root) %{_bindir}/openal-info
a26f1dac 139%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
65437b48 140%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
f2c99d8a 141%{_datadir}/openal
6a3db3d8 142
143%files devel
144%defattr(644,root,root,755)
a26f1dac 145%attr(755,root,root) %{_libdir}/libopenal.so
68071dbf 146%{_includedir}/AL
a26f1dac 147%{_pkgconfigdir}/openal.pc
99cf5ae3 148%{_libdir}/cmake/OpenAL
f2c99d8a
JB
149
150%if %{with gui}
151%files gui
152%defattr(644,root,root,755)
153%attr(755,root,root) %{_bindir}/alsoft-config
154%endif
This page took 1.130976 seconds and 4 git commands to generate.