]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
BR: libmysofa-devel
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
f2c99d8a 3%bcond_without alsa # ALSA backend
b5f2479e 4%bcond_without jack # JACK backend
f2c99d8a
JB
5%bcond_without portaudio # PortAudio backend
6%bcond_without pulseaudio # PulseAudio backend
bd9b58be
JB
7%bcond_with sdl # SDL2 backend
8%bcond_with sse # force use of SSE instructions (x86)
9%bcond_with sse2 # force use of SSE2 instructions (x86)
f2c99d8a 10%bcond_without gui # alsoft-config GUI
99cf5ae3 11%bcond_with qt4 # Qt 4 instead of Qt 5 for GUI
a26f1dac 12#
bd9b58be
JB
13%ifarch pentium3 pentium4
14%define with_sse 1
15%endif
16%ifarch pentium4
17%define with_sse2 1
18%endif
d451b59a 19Summary: Open Audio Library
8be14136 20Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 21Name: OpenAL
996f154d
JP
22Version: 1.20.0
23Release: 1
65437b48 24License: LGPL v2+
68071dbf 25Group: Libraries
bd9b58be 26Source0: http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
996f154d 27# Source0-md5: f6349071db03e48994ea09daa031ef6e
60781cc7 28Patch0: %{name}-pc.patch
827050d4 29URL: http://www.openal.org/
bd9b58be 30%{?with_sdl:BuildRequires: SDL2-devel >= 2}
e62907a5 31%{?with_alsa:BuildRequires: alsa-lib-devel}
99cf5ae3 32BuildRequires: cmake >= 3.0.2
b5f2479e 33%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
2b67cb40 34BuildRequires: libmysofa-devel
996f154d 35BuildRequires: libstdc++-devel >= 6:4.8.1
89d1fa49 36BuildRequires: pkgconfig
7e80d8dd 37%{?with_portaudio:BuildRequires: portaudio-devel}
f953b352 38%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
60652dc3 39BuildRequires: rpmbuild(macros) >= 1.605
f2c99d8a 40%if %{with gui}
99cf5ae3 41%if %{with qt4}
f2c99d8a
JB
42BuildRequires: QtCore-devel >= 4.8.0
43BuildRequires: QtGui-devel >= 4.8.0
44BuildRequires: qt4-build >= 4.8.0
99cf5ae3
JB
45%else
46BuildRequires: Qt5Core-devel >= 5
47BuildRequires: Qt5Gui-devel >= 5
48BuildRequires: Qt5Widgets-devel >= 5
49BuildRequires: qt5-build >= 5
50%endif
f2c99d8a 51%endif
6a3db3d8 52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
6a3db3d8 54%description
55OpenAL, the Open Audio Library, is a joint effort to create an open,
56vendor-neutral, cross-platform API for interactive, primarily
57spatialized audio. OpenAL's primary audience are application
58developers and desktop users that rely on portable standards like
59OpenGL, for games and other multimedia applications. OpenAL is already
60supported by a number of hardware vendors and developers.
61
a4959810
JR
62%description -l pl.UTF-8
63OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
64stworzenia otwartego, niezależnego od producentów, międzyplatformowego
65interfejsu projektowania aplikacji w części obsługi dźwięku.
66Biblioteka adresowana jest do twórców aplikacji i użytkowników,
67którzy wybierają przenośne standardy, jak OpenGL, w grach i
68aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
69dostarczycieli sprzętu i programistów.
d451b59a 70
6a3db3d8 71%package devel
d451b59a 72Summary: Headers for OpenAL
8be14136 73Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 74Group: Development/Libraries
e62907a5 75Requires: %{name} = %{version}-%{release}
6a3db3d8 76
77%description devel
d451b59a 78Header files for OpenAL-based programs.
6a3db3d8 79
a4959810
JR
80%description devel -l pl.UTF-8
81Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 82OpenAL.
83
f2c99d8a
JB
84%package gui
85Summary: OpenAL configuration GUI
86Summary(pl.UTF-8): Graficzny interfejs do konfiguracji biblioteki OpenAL
87Group: X11/Applications/Sound
88Requires: %{name} = %{version}-%{release}
89Requires: QtCore >= 4.8.0
90Requires: QtGui >= 4.8.0
91
92%description gui
93OpenAL configuration GUI.
94
95%description gui -l pl.UTF-8
96Graficzny interfejs do konfiguracji biblioteki OpenAL.
97
6a3db3d8 98%prep
7e80d8dd 99%setup -q -n openal-soft-%{version}
60781cc7 100%patch0 -p1
68071dbf 101
6a3db3d8 102%build
99cf5ae3
JB
103cd build
104%cmake .. \
b5f2479e
JB
105 %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
106 %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
107 %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
99cf5ae3 108 %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
bd9b58be 109 %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
4d244e7b
JP
110 %{!?with_sse:-DALSOFT_CPUEXT_SSE=OFF} \
111 %{!?with_sse2:-DALSOFT_CPUEXT_SSE2=OFF} \
99cf5ae3
JB
112 -DALSOFT_EXAMPLES=OFF \
113 %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
114 %{?with_qt4:-DALSOFT_NO_QT5=ON} \
65437b48 115
7e80d8dd 116%{__make}
6a3db3d8 117
118%install
119rm -rf $RPM_BUILD_ROOT
6ce9e958 120install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
d451b59a 121
99cf5ae3 122%{__make} -C build install \
68071dbf 123 DESTDIR=$RPM_BUILD_ROOT
d451b59a 124
c06f4ed0 125install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
6ce9e958 126
b5f2479e 127# these look not really useful
96987817 128%{__rm} $RPM_BUILD_ROOT%{_bindir}/altonegen
b5f2479e 129
6a3db3d8 130%clean
131rm -rf $RPM_BUILD_ROOT
132
404a1bc6
JB
133%post -p /sbin/ldconfig
134%postun -p /sbin/ldconfig
135
6a3db3d8 136%files
3f81b215 137%defattr(644,root,root,755)
6ce9e958 138%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
996f154d 139%attr(755,root,root) %{_bindir}/makemhr
65437b48 140%attr(755,root,root) %{_bindir}/openal-info
a26f1dac 141%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
65437b48 142%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
f2c99d8a 143%{_datadir}/openal
6a3db3d8 144
145%files devel
146%defattr(644,root,root,755)
a26f1dac 147%attr(755,root,root) %{_libdir}/libopenal.so
68071dbf 148%{_includedir}/AL
a26f1dac 149%{_pkgconfigdir}/openal.pc
99cf5ae3 150%{_libdir}/cmake/OpenAL
f2c99d8a
JB
151
152%if %{with gui}
153%files gui
154%defattr(644,root,root,755)
155%attr(755,root,root) %{_bindir}/alsoft-config
156%endif
This page took 0.096479 seconds and 4 git commands to generate.