]> git.pld-linux.org Git - packages/Collage.git/blame - Collage.spec
- updated to 1.7.0
[packages/Collage.git] / Collage.spec
CommitLineData
262ad267
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
59a55be8 4
262ad267
JB
5Summary: Cross-platform C++ network library
6Summary(pl.UTF-8): Wieloplatformowa biblioteka sieciowa dla C++
7Name: Collage
44e57821 8Version: 1.7.0
ced5b5c1 9Release: 1
262ad267
JB
10License: LGPL v2.1
11Group: Libraries
44e57821 12#Source0Download: https://github.com/Eyescale/Collage/releases
262ad267 13Source0: https://github.com/Eyescale/Collage/archive/%{version}/%{name}-%{version}.tar.gz
44e57821 14# Source0-md5: f0e57c1a2f6196c11ad8ac6029483e56
ced5b5c1 15Patch0: boost-1.61.patch
262ad267 16URL: http://libcollage.net/
44e57821
JB
17BuildRequires: Lunchbox-devel >= 1.16.0
18BuildRequires: Eyescale-CMake >= 2017.05
19BuildRequires: Pression-devel >= 2.0.0
20BuildRequires: Servus-devel >= 1.5.1
262ad267 21BuildRequires: boost-devel >= 1.41.0
44e57821 22BuildRequires: cmake >= 3.1
262ad267
JB
23%{?with_apidocs:BuildRequires: doxygen}
24BuildRequires: libibverbs-devel
25BuildRequires: librdmacm-devel
26BuildRequires: libstdc++-devel
27BuildRequires: pkgconfig
28BuildRequires: udt-devel
44e57821
JB
29Requires: Lunchbox >= 1.16.0
30Requires: Pression >= 2.0.0
31Requires: Servus >= 1.5.1
262ad267
JB
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Collage is a cross-platform C++ library for building heterogenous,
36distributed applications. Among other things, it is the cluster
37backend for the Equalizer parallel rendering framework. Collage
38provides an abstraction of different network connections, peer-to-peer
39messaging, node discovery, synchronization and high-performance,
40object-oriented, versioned data distribution. Collage is designed for
41low-overhead multi-threaded execution which allows applications to
42easily exploit multi-core architectures.
43
44%description -l pl.UTF-8
45Collage to wieloplatformowa biblioteka C++ do tworzenia
46heterogenicznych, rozproszonych aplikacji. Jest to między innymi
47backend klastrowy dla szkieletu równoległego renderowania Equalizer.
48Zapewnia abstrakcję różnych połączeń sieciowych, przesyłania
49komunikatów między węzłami, wykrywanie węzłów, synchronizację oraz
50wydajne, zorientowane obiektowo i wersjonowane rozproszenie danych.
51Collage został zaprojektowany pod kątem lekkiej wielowątkowości, co
52pozwala aplikacjom łatwo wykorzystywać architektury wielordzeniowe.
53
54%package devel
55Summary: Header files for Collage library
56Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Collage
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
44e57821
JB
59Requires: Lunchbox-devel >= 1.16.0
60Requires: Pression-devel >= 2.0.0
61Requires: Servus-devel >= 1.5.1
62Requires: boost-devel >= 1.41.0
262ad267
JB
63
64%description devel
65Header files for Collage library.
66
67%description devel -l pl.UTF-8
68Pliki nagłówkowe biblioteki Collage.
69
70%package apidocs
71Summary: Collage API documentation
72Summary(pl.UTF-8): Dokumentacja API biblioteki Collage
73Group: Documentation
59a55be8
ER
74%if "%{_rpmversion}" >= "5"
75BuildArch: noarch
76%endif
262ad267
JB
77
78%description apidocs
79API documentation for Collage library.
80
81%description apidocs -l pl.UTF-8
82Dokumentacja API biblioteki Collage.
83
84%prep
ced5b5c1
JR
85%setup -q
86%patch0 -p1
262ad267 87
44e57821 88rmdir CMake/common
ced5b5c1 89ln -s %{_datadir}/Eyescale-CMake CMake/common
262ad267
JB
90
91%build
92install -d build
93cd build
94%cmake .. \
95 -DBUILDYARD_DISABLED=ON
96%{__make}
97
98%if %{with apidocs}
99doxygen doc/Doxyfile
100%endif
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105%{__make} -C build install \
106 DESTDIR=$RPM_BUILD_ROOT
107
108%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Collage/{doc,tests}
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(644,root,root,755)
ced5b5c1 118%doc LICENSE.txt README.md doc/{README.IB,README.udt} doc/Changelog.md
262ad267
JB
119%attr(755,root,root) %{_bindir}/coNetperf
120%attr(755,root,root) %{_bindir}/coNodeperf
121%attr(755,root,root) %{_bindir}/coObjectperf
122%attr(755,root,root) %{_libdir}/libCollage.so.*.*.*
44e57821 123%attr(755,root,root) %ghost %{_libdir}/libCollage.so.7
262ad267
JB
124
125%files devel
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_libdir}/libCollage.so
128%{_includedir}/co
262ad267
JB
129%dir %{_datadir}/Collage
130%{_datadir}/Collage/CMake
131
132%if %{with apidocs}
133%files apidocs
134%defattr(644,root,root,755)
135%doc build/doc/html/*
136%endif
This page took 0.231701 seconds and 4 git commands to generate.