]> git.pld-linux.org Git - packages/wayland.git/blob - wayland.spec
- release 3 (libffi 3.4.x)
[packages/wayland.git] / wayland.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't build API documentation
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Wayland - protocol for a compositor to talk to its clients
7 Summary(pl.UTF-8):      Wayland - protokół między serwerem składającym a klientami
8 Name:           wayland
9 Version:        1.21.0
10 Release:        3
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://gitlab.freedesktop.org/wayland/wayland/-/releases/
14 Source0:        https://gitlab.freedesktop.org/wayland/wayland/-/releases/%{version}/downloads/%{name}-%{version}.tar.xz
15 # Source0-md5:  f2653a2293bcd882d756c6a83d278903
16 URL:            https://wayland.freedesktop.org/
17 BuildRequires:  expat-devel >= 1.95
18 BuildRequires:  libffi-devel >= 3
19 # for DTD valudation
20 BuildRequires:  libxml2-devel >= 2.0
21 BuildRequires:  meson >= 0.56.0
22 BuildRequires:  ninja
23 BuildRequires:  pkgconfig
24 %if %{with apidocs}
25 BuildRequires:  docbook-style-xsl-nons
26 BuildRequires:  doxygen >= 1.6.0
27 BuildRequires:  graphviz >= 2.26.0
28 BuildRequires:  libxslt-progs
29 BuildRequires:  rpm-build >= 4.6
30 BuildRequires:  rpmbuild(macros) >= 1.752
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xmlto
33 BuildRequires:  xz
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Wayland is a project to define a protocol for a compositor to talk to
39 its clients as well as a library implementation of the protocol. The
40 compositor can be a standalone display server running on Linux kernel
41 modesetting and evdev input devices, an X application, or a Wayland
42 client itself. The clients can be traditional applications, X servers
43 (rootless or fullscreen) or other display servers.
44
45 %description -l pl.UTF-8
46 Wayland to projekt definiujący protokół między serwerem składającym a
47 klientami, a także biblioteki implementujące ten protokół. Serwer
48 składający może być samodzielnym serwerem wyświetlającym działającym
49 na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
50 aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
51 aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
52 wyświetlające.
53
54 %package devel
55 Summary:        Header files for Wayland libraries
56 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wayland
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libffi-devel
60
61 %description devel
62 Header files for Wayland libraries.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe bibliotek Wayland.
66
67 %package static
68 Summary:        Static Wayland libraries
69 Summary(pl.UTF-8):      Statyczne biblioteki Wayland
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static Wayland libraries.
75
76 %description static -l pl.UTF-8
77 Statyczne biblioteki Wayland.
78
79 %package egl
80 Summary:        Wayland EGL library
81 Summary(pl.UTF-8):      Biblioteka Wayland EGL
82 Group:          Libraries
83 Obsoletes:      Mesa-libwayland-egl < 18.2
84
85 %description egl
86 Wayland EGL library.
87
88 %description egl -l pl.UTF-8
89 Biblioteka Wayland EGL.
90
91 %package egl-devel
92 Summary:        Header files for Wayland EGL library
93 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Wayland EGL
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96 Requires:       %{name}-egl = %{version}-%{release}
97 Obsoletes:      Mesa-libwayland-egl-devel < 18.2
98
99 %description egl-devel
100 Header files for Wayland EGL library.
101
102 %description egl-devel -l pl.UTF-8
103 Pliki nagłówkowe biblioteki Wayland EGL.
104
105 %package egl-static
106 Summary:        Static Wayland EGL library
107 Summary(pl.UTF-8):      Statyczna biblioteka Wayland EGL
108 Group:          Development/Libraries
109 Requires:       %{name}-egl-devel = %{version}-%{release}
110
111 %description egl-static
112 Static Wayland EGL library.
113
114 %description egl-static -l pl.UTF-8
115 Statyczna biblioteka Wayland EGL.
116
117 %package apidocs
118 Summary:        Wayland API and protocol documentation
119 Summary(pl.UTF-8):      Dokumentacja API biblioteki oraz protokołu Wayland
120 Group:          Documentation
121 BuildArch:      noarch
122
123 %description apidocs
124 Wayland API and protocol documentation.
125
126 %description apidocs -l pl.UTF-8
127 Dokumentacja API biblioteki oraz protokołu Wayland.
128
129 %prep
130 %setup -q
131
132 %build
133 %meson build \
134         %{!?with_apidocs:-Ddocumentation=false} \
135         %{!?with_static_libs:--default-library=shared}
136
137 %ninja_build -C build
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %ninja_install -C build
143
144 %if %{with apidocs}
145 # packaged as %doc in -devel
146 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
147 %endif
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %post   egl -p /sbin/ldconfig
156 %postun egl -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc COPYING CONTRIBUTING.md README
161 %attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
163 %attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
165 %attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/wayland-scanner
171 %attr(755,root,root) %{_libdir}/libwayland-client.so
172 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
173 %attr(755,root,root) %{_libdir}/libwayland-server.so
174 %{_includedir}/wayland-client*.h
175 %{_includedir}/wayland-cursor.h
176 %{_includedir}/wayland-server*.h
177 %{_includedir}/wayland-util.h
178 %{_includedir}/wayland-version.h
179 %dir %{_datadir}/wayland
180 %{_datadir}/wayland/wayland.dtd
181 %{_datadir}/wayland/wayland.xml
182 %{_datadir}/wayland/wayland-scanner.mk
183 %{_pkgconfigdir}/wayland-client.pc
184 %{_pkgconfigdir}/wayland-cursor.pc
185 %{_pkgconfigdir}/wayland-scanner.pc
186 %{_pkgconfigdir}/wayland-server.pc
187 %{_aclocaldir}/wayland-scanner.m4
188 %if %{with apidocs}
189 %{_mandir}/man3/wl_*.3*
190 %endif
191 # NOTE: temporarily here because they're used but not included in Mesa 18.1.x
192 # TODO: move to -egl-devel after transition to Mesa 18.2.x
193 %{_includedir}/wayland-egl.h
194 %{_includedir}/wayland-egl-core.h
195
196 %if %{with static_libs}
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/libwayland-client.a
200 %{_libdir}/libwayland-cursor.a
201 %{_libdir}/libwayland-server.a
202 %endif
203
204 %if %{with apidocs}
205 %files apidocs
206 %defattr(644,root,root,755)
207 %doc build/doc/publican/html/* doc/publican/sources/{css,images}
208 %endif
209
210 %files egl
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
213 %attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
214
215 %files egl-devel
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libwayland-egl.so
218 %{_includedir}/wayland-egl-backend.h
219 %{_pkgconfigdir}/wayland-egl.pc
220 %{_pkgconfigdir}/wayland-egl-backend.pc
221
222 %if %{with static_libs}
223 %files egl-static
224 %defattr(644,root,root,755)
225 %{_libdir}/libwayland-egl.a
226 %endif
This page took 0.146025 seconds and 3 git commands to generate.