]> git.pld-linux.org Git - packages/vips.git/blob - vips.spec
5e5ccd07110d8a1abc21cae6a3ef444ffe7365c7
[packages/vips.git] / vips.spec
1 # TODO:
2 # - split -libs (-n libvips)
3 # - python package (-n python-vipsCC)
4 # - gir stuff belongs to what package?
5 Summary:        A fast image processing library with low memory needs
6 Summary(pl.UTF-8):      Biblioteka przetwarzania obrazów
7 Name:           vips
8 Version:        8.5.9
9 Release:        3
10 License:        LGPL
11 Group:          Libraries
12 Source0:        https://github.com/jcupitt/libvips/releases/download/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  b8639ec0b05dfa17deca50007895963a
14 URL:            http://jcupitt.github.io/libvips/
15 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  bzip2-devel
19 BuildRequires:  fftw3-devel >= 3.0.0
20 BuildRequires:  glib2-devel >= 2.4.0
21 BuildRequires:  imlib-devel
22 BuildRequires:  intltool
23 BuildRequires:  lcms-devel
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libltdl-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel
31 BuildRequires:  pango-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(find_lang) >= 1.32
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 BuildRequires:  zlib-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 libvips is a demand-driven, horizontally threaded image processing
41 library. Compared to similar libraries, libvips runs quickly and uses
42 little memory.
43
44 It has around 300 operations covering arithmetic, histograms,
45 convolution, morphological operations, frequency filtering, colour,
46 resampling, statistics and others. It supports a large range of
47 numeric formats, from 8-bit int to 128-bit complex. Images can have
48 any number of bands. It supports a good range of image formats,
49 including JPEG, TIFF, OME-TIFF, PNG, WebP, FITS, Matlab, OpenEXR, PDF,
50 SVG, HDR, PPM, CSV, GIF, Analyze, DeepZoom, and OpenSlide. It can also
51 load images via ImageMagick or GraphicsMagick, letting it load formats
52 like DICOM.
53
54 %description -l pl.UTF-8
55 VIPS jest biblioteką przetwarzania obrazów. Jest dobra dla bardzo
56 dużych obrazów (to znaczy większych niż ilość RAM w komputerze), oraz
57 do pracy z kolorami. Zawiera API w C++, kompletne strony pomocy man,
58 interfejs linii poleceń, automatyczne wątkowanie i bazę danych
59 operacji. Jest kilka interfejsów użytkownika zbudowanych na podstawie
60 VIPS, na przykład "nip".
61
62 %package devel
63 Summary:        Header files for vips library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vips
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description devel
69 Header files for vips library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki vips.
73
74 %package static
75 Summary:        Static vips library
76 Summary(pl.UTF-8):      Statyczna biblioteka vips
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static vips library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka vips.
85
86 %prep
87 %setup -q
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvips-cpp.la
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvips.la
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvipsCC.la
107 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/vipsCC/*.la
108 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/vipsCC/*.a
109
110 rm -r $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/libvips
111
112 %py_postclean
113
114 %find_lang vips8.5 -o %{name}.lang
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files -f %{name}.lang
123 %defattr(644,root,root,755)
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS THANKS TODO
126 %attr(755,root,root) %{_bindir}/batch_crop
127 %attr(755,root,root) %{_bindir}/batch_image_convert
128 %attr(755,root,root) %{_bindir}/batch_rubber_sheet
129 %attr(755,root,root) %{_bindir}/light_correct
130 %attr(755,root,root) %{_bindir}/shrink_width
131 %attr(755,root,root) %{_bindir}/vips
132 %attr(755,root,root) %{_bindir}/vips-8.5
133 %attr(755,root,root) %{_bindir}/vipsedit
134 %attr(755,root,root) %{_bindir}/vipsheader
135 %attr(755,root,root) %{_bindir}/vipsprofile
136 %attr(755,root,root) %{_bindir}/vipsthumbnail
137 %attr(755,root,root) %{_libdir}/libvips-cpp.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libvips-cpp.so.42
139 %attr(755,root,root) %{_libdir}/libvips.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libvips.so.42
141 %attr(755,root,root) %{_libdir}/libvipsCC.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libvipsCC.so.42
143 %{_libdir}/girepository-1.0/Vips-8.0.typelib
144 %{_datadir}/gir-1.0/Vips-8.0.gir
145 %{_mandir}/man1/batch_crop.1*
146 %{_mandir}/man1/batch_image_convert.1*
147 %{_mandir}/man1/batch_rubber_sheet.1*
148 %{_mandir}/man1/light_correct.1*
149 %{_mandir}/man1/vips.1*
150 %{_mandir}/man1/vipsedit.1*
151 %{_mandir}/man1/vipsheader.1*
152 %{_mandir}/man1/vipsprofile.1*
153 %{_mandir}/man1/vipsthumbnail.1*
154
155 %dir %{py_sitedir}/vipsCC
156 %{py_sitedir}/vipsCC/*.py[co]
157 %attr(755,root,root) %{py_sitedir}/vipsCC/vdisplaymodule.so
158 %attr(755,root,root) %{py_sitedir}/vipsCC/verrormodule.so
159 %attr(755,root,root) %{py_sitedir}/vipsCC/vimagemodule.so
160 %attr(755,root,root) %{py_sitedir}/vipsCC/vmaskmodule.so
161 %{py_sitedir}/gi/overrides/Vips.py[co]
162
163 %files devel
164 %defattr(644,root,root,755)
165 %{_libdir}/libvips-cpp.so
166 %{_libdir}/libvips.so
167 %{_libdir}/libvipsCC.so
168 %{_includedir}/vips
169 %{_pkgconfigdir}/vips-cpp.pc
170 %{_pkgconfigdir}/vips.pc
171 %{_pkgconfigdir}/vipsCC.pc
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libvips-cpp.a
176 %{_libdir}/libvips.a
177 %{_libdir}/libvipsCC.a
This page took 0.091433 seconds and 2 git commands to generate.