]> git.pld-linux.org Git - packages/valgrind.git/commitdiff
up to 3.17.0 auto/th/valgrind-3.17.0-1
authorJan Palus <atler@pld-linux.org>
Fri, 9 Apr 2021 15:55:03 +0000 (17:55 +0200)
committerJan Palus <atler@pld-linux.org>
Fri, 9 Apr 2021 15:55:03 +0000 (17:55 +0200)
valgrind-datadir.patch
valgrind-native-cpuid.patch
valgrind.spec

index 48e95270c41956483f246156528da6b99e07d40d..686cb77524699fae1a8d7bdae9a052167de2fd93 100644 (file)
@@ -1,7 +1,7 @@
 --- valgrind-3.15.0/dhat/Makefile.am.orig      2019-04-13 12:56:21.000000000 +0200
 +++ valgrind-3.15.0/dhat/Makefile.am   2019-06-08 21:33:09.268983176 +0200
 @@ -9,7 +9,7 @@
- #----------------------------------------------------------------------------
+       dhat.h
  
  # Ensure the viewer components get copied into the install tree.
 -dhatdir = $(pkglibexecdir)
index 8994509addfa8edc3b44b472365b2ef90d897fd5..485c85daee84014abc3390064d24def2a7031068 100644 (file)
@@ -2,24 +2,24 @@ diff -uNr valgrind-3.6.0.orig/coregrind/m_main.c valgrind-3.6.0/coregrind/m_main
 --- valgrind-3.6.0.orig/coregrind/m_main.c     2010-10-20 22:19:45.000000000 +0200
 +++ valgrind-3.6.0/coregrind/m_main.c  2011-01-17 20:38:26.676472616 +0100
 @@ -519,6 +519,8 @@
-                        VG_(clo_vex_control).guest_chase_thresh, 0, 99) {}
-       else if VG_BOOL_CLO(arg, "--vex-guest-chase-cond",
-                        VG_(clo_vex_control).guest_chase_cond) {}
+                        VG_(clo_vex_control).guest_max_insns, 1, 100) {}
+    else if VG_BOOL_CLO(arg, "--vex-guest-chase",
+                        VG_(clo_vex_control).guest_chase) {}
 +      else if VG_BOOL_CLO(arg, "--vex-native-cpuid",
 +                       VG_(clo_vex_control).iropt_native_cpuid) {}
  
-       else if VG_INT_CLO(arg, "--log-fd", tmp_log_fd) {
-          log_to = VgLogTo_Fd;
+    else if VG_INT_CLO(arg, "--log-fd", pos->tmp_log_fd) {
+       pos->log_to = VgLogTo_Fd;
 --- valgrind-3.11.0/VEX/priv/guest_amd64_defs.h.orig   2015-11-15 19:07:11.062949101 +0100
 +++ valgrind-3.11.0/VEX/priv/guest_amd64_defs.h        2015-11-15 19:09:09.992944110 +0100
 @@ -170,6 +170,7 @@ extern void  amd64g_dirtyhelper_CPUID_ss
- extern void  amd64g_dirtyhelper_CPUID_avx_and_cx16 ( VexGuestAMD64State* st );
extern void  amd64g_dirtyhelper_CPUID_avx2 ( VexGuestAMD64State* st,
-                                              ULong hasF16C, ULong hasRDRAND );
+ extern void amd64g_dirtyhelper_CPUID_avx2 ( VexGuestAMD64State* st,
                                            ULong hasF16C, ULong hasRDRAND,
+                                             ULong hasRDSEED );
 +extern void  amd64g_dirtyhelper_CPUID_native ( VexGuestAMD64State* st );
  
- extern void  amd64g_dirtyhelper_FINIT ( VexGuestAMD64State* );
  
+ extern void  amd64g_dirtyhelper_FINIT ( VexGuestAMD64State* );
 diff -uNr valgrind-3.6.0.orig/VEX/priv/guest_amd64_helpers.c valgrind-3.6.0/VEX/priv/guest_amd64_helpers.c
 --- valgrind-3.6.0.orig/VEX/priv/guest_amd64_helpers.c 2010-10-20 22:19:51.000000000 +0200
 +++ valgrind-3.6.0/VEX/priv/guest_amd64_helpers.c      2011-01-17 20:36:00.884903903 +0100
@@ -41,9 +41,9 @@ diff -uNr valgrind-3.6.0.orig/VEX/priv/guest_amd64_helpers.c valgrind-3.6.0/VEX/
 +}
 +
 +
- ULong amd64g_calculate_RCR ( ULong arg, 
-                              ULong rot_amt, 
-                              ULong rflags_in, 
+ /*---------------------------------------------------------------*/
+ /*--- Misc integer helpers, including rotates and crypto.     ---*/
+ /*---------------------------------------------------------------*/
 --- valgrind-3.11.0/VEX/priv/guest_amd64_toIR.c.orig   2015-11-15 19:07:11.129615765 +0100
 +++ valgrind-3.11.0/VEX/priv/guest_amd64_toIR.c        2015-11-15 19:13:47.379599136 +0100
 @@ -21920,6 +21920,10 @@
@@ -56,7 +56,7 @@ diff -uNr valgrind-3.6.0.orig/VEX/priv/guest_amd64_helpers.c valgrind-3.6.0/VEX/
 +      } else
        /* This isn't entirely correct, CPUID should depend on the VEX
           capabilities, not on the underlying CPU. See bug #324882. */
-       if ((archinfo->hwcaps & VEX_HWCAPS_AMD64_SSE3) &&
+       if ((archinfo->hwcaps & VEX_HWCAPS_AMD64_SSSE3) &&
 --- valgrind-3.14.0/VEX/pub/libvex.h~  2018-10-12 20:12:49.000000000 +0200
 +++ valgrind-3.14.0/VEX/pub/libvex.h   2018-10-12 20:13:55.990940300 +0200
 @@ -519,6 +519,8 @@ typedef
index 9177079cbe21f9066a7fb598c9fee223c293820c..159cb89e6a43b13203bbb600b8f96c4eaad3cc2d 100644 (file)
@@ -7,12 +7,12 @@
 Summary:       An open-source memory debugger
 Summary(pl.UTF-8):     Otwarty odpluskwiacz pamiÄ™ci
 Name:          valgrind
-Version:       3.15.0
+Version:       3.17.0
 Release:       1
 License:       GPL v2+
 Group:         Development/Tools
 Source0:       https://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
-# Source0-md5: 46e5fbdcbc3502a5976a317a0860a975
+# Source0-md5: afe11b5572c3121a781433b7c0ab741b
 Patch0:                %{name}-native-cpuid.patch
 Patch1:                %{name}-ld_linux_strlen.patch
 Patch2:                %{name}-datadir.patch
@@ -73,7 +73,7 @@ ac_cv_path_GDB=/usr/bin/gdb \
        CC=gcc \
        --enable-tls \
        %{!?with_mpi:--with-mpicc=/bin/false} \
-%if %{_lib} != "lib"
+%if "%{_lib}" != "lib"
        --enable-only64bit \
 %endif \
        --enable-lto=yes \
@@ -109,15 +109,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/valgrind-listener
 %attr(755,root,root) %{_bindir}/vgdb
 %dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/*-linux
-%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
+%{_libdir}/%{name}/lib*-linux.a
 %if %{with mpi}
 # TODO: subpackage?
 %attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
 %endif
-%{_libdir}/%{name}/*.xml
-%{_libdir}/%{name}/default.supp
-%{_libdir}/%{name}/lib*-linux.a
+%dir %{_libexecdir}/%{name}
+%attr(755,root,root) %{_libexecdir}/%{name}/*-linux
+%attr(755,root,root) %{_libexecdir}/%{name}/vgpreload_*-linux.so
+%{_libexecdir}/%{name}/*.xml
+%{_libexecdir}/%{name}/default.supp
 %{_datadir}/%{name}
 %{_includedir}/valgrind
 %{_mandir}/man1/callgrind_annotate.1*
This page took 0.6491 seconds and 4 git commands to generate.