]> git.pld-linux.org Git - packages/v8.git/blob - v8.spec
4c915347fb6f296a6f79061acfaac78b15713bea
[packages/v8.git] / v8.spec
1 # NOTES
2 # - see this page for deciding switching branch: http://upstream-tracker.org/versions/v8.html
3 # TODO
4 # - readline not working in d8 (at least arrows)
5 #
6 # Conditional build:
7 %bcond_without  verbose                 # verbose build (V=1)
8
9 Summary:        JavaScript Engine by Google
10 Summary(pl.UTF-8):      Silnik JavaScript firmy Google
11 Name:           v8
12 Version:        3.15.11.18
13 Release:        2
14 License:        BSD
15 Group:          Development/Languages
16 # Source0Download: http://gsdview.appspot.com/chromium-browser-official/?marker=v8-3.15.11.17.tar.bz2
17 #Source0:       http://commondatastorage.googleapis.com/chromium-browser-official/%{name}-%{version}.tar.bz2
18 Source0:        %{name}-%{version}.tar.bz2
19 # Source0-md5:  a08c74de1f8d71d309077cb7a640583f
20 Patch0:         %{name}-cstdio.patch
21 Patch1:         %{name}-strndup.patch
22 Patch3:         %{name}-dynlink.patch
23 Patch4:         abort-uncaught-exception.patch
24 URL:            https://code.google.com/p/v8/
25 BuildRequires:  gyp
26 BuildRequires:  libstdc++-devel >= 5:4.0
27 BuildRequires:  python >= 1:2.5
28 BuildRequires:  readline-devel
29 BuildRequires:  sed >= 4.0
30 Requires:       %{name}-libs = %{version}-%{release}
31 ExclusiveArch:  %{ix86} %{x8664} arm mips
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         sover   %(echo %{version} | cut -d. -f1-2)
35
36 %description
37 V8 is Google's open source JavaScript engine. V8 is written in C++ and
38 is used in Google Chrome, the open source browser from Google. V8
39 implements ECMAScript as specified in ECMA-262, 3rd edition.
40
41 This package contains the V8 developer shell.
42
43 %description -l pl.UTF-8
44 V8 to mający otwarte źródła silnik JavaScriptu firmy Google. V8 jest
45 napisany w C++ i wykorzystywany w mającej otwarte źródła przeglądarce
46 Google Chrome. V8 implementuje ECMAScript zgodnie ze specyfikacją
47 ECMA-262, edycja 3.
48
49 Ten pakiet zawiera powłokę programistyczną V8.
50
51 %package libs
52 Summary:        V8 JavaScript Engine shared library
53 Summary(pl.UTF-8):      Biblioteka współdzielona silnika JavaScriptu V8
54 Group:          Libraries
55 Conflicts:      v8 < 2.0.0
56
57 %description libs
58 V8 is Google's open source JavaScript engine. V8 is written in C++ and
59 is used in Google Chrome, the open source browser from Google. V8
60 implements ECMAScript as specified in ECMA-262, 3rd edition.
61
62 This package contains the shared library.
63
64 %description libs -l pl.UTF-8
65 V8 to mający otwarte źródła silnik JavaScriptu firmy Google. V8 jest
66 napisany w C++ i wykorzystywany w mającej otwarte źródła przeglądarce
67 Google Chrome. V8 implementuje ECMAScript zgodnie ze specyfikacją
68 ECMA-262, edycja 3.
69
70 Ten pakiet zawiera bibliotekę współdzieloną.
71
72 %package devel
73 Summary:        Development headers for V8 JavaScript engine
74 Summary(pl.UTF-8):      Pliki nagłówkowe silnika JavaScriptu V8
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       libstdc++-devel
78
79 %description devel
80 Development headers for V8 JavaScript engine.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe silnika JavaScriptu V8.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch3 -p1
90 %patch4 -p1
91
92 install -d build/gyp
93 ln -s %{_bindir}/gyp build/gyp/gyp
94
95 %build
96 # -Wno-unused-local-typedefs is gcc 4.8 workaround: http://code.google.com/p/v8/issues/detail?id=2149
97 %{__make} -r native \
98         component=shared_library \
99         soname_version=%{sover} \
100         console=readline \
101         CC="%{__cc}" \
102         CXX="%{__cxx}" \
103         LINK="%{__cxx} -fuse-ld=gold" \
104         CFLAGS="%{rpmcflags}" \
105         CXXFLAGS="%{rpmcxxflags} -Wno-unused-local-typedefs" \
106         LDFLAGS="%{rpmldflags}" \
107         %{?with_verbose:V=1}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
112
113 install -p out/native/lib.target/libv8.so.%{sover} $RPM_BUILD_ROOT%{_libdir}/libv8.so.%{version}
114 ln -sf libv8.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libv8.so.%{sover}
115 ln -sf libv8.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libv8.so
116 cp -p include/*.h $RPM_BUILD_ROOT%{_includedir}
117
118 install -p out/native/d8 $RPM_BUILD_ROOT%{_bindir}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   libs -p /sbin/ldconfig
124 %postun libs -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog LICENSE LICENSE.strongtalk LICENSE.valgrind
129 %attr(755,root,root) %{_bindir}/d8
130
131 %files libs
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libv8.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libv8.so.%{sover}
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libv8.so
139 %{_includedir}/v8*.h
This page took 0.074101 seconds and 2 git commands to generate.