]> git.pld-linux.org Git - packages/twinkle.git/commitdiff
- libilbc is gone, partial webrtc-libilbc support
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 25 Nov 2012 12:48:22 +0000 (13:48 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 25 Nov 2012 12:48:22 +0000 (13:48 +0100)
twinkle-ilbc.patch [new file with mode: 0644]
twinkle.spec

diff --git a/twinkle-ilbc.patch b/twinkle-ilbc.patch
new file mode 100644 (file)
index 0000000..0566cf7
--- /dev/null
@@ -0,0 +1,69 @@
+--- twinkle-1.4.2/configure.in.org     2012-11-25 13:35:52.700436829 +0100
++++ twinkle-1.4.2/configure.in 2012-11-25 13:36:12.737587289 +0100
+@@ -247,15 +247,18 @@
+ # iLBC
+ if test "x$ac_cv_ilbc" = "xyes"
+ then
+-      AC_CHECK_LIB(ilbc, iLBC_decode, [
+-              AC_CHECK_HEADER(ilbc/iLBC_define.h, [],
+-                      [AC_MSG_ERROR([ilbc header files missing])])
++      saved_LIBS="$LIBS"
++      LIBS="$LIBS -lilbc"
++      AC_LINK_IFELSE([
++                   #include <stdio.h>
++                   #include <ilbc.h>
++                   int main() { iLBC_decode(NULL, NULL, NULL, 0); return 0; } ], [
+               AC_DEFINE(HAVE_ILBC, 1, [Define to 1 if you have the <ilbc> library.])
+               LIBS="-lilbc $LIBS"
+               echo "LIBS += -lilbc" >> $QT_INCL_PRO
+               have_ilbc="yes"
+               ], [have_ilbc="no"])
+-              
++      LIBS="$saved_LIBS"
+       if test "x$ac_cv_ilbc_cpp" = "xyes"
+       then
+               AC_DEFINE(HAVE_ILBC_CPP, 1, [Define to 1 if you have a C++ ilbc library.])
+--- twinkle-1.4.2/src/audio/audio_encoder.h~   2012-11-25 13:36:19.687755088 +0100
++++ twinkle-1.4.2/src/audio/audio_encoder.h    2012-11-25 13:37:58.863482959 +0100
+@@ -39,7 +39,7 @@
+ #ifndef HAVE_ILBC_CPP
+ extern "C" {
+ #endif
+-#include <ilbc/iLBC_define.h>
++#include <ilbc.h>
+ #ifndef HAVE_ILBC_CPP
+ }
+ #endif
+--- twinkle-1.4.2/src/audio/audio_decoder.h~   2012-11-25 13:36:19.687755088 +0100
++++ twinkle-1.4.2/src/audio/audio_decoder.h    2012-11-25 13:38:12.730484432 +0100
+@@ -40,7 +40,7 @@
+ #ifndef HAVE_ILBC_CPP
+ extern "C" {
+ #endif
+-#include <ilbc/iLBC_define.h>
++#include <ilbc.h>
+ #ifndef HAVE_ILBC_CPP
+ }
+ #endif
+--- twinkle-1.4.2/src/audio/audio_encoder.cpp~ 2009-01-18 15:13:46.000000000 +0100
++++ twinkle-1.4.2/src/audio/audio_encoder.cpp  2012-11-25 13:39:31.529053658 +0100
+@@ -24,7 +24,7 @@
+ #ifndef HAVE_ILBC_CPP
+ extern "C" {
+ #endif
+-#include <ilbc/iLBC_encode.h>
++#include <ilbc.h>
+ #ifndef HAVE_ILBC_CPP
+ }
+ #endif
+--- twinkle-1.4.2/src/audio/audio_decoder.cpp~ 2009-01-18 14:38:00.000000000 +0100
++++ twinkle-1.4.2/src/audio/audio_decoder.cpp  2012-11-25 13:39:48.622799700 +0100
+@@ -25,7 +25,7 @@
+ #ifndef HAVE_ILBC_CPP
+ extern "C" {
+ #endif
+-#include <ilbc/iLBC_decode.h>
++#include <ilbc.h>
+ #ifndef HAVE_ILBC_CPP
+ }
+ #endif
index d9e1cb0e71aff5120b047822cad8fdacde13c654..62c07ab5e09bebf345e497febccfb20b73ff69d2 100644 (file)
@@ -6,7 +6,7 @@ Summary:        twinkle - SIP Soft Phone
 Summary(pl.UTF-8):     twinkle - telefon programowy SIP
 Name:          twinkle
 Version:       1.4.2
-Release:       15
+Release:       16.1
 License:       GPL v2
 Group:         Applications/Communications
 Source0:       http://www.xs4all.nl/~mfnboer/twinkle/download/%{name}-%{version}.tar.gz
@@ -15,6 +15,7 @@ Source1:      %{name}.desktop
 Patch0:                %{name}-nobind.patch
 Patch1:                %{name}-build.patch
 Patch2:                %{name}-ucommon.patch
+Patch3:                %{name}-ilbc.patch
 URL:           http://www.twinklephone.com/
 BuildRequires: alsa-lib-devel
 BuildRequires: autoconf
@@ -24,7 +25,7 @@ BuildRequires:        ccrtp-devel >= 2.0.0
 BuildRequires: commoncpp2-devel >= 1.7.1
 %{?with_kde:BuildRequires:     kdelibs-devel}
 BuildRequires: libgsm-devel >= 1.0.11
-BuildRequires: libilbc-devel
+BuildRequires: webrtc-libilbc-devel
 BuildRequires: libmagic-devel
 BuildRequires: libsndfile-devel
 BuildRequires: libtool
@@ -51,6 +52,7 @@ telefonicznych po sieciach IP.
 %patch0 -p1
 %patch1 -p0
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
This page took 0.045505 seconds and 4 git commands to generate.