]> git.pld-linux.org Git - packages/ttembed.git/blob - ttembed.spec
new, version 1.1
[packages/ttembed.git] / ttembed.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        Remove embedding limitations from TrueType fonts
6 Name:           ttembed
7 Version:        1.1
8 Release:        1
9 License:        Public Domain
10 Group:          Applications
11 Source0:        https://github.com/hisdeedsaredust/ttembed/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  1eccad30e260d4ccd2a1f8a9b1a165ce
13 URL:            https://github.com/hisdeedsaredust/ttembed
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Remove embedding limitations from TrueType fonts, by setting the
18 fsType field in the OS/2 table to zero. That's it; this program is a
19 one-trick pony.
20
21 %prep
22 %setup -q
23
24 %build
25 CFLAGS="%{rpmcflags}" \
26 %{__make}
27
28 %if %{with tests}
29 # smoke test - fail on not font file
30 echo 'not a font' > test
31 if [ "$(./ttembed test 2>&1)" != "test: Not TTF/OTF" ]; then
32         echo "TEST FAIL: not a font input test" 1>&2
33         exit 1
34 fi
35 rm test
36 %endif
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
41 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
42 cp -p %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc LICENSE README.md
50 %{_bindir}/ttembed
51 %{_mandir}/man1/ttembed.1*
This page took 0.08211 seconds and 3 git commands to generate.