]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
a34fbdc86fbdf484d8ec5db223338cc209e21afd
[packages/swig.git] / swig.spec
1 #
2 # Conditional build:
3 %bcond_without  guile   # disable guile support
4 %bcond_without  ocaml   # disable ocaml support
5 %bcond_without  octave  # disable octave support
6 %bcond_without  perl    # disable perl support
7 %bcond_without  php     # disable php support
8 %bcond_without  ruby    # disable ruby support
9 %bcond_without  tcl     # disable tcl support
10 #
11 Summary:        Interface generator for Perl, Tcl, Guile and Python
12 Summary(pl.UTF-8):      Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
13 Summary(pt_BR.UTF-8):   Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
14 Name:           swig
15 Version:        2.0.0
16 Release:        1
17 License:        GPL v3+ (utility), free (library)
18 Group:          Development/Languages
19 Source0:        http://downloads.sourceforge.net/swig/%{name}-%{version}.tar.gz
20 # Source0-md5:  36ee2d9974be46a9f0a36460af928eb9
21 Patch0:         %{name}-php-freearg.patch
22 URL:            http://www.swig.org/
23 BuildRequires:  autoconf >= 2.58
24 BuildRequires:  automake >= 1:1.7.2
25 %{?with_guile:BuildRequires:    guile-devel}
26 BuildRequires:  libstdc++-devel
27 %{?with_ocaml:BuildRequires:    ocaml}
28 %{?with_octave:BuildRequires:   octave-devel}
29 %{?with_perl:BuildRequires:     perl-devel >= 1:5.6.1}
30 %{?with_php:BuildRequires:      php-cli}
31 %{?with_php:BuildRequires:      php-devel >= 4.1.0}
32 BuildRequires:  python-devel >= 1:2.3.2
33 BuildRequires:  python-modules
34 BuildRequires:  rpm-pythonprov
35 %if %{with ruby}
36 BuildRequires:  rpmbuild(macros) >= 1.277
37 BuildRequires:  ruby-devel >= 1:1.6.3
38 %endif
39 %{?with_tcl:BuildRequires:      tcl-devel >= 8.3.3}
40 Obsoletes:      swig-ocaml
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 SWIG is a compiler that attempts to make it easy to integrate C, C++,
45 or Objective-C code with scripting languages including Perl, Tcl, and
46 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
47 and it generates an interface between C and your favorite scripting
48 language. However, this is only scratching the surface of what SWIG
49 can do--some of its more advanced features include automatic
50 documentation generation, module and library management, extensive
51 customization options, and more.
52
53 SWIG is entirely the product of users who have used the system and
54 suggested new idea. There are far too many people to thank
55 individually, but without this support, SWIG would be not be nearly as
56 powerful or fun to use as it is now. Many thanks!
57
58 %description -l pl.UTF-8
59 SWIG jesk kompilatorem, który próbuje ułatwić integrowanie kodu
60 napisanego w C, C++ lub Objective-C z językami skryptowymi, takimi jak
61 Perl, Tcl i Python. Mówiąc najprościej, jeśli dostarczysz mu zestaw
62 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
63 pomiędzy C a Twoim ulubionym językiem skryptowym. To tylko drobna
64 część tego co SWIG potrafi robić, bardziej zaawansowane zastosowania
65 to automatyczne generowanie dokumentacji, zarządzanie bibliotekami i
66 modułami i wiele innych.
67
68 SWIG jest w całości dziełem ludzi, którzy go używali i wprowadzali
69 nowe pomysły. Zbyt wielu ich jest, aby dziękować każdemu z nich
70 osobno, ale bez ich wsparcia SWIG nie byłby ani tak potężnym
71 narzędziem, ani tak fajnym w użyciu jak jest teraz. Wiekie dzięki!
72
73 %description -l pt_BR.UTF-8
74 O SWIG gera interfaces para perl, python e Tcl a partir de uma arquivo
75 com uma interface de descrição que consiste de uma combinação de C/C++
76 e diretivas especiais. Permite que linguagens tipo script usem C/C++
77 com um mínimo de esforço.
78
79 %package guile
80 Summary:        SWIG library: guile
81 Summary(pl.UTF-8):      Biblioteka SWIG: guile
82 License:        free
83 Group:          Libraries
84 Requires:       %{name} = %{version}-%{release}
85
86 %description guile
87 SWIG library: guile.
88
89 %description guile -l pl.UTF-8
90 Biblioteka SWIG: guile.
91
92 %package perl
93 Summary:        SWIG library: Perl
94 Summary(pl.UTF-8):      Biblioteka SWIG: Perl
95 License:        free
96 Group:          Libraries
97 Requires:       %{name} = %{version}-%{release}
98
99 %description perl
100 SWIG library: perl.
101
102 %description perl -l pl.UTF-8
103 Biblioteka SWIG: perl.
104
105 %package php
106 Summary:        SWIG library: php
107 Summary(pl.UTF-8):      Biblioteka SWIG: php
108 License:        free
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description php
113 SWIG library: php.
114
115 %description php -l pl.UTF-8
116 Biblioteka SWIG: php.
117
118 %package python
119 Summary:        SWIG library: python
120 Summary(pl.UTF-8):      Biblioteka SWIG: python
121 License:        free
122 Group:          Libraries
123 Requires:       %{name} = %{version}-%{release}
124
125 %description python
126 SWIG library: python.
127
128 %description python -l pl.UTF-8
129 Biblioteka SWIG: python.
130
131 %package ruby
132 Summary:        SWIG library: ruby
133 Summary(pl.UTF-8):      Biblioteka SWIG: ruby
134 License:        free
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137 %{?ruby_mod_ver_requires_eq}
138
139 %description ruby
140 SWIG library: ruby.
141
142 %description ruby -l pl.UTF-8
143 Biblioteka SWIG: ruby.
144
145 %package tcl
146 Summary:        SWIG library: tcl
147 Summary(pl.UTF-8):      Biblioteka SWIG: tcl
148 License:        free
149 Group:          Libraries
150 Requires:       %{name} = %{version}-%{release}
151
152 %description tcl
153 SWIG library: tcl.
154
155 %description tcl -l pl.UTF-8
156 Biblioteka SWIG: tcl.
157
158 %prep
159 %setup -q
160 %patch0 -p1
161
162 %build
163 %{__aclocal} -I Tools/config
164 %{__autoconf}
165 %{__automake}
166 %configure
167
168 %{__make} \
169         OPT="%{rpmcflags}"
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
174
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT \
177         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
178
179 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %doc ANNOUNCE CHANGES CHANGES.current COPYRIGHT LICENSE LICENSE-UNIVERSITIES README RELEASENOTES TODO Doc
187 %attr(755,root,root) %{_bindir}/ccache-swig
188 %attr(755,root,root) %{_bindir}/swig
189 %{_datadir}/%{name}
190 %{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
191 %{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
192 %{?with_php:%exclude %{_datadir}/%{name}/%{version}/php}
193 %exclude %{_datadir}/%{name}/%{version}/python
194 %{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
195 %{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
196 %{_mandir}/man1/ccache-swig.1*
197 %{_examplesdir}/%{name}-%{version}
198
199 %if %{with guile}
200 %files guile
201 %defattr(644,root,root,755)
202 %{_datadir}/%{name}/%{version}/guile
203 %endif
204
205 %if %{with perl}
206 %files perl
207 %defattr(644,root,root,755)
208 %{_datadir}/%{name}/%{version}/perl5
209 %endif
210
211 %if %{with php}
212 %files php
213 %defattr(644,root,root,755)
214 %{_datadir}/%{name}/%{version}/php
215 %endif
216
217 %files python
218 %defattr(644,root,root,755)
219 %{_datadir}/%{name}/%{version}/python
220
221 %if %{with ruby}
222 %files ruby
223 %defattr(644,root,root,755)
224 %{_datadir}/%{name}/%{version}/ruby
225 %endif
226
227 %if %{with tcl}
228 %files tcl
229 %defattr(644,root,root,755)
230 %{_datadir}/%{name}/%{version}/tcl
231 %endif
This page took 0.059772 seconds and 2 git commands to generate.