]> git.pld-linux.org Git - packages/sway.git/blob - sway.spec
correct bash-completion/systemd epochs
[packages/sway.git] / sway.spec
1 Summary:        i3-compatible Wayland compositor
2 Name:           sway
3 Version:        1.8
4 Release:        1
5 License:        MIT
6 Group:          Applications
7 Source0:        https://github.com/swaywm/sway/releases/download/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  3d3aa8b01f0446ab42a0bb36b37eb08f
9 Patch0:         x32.patch
10 URL:            https://swaywm.org/
11 BuildRequires:  OpenGLESv2-devel
12 BuildRequires:  bash-completion
13 BuildRequires:  cairo-devel
14 BuildRequires:  gdk-pixbuf2-devel
15 BuildRequires:  json-c-devel >= 0.13
16 BuildRequires:  libdrm-devel
17 BuildRequires:  libevdev-devel
18 BuildRequires:  libinput-devel >= 1.21.0
19 BuildRequires:  libxcb-devel
20 BuildRequires:  meson >= 0.60.0
21 BuildRequires:  ninja
22 BuildRequires:  pango-devel
23 BuildRequires:  pcre2-8-devel
24 BuildRequires:  pixman-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpm-build >= 4.6
27 BuildRequires:  rpmbuild(macros) >= 1.752
28 BuildRequires:  scdoc >= 1.9.2
29 BuildRequires:  systemd-devel >= 1:239
30 BuildRequires:  udev-devel
31 BuildRequires:  wayland-devel >= 1.21.0
32 BuildRequires:  wayland-protocols >= 1.24
33 BuildRequires:  wlroots-devel >= 0.16.0
34 BuildRequires:  xcb-util-wm-devel
35 BuildRequires:  xorg-lib-libxkbcommon-devel
36 Requires:       json-c >= 0.13
37 Requires:       libinput >= 1.21.0
38 Requires:       systemd-libs >= 1:239
39 Requires:       wayland >= 1.21.0
40 Requires:       wlroots >= 0.16.0
41 Suggests:       xorg-xserver-Xwayland
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Sway is a tiling Wayland compositor and a drop-in replacement for the
46 i3 window manager for X11. It works with your existing i3
47 configuration and supports most of i3's features, plus a few extras.
48
49 Sway allows you to arrange your application windows logically, rather
50 than spatially. Windows are arranged into a grid by default which
51 maximizes the efficiency of your screen and can be quickly manipulated
52 using only the keyboard.
53
54 %package backgrounds
55 Summary:        Background images for sway compositor
56 Group:          Themes
57 Requires:       %{name} = %{version}-%{release}
58 BuildArch:      noarch
59
60 %description backgrounds
61 Background images for sway compositor.
62
63 %package -n bash-completion-sway
64 Summary:        Bash completion for sway
65 Group:          Applications/Shells
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       bash-completion >= 1:2.0
68 BuildArch:      noarch
69
70 %description -n bash-completion-sway
71 Bash completion for sway.
72
73 %package -n fish-completion-sway
74 Summary:        fish-completion for sway
75 Group:          Applications/Shells
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       fish
78 BuildArch:      noarch
79
80 %description -n fish-completion-sway
81 fish-completion for sway.
82
83 %package -n zsh-completion-sway
84 Summary:        ZSH completion for sway
85 Group:          Applications/Shells
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       zsh
88 BuildArch:      noarch
89
90 %description -n zsh-completion-sway
91 ZSH completion for sway.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96
97 %build
98 %meson build \
99         -Dxwayland=enabled
100 %ninja_build -C build
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 %ninja_install -C build
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc CONTRIBUTING.md README.md
112 %dir %{_sysconfdir}/sway
113 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sway/config
114 %attr(755,root,root) %{_bindir}/sway
115 %attr(755,root,root) %{_bindir}/swaybar
116 %attr(755,root,root) %{_bindir}/swaymsg
117 %attr(755,root,root) %{_bindir}/swaynag
118 %{_datadir}/wayland-sessions/sway.desktop
119 %{_mandir}/man1/sway.1*
120 %{_mandir}/man1/swaymsg.1*
121 %{_mandir}/man1/swaynag.1*
122 %{_mandir}/man5/sway-bar.5*
123 %{_mandir}/man5/sway-input.5*
124 %{_mandir}/man5/sway-output.5*
125 %{_mandir}/man5/sway.5*
126 %{_mandir}/man5/swaynag.5*
127 %{_mandir}/man7/sway-ipc.7*
128 %{_mandir}/man7/swaybar-protocol.7*
129
130 %files backgrounds
131 %defattr(644,root,root,755)
132 %dir %{_datadir}/backgrounds/sway
133 %{_datadir}/backgrounds/sway/Sway_Wallpaper_Blue_*.png
134
135 %files -n bash-completion-sway
136 %defattr(644,root,root,755)
137 %{bash_compdir}/sway
138 %{bash_compdir}/swaybar
139 %{bash_compdir}/swaymsg
140
141 %files -n fish-completion-sway
142 %defattr(644,root,root,755)
143 %{fish_compdir}/sway.fish
144 %{fish_compdir}/swaymsg.fish
145 %{fish_compdir}/swaynag.fish
146
147 %files -n zsh-completion-sway
148 %defattr(644,root,root,755)
149 %{zsh_compdir}/_sway
150 %{zsh_compdir}/_swaymsg
This page took 0.086268 seconds and 3 git commands to generate.