]> git.pld-linux.org Git - packages/subdownloader.git/blob - subdownloader.spec
5cccdf7686cf6792fec3d1a9787f9446eb37dc58
[packages/subdownloader.git] / subdownloader.spec
1 %global commit df8427e
2 %define         module          subdownloader
3 %define         egg_name        SubDownloader
4 Summary:        Fast and Easy Subtitle Downloader
5 Summary(pl.UTF-8):      Narzędzie do automatycznego ściągania/wysyłania podpisów do plików wideo
6 Name:           subdownloader
7 Version:        2.0.19
8 Release:        0.6
9 License:        GPL v3
10 Group:          X11/Applications/Multimedia
11 #Source0:       https://launchpad.net/subdownloader/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
12 Source0:        https://github.com/subdownloader/subdownloader/archive/%{commit}/%{name}-%{version}-%{commit}.tar.gz
13 # Source0-md5:  50efbf629daefd04bd261a4d8f0d2346
14 Source1:        %{name}.desktop
15 Source2:        %{name}.png
16 # Source2-md5:  de3d0cfa08b1572878cde6e3800205fa
17 Source3:        %{name}.sh
18 # site down, and was not in distfiles
19 #Source:        http://starowa.one.pl/~uzi/pld/%{name}-locale-pl.tar.gz
20 Patch0:         always-en.patch
21 Patch1:         egginfo.patch
22 URL:            http://www.subdownloader.net/
23 BuildRequires:  python3 >= 1:3.4
24 BuildRequires:  python3-PyQt5
25 #BuildRequires: python3-PyQt5-devel-tools
26 BuildRequires:  python3-PyQt5-uic
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 Requires:       desktop-file-utils
30 #Requires:      python-mmpython
31 Requires:       python3-PyQt5 >= 5.0.0
32 Requires:       python3-pymediainfo
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _appdir %{_datadir}/%{name}
37 %define         _localedir %{py3_sitescriptdir}/subdownloader/client/locale
38
39 %description
40 SubDownloader is a program for automatic download/upload subtitles for
41 videofiles (DivX, MPEG, AVI, VOB, etc) and DVDs using fast hashing.
42
43 Features:
44 - no spyware, no adware, source code is available
45 - it uses fast hashing algorithm (27 GB movies/7 seconds)
46 - recursively folders search
47 - autodetect language of the subtitles
48 - upload entire series seasons' subtitles in less than 1 minute
49 - and many more
50
51 %description -l pl.UTF-8
52 Subdownloader to napisane w Pythonie wolnodostępne narzędzie do
53 automatycznego ściągania/wysyłania podpisów do filmów (DivX, MPEG, AVI
54 itp.).
55
56 Cechy:
57 - brak spyware, adware; dostępny kod źródłowy
58 - wykorzystuje szybki algorytm haszujący (27 GB filmów/7 sekund)
59 - rekurencyjne wyszukiwanie napisów z folderów divx
60 - wysyłanie całych serii podpisów seriali w czasie poniżej minuty
61 - automatyczne wykrywanie języka podpisów
62 - i wiele więcej
63
64 %prep
65 %setup -qc
66 mv subdownloader-%{commit}*/* .
67 #%patch0 -p1
68 %patch1 -p1
69
70 #tar xzf %{SOURCE3}
71
72 %{__rm} scripts/gui/rc/images/icon32.ico
73
74 # cleanup backups after patching
75 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
76
77 %build
78 %py3_build
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 %py3_install
83
84 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/tests
85 cp -p subdownloader.1 $RPM_BUILD_ROOT%{_mandir}/man1
86 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
87 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
88
89 %{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/subdownloader/client/locale/subdownloader.pot
90 %{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/subdownloader/client/locale/*/subdownloader.po
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 %update_desktop_database
99
100 %postun
101 %update_desktop_database
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc ChangeLog README.md
106 %attr(755,root,root) %{_bindir}/%{name}
107 %if 0
108 %{_mandir}/man1/*.1*
109 %{_desktopdir}/%{name}.desktop
110 %{_pixmapsdir}/%{name}.png
111 %endif
112
113 %dir %{py3_sitescriptdir}/%{module}
114 %{py3_sitescriptdir}/%{module}/*.py
115 %{py3_sitescriptdir}/%{module}/__pycache__
116 %dir %{py3_sitescriptdir}/%{module}/client
117 %{py3_sitescriptdir}/%{module}/client/*.py
118 %{py3_sitescriptdir}/%{module}/client/__pycache__
119 %{py3_sitescriptdir}/%{module}/client/cli
120 %{py3_sitescriptdir}/%{module}/client/gui
121 %{py3_sitescriptdir}/%{module}/client/locale
122 %{py3_sitescriptdir}/%{module}/client/modules
123 %{py3_sitescriptdir}/%{module}/languages
124 %{py3_sitescriptdir}/%{module}/provider
125 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.173503 seconds and 2 git commands to generate.