]> git.pld-linux.org Git - packages/strace.git/commitdiff
- struct stat64 can have other fields than struct stat (e.g. alpha with Linux >=...
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 25 Apr 2004 17:13:46 +0000 (17:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    strace-stat64.patch -> 1.2

strace-stat64.patch

index 137cbc48108591d20c140776d12859d4e3155b58..1e61d231b114aae80ed7dbb1a8254bf2571d5af3 100644 (file)
@@ -1,20 +1,84 @@
---- strace-4.2/file.c.foo      Fri Mar 31 12:44:35 2000
-+++ strace-4.2/file.c  Fri Mar 31 12:44:53 2000
-@@ -611,7 +611,7 @@
-       realprintstat(tcp, &statbuf);
- }
+--- strace-4.5.3/configure.ac.orig     2004-04-25 15:46:46.000000000 +0000
++++ strace-4.5.3/configure.ac  2004-04-25 16:29:07.000000000 +0000
+@@ -165,6 +165,14 @@
+                 struct stat.st_level,
+                 struct stat.st_rdev])
+ AC_STAT64
++AC_CHECK_MEMBERS([struct stat64.st_blksize,
++                struct stat64.st_blocks,
++                struct stat64.st_aclcnt,
++                struct stat64.st_flags,
++                struct stat64.st_fstype,
++                struct stat64.st_gen,
++                struct stat64.st_level,
++                struct stat64.st_rdev],,,[#include <asm/stat.h>])
  
--#ifdef STAT64
-+#ifdef HAVE_STAT64
- static void
- printstat64(tcp, addr)
- struct tcb *tcp;
-@@ -683,7 +683,7 @@
+ AC_TYPE_SIGNAL
+ AC_TYPE_UID_T
+--- strace-4.5.3/file.c.orig   2004-01-13 10:16:47.000000000 +0000
++++ strace-4.5.3/file.c        2004-04-25 16:30:39.000000000 +0000
+@@ -862,27 +862,27 @@
+                       (unsigned long) statbuf.st_nlink,
+                       (unsigned long) statbuf.st_uid,
+                       (unsigned long) statbuf.st_gid);
+-#ifdef HAVE_STRUCT_STAT_ST_BLKSIZE
++#ifdef HAVE_STRUCT_STAT64_ST_BLKSIZE
+               tprintf("st_blksize=%lu, ",
+                       (unsigned long) statbuf.st_blksize);
+-#endif /* HAVE_STRUCT_STAT_ST_BLKSIZE */
+-#ifdef HAVE_STRUCT_STAT_ST_BLOCKS
++#endif /* HAVE_STRUCT_STAT64_ST_BLKSIZE */
++#ifdef HAVE_STRUCT_STAT64_ST_BLOCKS
+               tprintf("st_blocks=%lu, ", (unsigned long) statbuf.st_blocks);
+-#endif /* HAVE_STRUCT_STAT_ST_BLOCKS */
++#endif /* HAVE_STRUCT_STAT64_ST_BLOCKS */
+       }
        else
-               tprintf("...}");
- }
--#endif /* STAT64 */
-+#endif /* HAVE_STAT64 */
- #if defined(linux) && !defined(IA64)
- static void
+               tprintf("{st_mode=%s, ", sprintmode(statbuf.st_mode));
+       switch (statbuf.st_mode & S_IFMT) {
+       case S_IFCHR: case S_IFBLK:
+-#ifdef HAVE_STRUCT_STAT_ST_RDEV
++#ifdef HAVE_STRUCT_STAT64_ST_RDEV
+               tprintf("st_rdev=makedev(%lu, %lu), ",
+                       (unsigned long) major(statbuf.st_rdev),
+                       (unsigned long) minor(statbuf.st_rdev));
+-#else /* !HAVE_STRUCT_STAT_ST_RDEV */
++#else /* !HAVE_STRUCT_STAT64_ST_RDEV */
+               tprintf("st_size=makedev(%lu, %lu), ",
+                       (unsigned long) major(statbuf.st_size),
+                       (unsigned long) minor(statbuf.st_size));
+-#endif /* !HAVE_STRUCT_STAT_ST_RDEV */
++#endif /* !HAVE_STRUCT_STAT64_ST_RDEV */
+               break;
+       default:
+               tprintf("st_size=%llu, ", statbuf.st_size);
+@@ -892,24 +892,24 @@
+               tprintf("st_atime=%s, ", sprinttime(statbuf.st_atime));
+               tprintf("st_mtime=%s, ", sprinttime(statbuf.st_mtime));
+               tprintf("st_ctime=%s", sprinttime(statbuf.st_ctime));
+-#if HAVE_STRUCT_STAT_ST_FLAGS
++#if HAVE_STRUCT_STAT64_ST_FLAGS
+               tprintf(", st_flags=");
+               if (statbuf.st_flags) {
+                       printflags(fileflags, statbuf.st_flags);
+               } else
+                       tprintf("0");
+ #endif
+-#if HAVE_STRUCT_STAT_ST_ACLCNT
++#if HAVE_STRUCT_STAT64_ST_ACLCNT
+               tprintf(", st_aclcnt=%d", statbuf.st_aclcnt);
+ #endif
+-#if HAVE_STRUCT_STAT_ST_LEVEL
++#if HAVE_STRUCT_STAT64_ST_LEVEL
+               tprintf(", st_level=%ld", statbuf.st_level);
+ #endif
+-#if HAVE_STRUCT_STAT_ST_FSTYPE
++#if HAVE_STRUCT_STAT64_ST_FSTYPE
+               tprintf(", st_fstype=%.*s",
+                       (int) sizeof statbuf.st_fstype, statbuf.st_fstype);
+ #endif
+-#if HAVE_STRUCT_STAT_ST_GEN
++#if HAVE_STRUCT_STAT64_ST_GEN
+               tprintf(", st_gen=%u", statbuf.st_gen);
+ #endif
+               tprintf("}");
This page took 0.120822 seconds and 4 git commands to generate.