]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- 3.8.10.1
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - some tests fail with tcl8.5, it's tcl fault,
3 #       if someone REALLY cares (s)he can look into it
4 #
5 # Conditional build:
6 %bcond_with     tests           # run tests
7 %bcond_without  tcl             # Tcl extension
8 %bcond_without  doc             # disable documentation building
9 %bcond_without  unlock_notify   # disable unlock notify API
10 %bcond_without  load_extension  # enable load extension API
11 %bcond_with     icu             # ICU tokenizer support
12
13 %ifarch alpha sparc %{x8664}
14 %undefine       with_tests
15 %endif
16
17 # disabling tcl currently breaks making test target,
18 # some hack in Makefile needs to be done
19 %if %{without tcl}
20 %undefine       with_tests
21 %endif
22
23 # sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
24 %define         vnum    3081002
25 %define         ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do; v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.","");print(v)}
26
27 %define         tclver          8.6
28 Summary:        SQLite library
29 Summary(pl.UTF-8):      Biblioteka SQLite
30 Name:           sqlite3
31 Version:        %{ver}
32 Release:        1
33 License:        Public Domain
34 Group:          Libraries
35 # Source0Download: http://www.sqlite.org/download.html
36 Source0:        http://www.sqlite.org/2015/sqlite-src-%{vnum}.zip
37 # Source0-md5:  5d717638b97b3be1a4d855d957028738
38 Patch0:         %{name}-sign-function.patch
39 URL:            http://www.sqlite.org/
40 %{?with_load_extension:Provides:        %{name}(load_extension)}
41 %{?with_unlock_notify:Provides: %{name}(unlock_notify)}
42 %{?with_icu:Provides:   %{name}(icu)}
43 BuildRequires:  autoconf >= 2.50
44 BuildRequires:  automake
45 BuildRequires:  libtool
46 BuildRequires:  readline-devel
47 %{?with_load_extension:BuildRequires:   sed >= 4.0}
48 BuildRequires:  tcl
49 %{?with_tcl:BuildRequires:      tcl-devel >= %{tclver}}
50 BuildRequires:  unzip
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _ulibdir        /usr/lib
54
55 %description
56 SQLite is a C library that implements an SQL database engine. A large
57 subset of SQL92 is supported. A complete database is stored in a
58 single disk file. The API is designed for convenience and ease of use.
59 Applications that link against SQLite can enjoy the power and
60 flexiblity of an SQL database without the administrative hassles of
61 supporting a separate database server. Because it omits the
62 client-server interaction overhead and writes directly to disk, SQLite
63 is also faster than the big database servers for most operations. In
64 addition to the C library, the SQLite distribution includes a
65 command-line tool for interacting with SQLite databases and SQLite
66 bindings for Tcl/Tk.
67
68 %description -l pl.UTF-8
69 SQLite jest biblioteką języka C, która implementuje silnik baz danych
70 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
71 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
72 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
73 danych bez konieczności utrzymywania osobnego serwera baz danych.
74 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
75 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
76 bazodanowych przy większości operacji na bazie danych. Dodatkowo
77 oprócz biblioteki języka C, dostarczany jest program do zarządzania
78 bazami danych.
79
80 %package devel
81 Summary:        Header files for SQLite development
82 Summary(pl.UTF-8):      Pliki nagłówkowe SQLite
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 %if %{with unlock_notify}
86 Provides:       %{name}-devel(unlock_notify)
87 %endif
88 %if %{with load_extension}
89 Provides:       %{name}-devel(load_extension)
90 %endif
91 %if %{with icu}
92 Provides:       %{name}-devel(icu)
93 %endif
94
95 %description devel
96 SQLite is a C library that implements an SQL database engine. A large
97 subset of SQL92 is supported. A complete database is stored in a
98 single disk file. The API is designed for convenience and ease of use.
99 Applications that link against SQLite can enjoy the power and
100 flexiblity of an SQL database without the administrative hassles of
101 supporting a separate database server. Because it omits the
102 client-server interaction overhead and writes directly to disk, SQLite
103 is also faster than the big database servers for most operations. In
104 addition to the C library, the SQLite distribution includes a
105 command-line tool for interacting with SQLite databases and SQLite
106 bindings for Tcl/Tk.
107
108 This package contains the header files needed to develop programs that
109 use these SQLite.
110
111 %description devel -l pl.UTF-8
112 SQLite jest biblioteką języka C, która implementuje silnik baz danych
113 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
114 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
115 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
116 danych bez konieczności utrzymywania osobnego serwera baz danych.
117 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
118 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
119 bazodanowych przy większości operacji na bazie danych. Dodatkowo
120 oprócz biblioteki języka C, dostarczany jest program do zarządzania
121 bazami danych.
122
123 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
124 używających biblioteki SQLite.
125
126 %package static
127 Summary:        Static libraries for SQLite development
128 Summary(pl.UTF-8):      Statyczne biblioteki SQLite
129 Group:          Development/Libraries
130 Requires:       %{name}-devel = %{version}-%{release}
131 %if %{with unclock_notify}
132 Provides:       %{name}-static(unlock_notify)
133 %endif
134 %if %{with load_extension}
135 Provides:       %{name}-static(load_extension)
136 %endif
137
138 %description static
139 SQLite is a C library that implements an SQL database engine. A large
140 subset of SQL92 is supported. A complete database is stored in a
141 single disk file. The API is designed for convenience and ease of use.
142 Applications that link against SQLite can enjoy the power and
143 flexiblity of an SQL database without the administrative hassles of
144 supporting a separate database server. Because it omits the
145 client-server interaction overhead and writes directly to disk, SQLite
146 is also faster than the big database servers for most operations. In
147 addition to the C library, the SQLite distribution includes a
148 command-line tool for interacting with SQLite databases and SQLite
149 bindings for Tcl/Tk.
150
151 This package contains the static SQLite libraries.
152
153 %description static -l pl.UTF-8
154 SQLite jest biblioteką języka C, która implementuje silnik baz danych
155 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
156 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
157 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
158 danych bez konieczności utrzymywania osobnego serwera baz danych.
159 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
160 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
161 bazodanowych przy większości operacji na bazie danych. Dodatkowo
162 oprócz biblioteki języka C, dostarczany jest program do zarządzania
163 bazami danych.
164
165 Pakiet zawiera statyczne biblioteki SQLite.
166
167 %package -n tcl-%{name}
168 Summary:        sqlite3 tcl extension
169 Summary(pl.UTF-8):      Rozszerzenie sqlite3 dla Tcl
170 Group:          Development/Languages/Tcl
171
172 %description -n tcl-%{name}
173 sqlite3 tcl extension.
174
175 %description -n tcl-%{name} -l pl.UTF-8
176 Rozszerzenie sqlite3 dla Tcl.
177
178 %prep
179 %setup -q -n sqlite-src-%{vnum}
180 %patch0 -p1
181
182 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
183
184 if [ "$(cat VERSION)" != "%{version}" ]; then
185         echo "Tarball content doesn't match version %{version}." >&2
186         exit 1
187 fi
188
189 %build
190 %{__libtoolize}
191 cp -f /usr/share/automake/config.sub .
192 %{__aclocal}
193 %{__autoconf}
194 append-cppflags() {
195         CPPFLAGS="$CPPFLAGS $*"
196 }
197 append-libs() {
198         LIBS="$LIBS $*"
199 }
200 export CPPFLAGS="%{rpmcflags}"
201 export LIBS
202 %if %{with tcl}
203 export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
204 %endif
205
206 append-cppflags -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_SECURE_DELETE
207
208 # Support column metadata functions.
209 # http://sqlite.org/c3ref/column_database_name.html
210 # http://sqlite.org/c3ref/table_column_metadata.html
211 append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
212
213 # Support Full-Text Search versions 3 and 4.
214 # http://sqlite.org/fts3.html
215 #append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
216 append-cppflags -DSQLITE_ENABLE_FTS3
217
218 # Support R*Trees.
219 # http://sqlite.org/rtree.html
220 append-cppflags -DSQLITE_ENABLE_RTREE
221
222 # Support soundex() function.
223 # http://sqlite.org/lang_corefunc.html#soundex
224 #append-cppflags -DSQLITE_SOUNDEX
225
226 %if %{with unlock_notify}
227 # Support unlock notification.
228 # http://sqlite.org/unlock_notify.html
229 append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
230 %endif
231
232 %if %{with icu}
233 append-cppflags -DSQLITE_ENABLE_ICU
234 append-libs "-licui18n -licuuc"
235 %endif
236
237 %if %{with load_extension}
238 append-libs "-ldl"
239 %endif
240
241 %configure \
242         %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
243         %{__enable_disable load_extension load-extension} \
244         --enable-threadsafe
245
246 %{__make}
247
248 %if %{with doc}
249 %{__make} doc
250 %endif
251
252 %{?with_tests:LC_ALL=C %{__make} test}
253
254 %install
255 rm -rf $RPM_BUILD_ROOT
256 install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
257 %{__make} install \
258         DESTDIR=$RPM_BUILD_ROOT
259
260 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
261 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
262 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
263         $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
264
265 cp -p sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
266
267 %clean
268 rm -rf $RPM_BUILD_ROOT
269
270 %post   -p /sbin/ldconfig
271 %postun -p /sbin/ldconfig
272
273 %files
274 %defattr(644,root,root,755)
275 %doc README.md
276 %attr(755,root,root) %{_bindir}/sqlite3
277 %attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
278 %attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
279 %{_mandir}/man1/sqlite3.1*
280
281 %files devel
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_libdir}/libsqlite3.so
284 %{_libdir}/libsqlite3.la
285 %{_includedir}/sqlite3.h
286 %{_includedir}/sqlite3ext.h
287 %{_pkgconfigdir}/sqlite3.pc
288
289 %files static
290 %defattr(644,root,root,755)
291 %{_libdir}/libsqlite3.a
292
293 %if %{with tcl}
294 %files -n tcl-%{name}
295 %defattr(644,root,root,755)
296 %dir %{_libdir}/tcl*/sqlite3
297 %attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
298 %{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
299 %endif
This page took 0.101374 seconds and 4 git commands to generate.