]> git.pld-linux.org Git - packages/spirv-tools.git/blob - spirv-tools.spec
up to 20160222 snapshot
[packages/spirv-tools.git] / spirv-tools.spec
1
2 %define snap    20160222
3 %define commit  9413fbbf587b23541c4339943325a474641cd605
4 %define _ver    %(echo %{version} | tr _ -)
5 Summary:        SPIR-V Tools
6 Name:           spirv-tools
7 Version:        1.0_rev3.s%{snap}
8 Release:        1
9 License:        MIT-like
10 Group:          Applications
11 Source0:        https://github.com/KhronosGroup/SPIRV-Tools/archive/%{commit}/%{name}-s%{snap}.tar.gz
12 # Source0-md5:  d11ec2de7a44a68535b0dbd62f0cc5b6
13 Patch0:         cmake-lib64.patch
14 URL:            https://github.com/KhronosGroup/SPIRV-Tools
15 BuildRequires:  cmake
16 Requires:       %{name}-libs = %{version}-%{release}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The SPIR-V Tools project provides an API and commands for processing
21 SPIR-V modules.
22
23 The project includes an assembler, binary module parser, disassembler,
24 and validator for SPIR-V, all based on a common static library. The
25 library contains all of the implementation details, and is used in the
26 standalone tools whilst also enabling integration into other code
27 bases directly.
28
29 The interfaces are still under development, and are expected to
30 change.
31
32 SPIR-V is defined by the Khronos Group Inc.
33
34 %package libs
35 Summary:        SPIR-V Tools library
36 Group:          Libraries
37
38 %description libs
39 The SPIR-V Tools project provides an API for processing SPIR-V
40 modules.
41
42 %package devel
43 Summary:        Header files for %{name} library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
45 Group:          Development/Libraries
46 Requires:       %{name}-libs = %{version}-%{release}
47
48 %description devel
49 Header files for %{name} library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki %{name}.
53
54 %prep
55 %setup -q -n SPIRV-Tools-%{commit}
56 %patch0 -p1
57
58 %build
59 install -d build
60 cd build
61 %cmake \
62         ../
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 cd build
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   libs -p /sbin/ldconfig
77 %postun libs -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc LICENSE README.md syntax.md
82 %attr(755,root,root) %{_bindir}/spirv-*
83
84 %files libs
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/libSPIRV-Tools.so
87
88 %files devel
89 %defattr(644,root,root,755)
90 %{_includedir}/spirv
91 %{_includedir}/spirv-tools
This page took 0.13564 seconds and 3 git commands to generate.