]> git.pld-linux.org Git - packages/spandsp.git/blob - spandsp.spec
fbdc90531c47a107339409a2afc9a1df480d3cc3
[packages/spandsp.git] / spandsp.spec
1 #
2 # TODO:
3 #       - build and package the 'tests' (sample programs)
4 #               should be conditional, as adds BR!
5 #
6 # Conditional build:
7 %bcond_without  mmx             # use MMX instructions
8 %bcond_without  sse             # use SSE instructions
9 %bcond_with     tests           # test programs
10
11 %ifnarch athlon pentium3 pentium4 %{x8664} x32
12 %undefine       with_mmx
13 %endif
14 %ifnarch pentium3 pentium4 %{x8664} x32
15 %undefine       with_sse
16 %endif
17
18 Summary:        DSP functions for telephony
19 Summary(pl.UTF-8):      Funkcje DSP dla telefonii
20 Name:           spandsp
21 Version:        0.0.6
22 Release:        2
23 Epoch:          1
24 License:        LGPL v2.1
25 Group:          Libraries
26 Source0:        http://www.soft-switch.org/downloads/spandsp/%{name}-%{version}.tar.gz
27 # Source0-md5:  897d839516a6d4edb20397d4757a7ca3
28 Patch0:         x32.patch
29 URL:            http://www.soft-switch.org/
30 BuildRequires:  autoconf >= 2.50
31 BuildRequires:  automake >= 1:1.9.5
32 BuildRequires:  docbook-dtd43-xml
33 BuildRequires:  docbook-style-xsl
34 BuildRequires:  doxygen
35 %{?with_tests:BuildRequires:    fftw3-common-devel}
36 %{?with_tests:BuildRequires:    fftw3-devel}
37 BuildRequires:  fltk-devel
38 BuildRequires:  libjpeg-devel
39 %{?with_tests:BuildRequires:    libpcap-devel}
40 %{?with_tests:BuildRequires:    libsndfile-devel}
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtiff-devel
43 %{?with_tests:BuildRequires:    libtiff-progs}
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.0
46 BuildRequires:  libxslt-progs
47 %{?with_tests:BuildRequires:    netpbm-progs}
48 BuildRequires:  pkgconfig
49 %{?with_tests:BuildRequires:    sox}
50 %{?with_tests:BuildRequires:    xorg-lib-libX11-devel}
51 %{?with_tests:BuildRequires:    xorg-lib-libXext-devel}
52 %{?with_tests:BuildRequires:    xorg-lib-libXft-devel}
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 spandsp is a library which provides many of the DSP functions needed
57 for telephony. It is designed to be independent of the telephony
58 platform itself.
59
60 %description -l pl.UTF-8
61 spandsp to biblioteka udostępniająca wiele funkcji DSP potrzebnych dla
62 telefonii. Jest zaprojektowana tak, by była niezależna od samej
63 platformy telefonicznej.
64
65 %package devel
66 Summary:        Header files to develop applications using spandsp
67 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia aplikacji używających spandsp
68 Group:          Development/Libraries
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70 Requires:       libtiff-devel
71
72 %description devel
73 Header files for the spandsp library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe dla biblioteki spandsp.
77
78 %package static
79 Summary:        Static spandsp library
80 Summary(pl.UTF-8):      Statyczna biblioteka spandsp
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
83
84 %description static
85 Static spandsp library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka spandsp.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --enable-doc \
102         %{?with_mmx:--enable-mmx} \
103         %{?with_sse:--enable-sse} \
104         %{?with_tests:--enable-tests}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog DueDiligence NEWS README
122 %attr(755,root,root) %{_libdir}/libspandsp.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libspandsp.so.2
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libspandsp.so
128 %{_libdir}/libspandsp.la
129 %{_includedir}/spandsp
130 %{_includedir}/spandsp.h
131 %{_pkgconfigdir}/spandsp.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libspandsp.a
This page took 0.069933 seconds and 2 git commands to generate.