]> git.pld-linux.org Git - packages/smartcardpp.git/blob - smartcardpp.spec
- add missing include unistd.h
[packages/smartcardpp.git] / smartcardpp.spec
1 Summary:        Library for accessing smart cards
2 Summary(pl.UTF-8):      Biblioteka do dostępu do kart procesorowych
3 Name:           smartcardpp
4 Version:        0.3.0
5 Release:        2
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: http://code.google.com/p/esteid/downloads/list
9 Source0:        http://esteid.googlecode.com/files/%{name}-%{version}.tar.bz2
10 # Source0-md5:  c6172387475982393d02314f389f3513
11 Patch0:         sleep.patch
12 Patch1:         getopt.patch
13 URL:            http://code.google.com/p/esteid/
14 BuildRequires:  cmake >= 2.6
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  pcsc-lite-devel
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 smartcardpp is a set of C++ classes to manage smart card
22 communications and implement basic command primitives.
23
24 %description -l pl.UTF-8
25 smartcardpp to zbiór klas C++ pozwalających na zarządzanie
26 komunikacją z kartami procesorowymi oraz implementujących podstawowe
27 polecenia.
28
29 %package devel
30 Summary:        Header files for smartcardpp library
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki smartcardpp
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       libstdc++-devel
35 Requires:       pcsc-lite-devel
36
37 %description devel
38 This package contains header files for developing applications that
39 use smartcardpp library.
40
41 %description devel -l pl.UTF-8
42 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
43 wykorzystujących bibliotekę smartcardpp.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48 %patch1 -p1
49
50 %build
51 install -d build
52 cd build
53 %cmake ..
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 %{__make} -C build install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(644,root,root,755)
69 %doc COPYING NEWS
70 %attr(755,root,root) %{_bindir}/card-test
71 %attr(755,root,root) %{_libdir}/libsmartcardpp.so.*.*.*
72 %attr(755,root,root) %ghost %{_libdir}/libsmartcardpp.so.1
73
74 %files devel
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_libdir}/libsmartcardpp.so
77 %{_includedir}/smartcardpp
78 %{_pkgconfigdir}/smartcardpp.pc
This page took 0.069483 seconds and 3 git commands to generate.