]> git.pld-linux.org Git - packages/slang.git/commitdiff
- added run aclocal on regenerate ac files (added automake to BuildRequires),
authorkloczek <kloczek@pld-linux.org>
Wed, 27 Feb 2002 02:03:17 +0000 (02:03 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- pass CC="%%{__cc}" on build shared library (for allow build correctly build
  slang linked with uClibc).

Changed files:
    slang.spec -> 1.58

slang.spec

index 6cf1646a2c6d94748455efe7e7af533593c90e18..82393a242f8a839b4f8bd44c40334271350f8311 100644 (file)
@@ -17,6 +17,8 @@ Patch0:               %{name}-security.patch
 Patch1:                %{name}-DESTDIR.patch
 Patch2:                %{name}-nodevel.patch
 Patch3:                %{name}-uclibc_ac_fix.patch
+Patch4:                %{name}-ac25x.patch
+BuildRequires: automake
 BuildRequires: autoconf
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -118,11 +120,17 @@ Biblioteka statyczna slang.
 %patch3 -p1
 
 %build
-(cd autoconf ; mv -f acsite.m4 aclocal.m4 ; autoconf ; cp -f configure ..)
-(cd demo ; cp -f ../autoconf/aclocal.m4 . ; autoconf)
+mv -f autoconf/aclocal.m4 acinclude.m4
+mv -f autoconf/configure.in .
+aclocal
+autoconf
+(cd demo
+cp -f ../acinclude.m4 .
+aclocal
+autoconf)
 %configure
 
-%{__make} elf ELF_CFLAGS="%{rpmcflags} -fPIC"
+%{__make} elf ELF_CFLAGS="%{rpmcflags} -fPIC" CC="%{__cc}"
 %{__make} all CFLAGS="%{rpmcflags}"
 %{__make} -C slsh DL_LIB="-ldl" ARCH="elf" CFLAGS="%{rpmcflags}"
 
This page took 1.08135 seconds and 4 git commands to generate.