]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- up to 4.7.3
[packages/sip.git] / sip.spec
1 # TODO: Check if really v 4.5 is python 2.5 compatible, if so,
2 #    kill python2.5.patch
3 Summary:        Python bindings generator for C++ class libraries
4 Summary(pl.UTF-8):      Generator powiązań Pythona z bibliotekami klas C++
5 Name:           sip
6 Version:        4.7.3
7 Release:        1
8 Epoch:          2
9 License:        redistributable (see LICENSE)
10 Group:          Development/Languages/Python
11 Source0:        http://www.riverbankcomputing.com/Downloads/sip4/sip-%{version}.tar.gz
12 # Source0-md5:  a792c58d4d211c65949dac6005eb652b
13 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
14 # Patch0:               %{name}-python2.5.patch
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  python-devel >= 2.3
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.167
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sipfilesdir    %{_datadir}/sip
22
23 %description
24 Generates Python bindings for C++ class libraries from a set of class
25 specification files.
26
27 %description -l pl.UTF-8
28 Generuje powiązania Pythona z bibliotekami klas C++ ze zbioru plików
29 ze specyfikacjami klas.
30
31 %package -n python-sip
32 Summary:        Python module needed by generated bindings
33 Summary(pl.UTF-8):      Moduł Pythona wymagany przez wygenerowane powiązania
34 Group:          Libraries/Python
35 %pyrequires_eq  python-libs
36
37 %description -n python-sip
38 Generates Python bindings for C++ class libraries from a set of class
39 specification files. This package includes runtime library needed by
40 all generated bindings.
41
42 %description -n python-sip -l pl.UTF-8
43 Generuje powiązania Pythona z bibliotekami klas C++ ze zbioru plików
44 ze specyfikacjami klas. Ten pakiet zawiera bibliotekę potrzebną do
45 uruchomienia wszystkich wygenerowanych powiązań.
46
47 %package -n python-sip-devel
48 Summary:        Development files needed to build bindings
49 Summary(pl.UTF-8):      Pliki programistyczne potrzebne do budowania powiązań
50 Group:          Development/Libraries
51 Requires:       %{name} = %{epoch}:%{version}-%{release}
52 Requires:       python-devel >= 2.3
53 %pyrequires_eq  python-libs
54
55 %description -n python-sip-devel
56 Development files needed to build bindings for C++ classes.
57
58 %description -n python-sip-devel -l pl.UTF-8
59 Pliki programistyczne potrzebne do budowania powiązań z klasami C++.
60
61 %prep
62 %setup -q
63 #%%patch0 -p1
64
65 %build
66 # configure.py notes:
67 # - macros overrides must be last
68 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
69 python configure.py \
70         -b %{_bindir} \
71         -e %{py_incdir} \
72         -v %{_sipfilesdir} \
73         -d %{py_sitedir} \
74         CC="%{__cc}" \
75         CXX="%{__cxx}" \
76         CFLAGS="%{rpmcflags}" \
77         CXXFLAGS="%{rpmcxxflags}" \
78         LINK="%{__cxx}" \
79         LINK_SHLIB="%{__cxx}"
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc ChangeLog LICENSE NEWS THANKS doc/*
96 %attr(755,root,root) %{_bindir}/*
97
98 %files -n python-sip
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{py_sitedir}/sip.so
101
102 %files -n python-sip-devel
103 %defattr(644,root,root,755)
104 %{py_sitedir}/sip*.py
105 %{py_incdir}/*.h
106 %dir %{_sipfilesdir}
This page took 0.083883 seconds and 3 git commands to generate.