]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- up to 4.10
[packages/sip.git] / sip.spec
1 # TODO: Check if really v 4.5 is python 2.5 compatible, if so,
2 #    kill python2.5.patch
3
4 Summary:        Python bindings generator for C++ class libraries
5 Summary(pl.UTF-8):      Generator powiązań Pythona z bibliotekami klas C++
6 Name:           sip
7 Version:        4.10
8 Release:        1
9 Epoch:          2
10 License:        redistributable (see LICENSE)
11 Group:          Development/Languages/Python
12 Source0:        http://www.riverbankcomputing.com/static/Downloads/sip4/sip-%{version}.tar.gz
13 # Source0-md5:  4b8f7361839b33868dd3cc576509ba8e
14 URL:            http://www.riverbankcomputing.com/software/sip/
15 # Patch0:               %{name}-python2.5.patch
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  python-devel >= 2.3
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.167
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sipfilesdir    %{_datadir}/sip
23
24 %description
25 Generates Python bindings for C++ class libraries from a set of class
26 specification files.
27
28 %description -l pl.UTF-8
29 Generuje powiązania Pythona z bibliotekami klas C++ ze zbioru plików
30 ze specyfikacjami klas.
31
32 %package -n python-sip
33 Summary:        Python module needed by generated bindings
34 Summary(pl.UTF-8):      Moduł Pythona wymagany przez wygenerowane powiązania
35 Group:          Libraries/Python
36 %pyrequires_eq  python-libs
37
38 %description -n python-sip
39 Generates Python bindings for C++ class libraries from a set of class
40 specification files. This package includes runtime library needed by
41 all generated bindings.
42
43 %description -n python-sip -l pl.UTF-8
44 Generuje powiązania Pythona z bibliotekami klas C++ ze zbioru plików
45 ze specyfikacjami klas. Ten pakiet zawiera bibliotekę potrzebną do
46 uruchomienia wszystkich wygenerowanych powiązań.
47
48 %package -n python-sip-devel
49 Summary:        Development files needed to build bindings
50 Summary(pl.UTF-8):      Pliki programistyczne potrzebne do budowania powiązań
51 Group:          Development/Libraries
52 Requires:       %{name} = %{epoch}:%{version}-%{release}
53 Requires:       python-devel >= 2.3
54 %pyrequires_eq  python-libs
55
56 %description -n python-sip-devel
57 Development files needed to build bindings for C++ classes.
58
59 %description -n python-sip-devel -l pl.UTF-8
60 Pliki programistyczne potrzebne do budowania powiązań z klasami C++.
61
62 %prep
63 %setup -q
64 #%%patch0 -p1
65
66 %build
67 # configure.py notes:
68 # - macros overrides must be last
69 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
70 python configure.py \
71         -b %{_bindir} \
72         -e %{py_incdir} \
73         -v %{_sipfilesdir} \
74         -d %{py_sitedir} \
75         CC="%{__cc}" \
76         CXX="%{__cxx}" \
77         CFLAGS="%{rpmcflags}" \
78         CXXFLAGS="%{rpmcxxflags}" \
79         LINK="%{__cxx}" \
80         LINK_SHLIB="%{__cxx}"
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc ChangeLog LICENSE NEWS README doc/*
97 %attr(755,root,root) %{_bindir}/*
98
99 %files -n python-sip
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{py_sitedir}/sip.so
102 %dir %{_sipfilesdir}
103
104 %files -n python-sip-devel
105 %defattr(644,root,root,755)
106 %{py_sitedir}/sip*.py
107 %{py_incdir}/*.h
This page took 0.094837 seconds and 3 git commands to generate.