]> git.pld-linux.org Git - packages/shadow.git/commitdiff
- updated pld patch
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 14 Dec 2012 13:10:39 +0000 (14:10 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 14 Dec 2012 13:10:39 +0000 (14:10 +0100)
- removed obsolete patches
- updated build/install/files

shadow-chage_expdays.patch [deleted file]
shadow-pld.patch
shadow.spec

diff --git a/shadow-chage_expdays.patch b/shadow-chage_expdays.patch
deleted file mode 100644 (file)
index 880ebba..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
---- shadow-4.0.6/src/chage.c   2004-11-18 21:36:19.617616944 +0100
-+++ shadow-4.0.16/src/chage.c  2006-06-08 00:30:20.837211299 +0300
-@@ -84,7 +84,7 @@
- extern int sp_dbm_mode;
- #endif
--#define       EPOCH           "1969-12-31"
-+#define       EPOCH_SHORT     "12/31/69"
- /* local function prototypes */
- static void usage (void);
-@@ -168,7 +168,7 @@
-       change_field (buf, sizeof buf,
-                     _("Last Password Change (YYYY-MM-DD)"));
--      if (strcmp (buf, EPOCH) == 0)
-+      if (strcmp (buf, EPOCH_SHORT) == 0)
-               lastday = -1;
-       else if ((lastday = strtoday (buf)) == -1)
-               return 0;
-@@ -190,7 +190,7 @@
-       change_field (buf, sizeof buf,
-                     _("Account Expiration Date (YYYY-MM-DD)"));
--      if (strcmp (buf, EPOCH) == 0)
-+      if (strcmp (buf, EPOCH_SHORT) == 0)
-               expdays = -1;
-       else if ((expdays = strtoday (buf)) == -1)
-               return 0;
-@@ -274,7 +274,7 @@
-        * password expiring or not.
-        */
-       printf (_("Account expires\t\t\t\t\t\t: "));
--      if (expdays < 0) {
-+      if (expdays == -1) {
-               printf (_("never\n"));
-       } else {
-               expires = expdays * SCALE;
-@@ -403,7 +403,10 @@
-                       case 'E':
-                               Eflg++;
-                               if (!isnum (optarg))
--                                      expdays = strtoday (optarg);
-+                                      if (strcmp (optarg, EPOCH_SHORT) == 0)
-+                                              expdays = -1;
-+                                      else
-+                                              expdays = strtoday (optarg);
-                               else
-                                       expdays = strtol (optarg, 0, 10);
-                               break;
index 4ed7b970d9ed57b377acf523ab53630ced1c951c..0f0837b783280f28c3cbded81b623efd859600da 100644 (file)
@@ -1,23 +1,3 @@
---- shadow-4.0.16/lib/getdef.c~        2006-06-08 00:19:27.452506888 +0300
-+++ shadow-4.0.16/lib/getdef.c 2006-06-08 00:21:20.945057953 +0300
-@@ -59,6 +59,8 @@
-       {"FAKE_SHELL", NULL},
-       {"GID_MAX", NULL},
-       {"GID_MIN", NULL},
-+      {"SYS_GID_MAX", NULL},
-+      {"SYS_GID_MIN", NULL},
-       {"HUSHLOGIN_FILE", NULL},
-       {"KILLCHAR", NULL},
-       {"LOGIN_RETRIES", NULL},
-@@ -77,6 +79,8 @@
-       {"TTYTYPE_FILE", NULL},
-       {"UID_MAX", NULL},
-       {"UID_MIN", NULL},
-+      {"SYS_UID_MAX", NULL},
-+      {"SYS_UID_MIN", NULL},
-       {"UMASK", NULL},
-       {"USERDEL_CMD", NULL},
-       {"USERGROUPS_ENAB", NULL},
 --- shadow-4.0.6/src/useradd.c 2004-11-18 21:45:00.713398344 +0100
 +++ shadow-4.0.16/src/useradd.c        2006-06-08 01:17:05.580340031 +0300
 @@ -72,10 +72,10 @@
@@ -30,7 +10,7 @@
 -static const char *def_home = "/home";
 -static const char *def_shell = "";
 +static const char *def_home = "/home/users";
-+static const char *def_shell = "/dev/null";
++static const char *def_shell = "/sbin/nologin";
  static const char *def_template = SKEL_DIR;
  static const char *def_create_mail_spool = "no";
  
  static uid_t user_id;
  static gid_t user_gid;
  static const char *user_comment = "";
-@@ -126,6 +126,7 @@
-     mflg = 0,                 /* create user's home directory if it doesn't exist */
-     nflg = 0,                 /* create a group having the same name as the user */
-     oflg = 0,                 /* permit non-unique user ID to be specified with -u */
-+      rflg = 0,                       /* create system account (wuth lower uid) */
-     sflg = 0,                 /* shell program for new account */
-     uflg = 0;                 /* specify user ID for new account */
-@@ -632,6 +633,7 @@
-                          "                            (non-unique) UID\n"
-                          "  -p, --password PASSWORD   use encrypted password for the new user\n"
-                          "                            account\n"
-+                         "  -r                                create a system account, with uid lower than usual\n"
-                          "  -s, --shell SHELL         the login shell for the new user account\n"
-                          "  -u, --uid UID                     force use the UID for the new user account\n"));
-       exit (E_USAGE);
-@@ -833,6 +835,13 @@
-       uid_min = getdef_unum ("UID_MIN", 1000);
-       uid_max = getdef_unum ("UID_MAX", 60000);
-+      if (!rflg) {
-+          uid_min = getdef_unum ("UID_MIN", 500);
-+          uid_max = getdef_unum ("UID_MAX", 60000);
-+      } else {
-+          uid_min = getdef_unum ("SYS_UID_MIN", 1);
-+          uid_max = getdef_unum ("SYS_UID_MAX", 499);
-+      }       
-       /*
-        * Start with some UID value if the user didn't provide us with
-@@ -1016,7 +1025,7 @@
-                       {NULL, 0, NULL, '\0'}
-               };
-               while ((c =
--                      getopt_long (argc, argv, "b:c:d:De:f:g:G:k:K:mMop:s:u:",
-+                      getopt_long (argc, argv, "b:c:d:De:f:g:G:k:K:mMop:s:u:r",
-                                    long_options, NULL)) != -1) {
-                       switch (c) {
-                       case 'b':
-@@ -1169,6 +1178,9 @@
-                               }
-                               user_pass = optarg;
-                               break;
-+                      case 'r':       /* create system account */
-+                              rflg++;
-+                              break;
-                       case 's':
-                               if (!VALID (optarg)
-                                   || (optarg[0]
---- shadow-4.0.16/src/groupadd.c       2006-06-09 21:26:14.039716861 +0300
-+++ shadow-4.0.18.1/src/groupadd.c     2006-11-11 18:38:27.453562057 +0200
-@@ -72,6 +72,7 @@
- static int oflg = 0;          /* permit non-unique group ID to be specified with -g */
- static int gflg = 0;          /* ID value for the new group */
- static int fflg = 0;          /* if group already exists, do nothing and exit(0) */
-+static int rflg = 0;           /* add system group (with lower gid) */
- #ifdef        NDBM
- extern int gr_dbm_mode;
-@@ -105,6 +106,7 @@
-                          "  -K, --key KEY=VALUE               overrides /etc/login.defs defaults\n"
-                          "  -o, --non-unique          allow create group with duplicate\n"
-                          "                            (non-unique) GID\n"
-+                         "  -r                                create a system account, with gid lower than usual\n"
-                          "\n"));
-       exit (E_USAGE);
- }
-@@ -197,8 +199,13 @@
-       const struct group *grp;
-       gid_t gid_min, gid_max;
--      gid_min = getdef_unum ("GID_MIN", 1000);
--      gid_max = getdef_unum ("GID_MAX", 60000);
-+      if (!rflg) {
-+              gid_min = getdef_unum ("GID_MIN", 500);
-+              gid_max = getdef_unum ("GID_MAX", 60000);
-+      } else {
-+              gid_min = getdef_unum ("SYS_GID_MIN", 10);
-+              gid_max = getdef_unum ("SYS_GID_MAX", 499);
-+      }
-       /*
-        * Start with some GID value if the user didn't provide us with
-@@ -412,7 +419,7 @@
-               };
-               while ((c =
--                      getopt_long (argc, argv, "fg:hK:o", long_options,
-+                      getopt_long (argc, argv, "fg:hK:or", long_options,
-                                    &option_index)) != -1) {
-                       switch (c) {
-                       case 'f':
-@@ -463,6 +470,10 @@
-                       case 'o':
-                               oflg++;
-                               break;
-+                      case 'r':
-+                              /* create system group */
-+                              rflg++;
-+                              break;                  
-                       default:
-                               usage ();
-                       }
---- shadow-4.0.16/man/groupadd.8~      2006-06-09 23:20:28.053339201 +0300
-+++ shadow-4.0.16/man/groupadd.8       2006-06-09 23:22:17.115785750 +0300
-@@ -14,7 +14,7 @@
- groupadd \- create a new group
- .SH "SYNOPSIS"
- .HP 9
--\fBgroupadd\fR [\-g\ \fIGID\fR\ [\-o]] [\-f] [\-K\ \fIKEY\fR=\fIVALUE\fR] \fIgroup\fR
-+\fBgroupadd\fR [\-g\ \fIGID\fR\ [\-o]] [\-f] [\-r] [\-K\ \fIKEY\fR=\fIVALUE\fR] \fIgroup\fR
- .SH "DESCRIPTION"
- .PP
- The
-@@ -58,6 +58,10 @@
- .TP 3n
- \fB\-o\fR
- This option permits to add group with non\-unique GID.
-+.TP 3n
-+\fB-r\fR
-+This flag is used to create a system group, with gid lower than usual
-+(chosen between SYS_GID_MIN and SYS_GID_MAX).
- .SH "FILES"
- .TP 3n
- \fI/etc/group\fR
---- shadow-4.0.16/man/useradd.8~       2006-06-09 23:05:41.393444193 +0300
-+++ shadow-4.0.16/man/useradd.8        2006-06-09 23:05:43.273486388 +0300
-@@ -118,6 +118,9 @@
- The encrypted password, as returned by
- \fBcrypt\fR(3). The default is to disable the account.
- .TP 3n
-+\fB-r\fR
-+The number of days after a password has expired before the account will be disabled.
-+.TP 3n
- \fB\-s\fR, \fB\-\-shell\fR \fISHELL\fR
- The name of the user's login shell. The default is to leave this field blank, which causes the system to select the default login shell.
- .TP 3n
---- shadow-4.0.16/man/pl/groupadd.8~   2006-06-09 21:27:27.071352380 +0300
-+++ shadow-4.0.16/man/pl/groupadd.8    2006-06-09 21:29:35.034218035 +0300
-@@ -29,7 +29,7 @@
- .SH NAZWA
- groupadd \- twórz nową grupę
- .SH SKŁADNIA
--\fBgroupadd\fR [\fB\-g\fR \fIgid\fR [\fB\-o\fR]] [\fB\-f\fR] \fIgrupa\fR
-+\fBgroupadd\fR [\fB\-g\fR \fIgid\fR [\fB\-o\fR]] [\fB\-f\fR] [\fB-r\fR] \fIgrupa\fR
- .SH OPIS
- Polecenie \fBgroupadd\fR tworzy nowe konto grupy posługując się
- wartościami podanymi w wierszu poleceń i domyślnymi wartościami z systemu.
-@@ -42,6 +42,10 @@
- podana groupa już istnieje. Z opcją \fB\-g\fR, jeśli podany gid już istnieje,
- wybierany jest inny (unikalny) gid (czyli \fB\-g\fR jest wyłączane).
- .TP
-+.BI -r
-+Ta opcja s¿u¿y do zak¿adania grup systemowych, z identyfikatorami ni¿szymi
-+ni¿ zwykle (wybieranymi z przedzia¿u od SYS_GID_MIN do SYS_GID_MAX).
-+.TP
- .BI \-g " gid"
- Numeryczna wartość identyfikatora grupy. Wartość ta musi być niepowtarzalna,
- chyba że użyto opcji \fB\-o\fR. Wartość ID grupy nie może być ujemna. Domyślnie
---- shadow-4.0.16/man/pl/useradd.8~    2006-06-09 22:52:54.696249131 +0300
-+++ shadow-4.0.16/man/pl/useradd.8     2006-06-09 23:00:57.427074349 +0300
-@@ -98,6 +98,9 @@
- .IP "\fB\-p\fR \fIpasswd\fR"
- Zakodowane hasło w postaci zwracanej przez \fBcrypt\fR(3).
- Domyślnym działaniem jest blokowanie konta.
-+.IP \fB-r\fR
-+Tworzenie konta systemowego, z identyfikatorem ni¿szym ni¿ zwykle
-+(wybieranym z przedzia¿u od SYS_UID_MIN do SYS_UID_MAX).
- .IP "\fB\-s\fR \fIpowłoka\fR"
- Nazwa powłoki (shell) użytkownika. Ustawienie tego pola na puste
- powoduje, że system wybierze domyślną powłokę logowania.
+--- shadow-4.1.5.1/libmisc/find_new_gid.c~     2011-07-29 17:38:23.000000000 +0200
++++ shadow-4.1.5.1/libmisc/find_new_gid.c      2012-12-14 14:03:45.355638812 +0100
+@@ -68,7 +68,7 @@
+                       return -1;
+               }
+       } else {
+-              gid_min = (gid_t) getdef_ulong ("SYS_GID_MIN", 101UL);
++              gid_min = (gid_t) getdef_ulong ("SYS_GID_MIN", 10UL);
+               gid_max = (gid_t) getdef_ulong ("GID_MIN", 1000UL) - 1;
+               gid_max = (gid_t) getdef_ulong ("SYS_GID_MAX", (unsigned long) gid_max);
+               if (gid_max < gid_min) {
+--- shadow-4.1.5.1/libmisc/find_new_uid.c~     2011-07-29 17:39:16.000000000 +0200
++++ shadow-4.1.5.1/libmisc/find_new_uid.c      2012-12-14 14:03:29.645639367 +0100
+@@ -68,7 +68,7 @@
+                       return -1;
+               }
+       } else {
+-              uid_min = (uid_t) getdef_ulong ("SYS_UID_MIN", 101UL);
++              uid_min = (uid_t) getdef_ulong ("SYS_UID_MIN", 1UL);
+               uid_max = (uid_t) getdef_ulong ("UID_MIN", 1000UL) - 1;
+               uid_max = (uid_t) getdef_ulong ("SYS_UID_MAX", (unsigned long) uid_max);
+               if (uid_max < uid_min) {
index 3aa116f2a616f08873028bb84be54fddfff6aa47..3d50d141aaf6adea4e54d3f96a111570f8ebd6a8 100644 (file)
@@ -108,13 +108,8 @@ Source5:   chsh.pamd
 Source6:       chfn.pamd
 Source7:       passwd.pamd
 Source8:       useradd.pamd
-Source9:       chpasswd.pamd
+#Source9:      chpasswd.pamd
 Patch0:                %{name}-pld.patch
-Patch1:                %{name}-chage_expdays.patch
-Patch2:                %{name}-po-update.patch
-Patch3:                %{name}-removed-programs.patch
-Patch4:                %{name}-shared.patch
-Patch5:                %{name}-typo.patch
 URL:           http://pkg-shadow.alioth.debian.org/
 BuildRequires: autoconf
 BuildRequires: automake >= 1.0
@@ -211,42 +206,35 @@ Programy nieczęsto używane. W małych systemach można je pominąć.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-#%patch2 -p1
-%patch3 -p1
-%{?with_shared:%patch4 -p1}
-#%patch5 -p1
-
-# ugh, too populated to patch
-%{__sed} -i -e 's/instead DES/instead of DES/' src/chpasswd.c po/*.po
-
-rm -f po/stamp-po
 
 %build
-%{__autoheader}
-%{__gettextize}
-%{__aclocal}
-%{__autoconf}
-%{__automake}
 %configure \
-       --disable-desrpc \
        %{?with_shared:--enable-shared --disable-static} \
        --without-libcrack \
-       --with-libcrypt \
+       --without-tcb \
+       --with-sha-crypt \
+       --with-nscd \
+       --with-audit \
+       --with-acl \
+       --with-attr \
        --with-libpam \
-       --with-md5crypt \
-       --with-nls \
+       --enable-nls \
+       --enable-shadowgrp \
        %{?with_selinux:--with-selinux} \
-       --without-included-gettext
+       --with-group-name-max-length=32
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/{default,pam.d,security,skel/tmp}
+install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/{default,pam.d,security,skel/tmp}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# move nologin "shell" where useradd specifies it
+%{__mv} $RPM_BUILD_ROOT%{_sbindir}/nologin $RPM_BUILD_ROOT/sbin
+
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/chage
@@ -266,20 +254,6 @@ install etc/pam.d/groupdel $RPM_BUILD_ROOT/etc/pam.d/groupdel
 > $RPM_BUILD_ROOT/etc/security/chfn.allow
 > $RPM_BUILD_ROOT/etc/security/chsh.allow
 
-# vigr symlink is created by make install, but in wrong dir
-ln -sf vipw $RPM_BUILD_ROOT%{_sbindir}/vigr
-
-# what's this for?
-echo '.so newgrp.1' > $RPM_BUILD_ROOT%{_mandir}/it/man1/sg.1
-
-%if !%{with shared}
-# invalid static library
-rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
-%endif
-
-# no -devel, be gone
-rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
-
 %find_lang %{name}
 
 %clean
@@ -300,26 +274,34 @@ fi
 %attr(640,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/default/*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chage
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chpasswd
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chgpasswd
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/groupmems
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/newusers
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/passwd
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/shadow
+#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/shadow
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/useradd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/usermod
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/userdel
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/groupadd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/groupdel
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/groupmod
+
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/login.defs
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_sysconfdir}/shadow
 %dir /etc/skel
 %dir /etc/skel/tmp
 %{?with_shared:%attr(755,root,root) %{_libdir}/lib*.so.*.*}
+%attr(755,root,root) /sbin/nologin
 %attr(755,root,root) %{_sbindir}/chpasswd
+%attr(755,root,root) %{_sbindir}/chgpasswd
 %attr(755,root,root) %{_sbindir}/groupadd
 %attr(755,root,root) %{_sbindir}/groupdel
+%attr(755,root,root) %{_sbindir}/groupmems
 %attr(755,root,root) %{_sbindir}/groupmod
 %attr(755,root,root) %{_sbindir}/grpck
 %attr(755,root,root) %{_sbindir}/grpconv
 %attr(755,root,root) %{_sbindir}/grpunconv
+%attr(755,root,root) %{_sbindir}/logoutd
 %attr(755,root,root) %{_sbindir}/pwck
 %attr(755,root,root) %{_sbindir}/pwconv
 %attr(755,root,root) %{_sbindir}/pwunconv
@@ -329,6 +311,7 @@ fi
 %attr(755,root,root) %{_sbindir}/vigr
 %attr(755,root,root) %{_sbindir}/vipw
 %attr(755,root,root) %{_bindir}/faillog
+%attr(755,root,root) %{_bindir}/groups
 %attr(755,root,root) %{_bindir}/lastlog
 %attr(4755,root,root) %{_bindir}/passwd
 %{_mandir}/man1/passwd.1*
@@ -371,13 +354,6 @@ fi
 %lang(de) %{_mandir}/de/man8/vipw.8*
 %lang(de) %{_mandir}/de/man5/passwd.5*
 
-%lang(es) %{_mandir}/es/man1/passwd.1*
-%lang(es) %{_mandir}/es/man5/passwd.5*
-%lang(es) %{_mandir}/es/man8/vigr.8*
-%lang(es) %{_mandir}/es/man8/vipw.8*
-
-%lang(fi) %{_mandir}/fi/man1/passwd.1*
-
 %lang(fr) %{_mandir}/fr/man1/passwd.1*
 %lang(fr) %{_mandir}/fr/man5/faillog.5*
 %lang(fr) %{_mandir}/fr/man5/login.defs.5*
@@ -451,30 +427,21 @@ fi
 %lang(ko) %{_mandir}/ko/man8/vigr.8*
 %lang(ko) %{_mandir}/ko/man8/vipw.8*
 
-%lang(pl) %{_mandir}/pl/man1/passwd.1*
+%lang(pl) %{_mandir}/pl/man1/groups.1*
 %lang(pl) %{_mandir}/pl/man5/faillog.5*
-%lang(pl) %{_mandir}/pl/man5/login.defs.5*
-%lang(pl) %{_mandir}/pl/man5/passwd.5*
-%lang(pl) %{_mandir}/pl/man5/shadow.5*
-%lang(pl) %{_mandir}/pl/man5/suauth.5*
 %lang(pl) %{_mandir}/pl/man8/faillog.8*
 %lang(pl) %{_mandir}/pl/man8/groupadd.8*
 %lang(pl) %{_mandir}/pl/man8/groupdel.8*
+%lang(pl) %{_mandir}/pl/man8/groupmems.8*
 %lang(pl) %{_mandir}/pl/man8/groupmod.8*
 %lang(pl) %{_mandir}/pl/man8/grpck.8*
-%lang(pl) %{_mandir}/pl/man8/grpconv.8*
-%lang(pl) %{_mandir}/pl/man8/grpunconv.8*
 %lang(pl) %{_mandir}/pl/man8/lastlog.8*
-%lang(pl) %{_mandir}/pl/man8/pwck.8*
-%lang(pl) %{_mandir}/pl/man8/pwconv.8*
-%lang(pl) %{_mandir}/pl/man8/pwunconv.8*
-%lang(pl) %{_mandir}/pl/man8/useradd.8*
+%lang(pl) %{_mandir}/pl/man8/logoutd.8*
 %lang(pl) %{_mandir}/pl/man8/userdel.8*
 %lang(pl) %{_mandir}/pl/man8/usermod.8*
 %lang(pl) %{_mandir}/pl/man8/vigr.8*
 %lang(pl) %{_mandir}/pl/man8/vipw.8*
 
-# FIXME change to -> pt?
 %lang(pt_BR) %{_mandir}/pt_BR/man5/passwd.5*
 %lang(pt_BR) %{_mandir}/pt_BR/man5/shadow.5*
 %lang(pt_BR) %{_mandir}/pt_BR/man8/groupadd.8*
@@ -562,8 +529,6 @@ fi
 %lang(de) %{_mandir}/de/man1/chsh.1*
 %lang(de) %{_mandir}/de/man1/newgrp.1*
 
-%lang(es) %{_mandir}/es/man1/newgrp.1*
-
 %lang(fi) %{_mandir}/fi/man1/chfn.1*
 %lang(fi) %{_mandir}/fi/man1/chsh.1*
 
@@ -623,14 +588,10 @@ fi
 %lang(ru) %{_mandir}/ru/man8/newusers.8*
 
 %lang(pl) %{_mandir}/pl/man1/chage.1*
-%lang(pl) %{_mandir}/pl/man1/chfn.1*
 %lang(pl) %{_mandir}/pl/man1/chsh.1*
 %lang(pl) %{_mandir}/pl/man1/expiry.1*
-%lang(pl) %{_mandir}/pl/man1/gpasswd.1*
 %lang(pl) %{_mandir}/pl/man1/newgrp.1*
 %lang(pl) %{_mandir}/pl/man1/sg.1*
-%lang(pl) %{_mandir}/pl/man8/chpasswd.8*
-%lang(pl) %{_mandir}/pl/man8/newusers.8*
 
 %lang(pt_BR) %{_mandir}/pt_BR/man1/gpasswd.1*
 
This page took 0.080449 seconds and 4 git commands to generate.