]> git.pld-linux.org Git - packages/scm.git/blob - scm.spec
- new
[packages/scm.git] / scm.spec
1 %define slib_ver        3b4
2 Summary:        Scheme implementation
3 Summary(pl.UTF-8):      Implementacja Scheme
4 Name:           scm
5 Version:        5f1
6 Release:        1
7 License:        LGPL v3+
8 Group:          Development/Languages/Scheme
9 Source0:        http://groups.csail.mit.edu/mac/ftpdir/scm/%{name}-%{version}.zip
10 # Source0-md5:  98be8275f5c69d234c55a8a995a500dd
11 Source1:        http://groups.csail.mit.edu/mac/ftpdir/scm/slib-%{slib_ver}.tar.gz
12 # Source1-md5:  dcada65c4df4209c8f71211095bcef8e
13 Patch0:         %{name}-info.patch
14 Patch1:         %{name}-install.patch
15 Patch2:         %{name}-texinfo.patch
16 URL:            http://people.csail.mit.edu/jaffer/SCM
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  texinfo
19 Requires:       slib >= %{slib_ver}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 SCM is a portable Scheme language implementation. SCM conforms to
24 Revised^5 Report on the Algorithmic Language Scheme and the IEEE P1178
25 specification.
26
27 %description -l pl.UTF-8
28 SCM jest przenośną implementacją języka Scheme. SCM jest zgodna ze
29 specyfikacją Revised^5 Report on the Algorithmic Language Scheme oraz
30 IEEE P1178.
31
32 %prep
33 %setup -q -c -a1
34 %patch0 -p0
35 %patch1 -p0
36 %patch2 -p0
37
38 ln -s slib-%{slib_ver} slib
39
40 %{__sed} -i -e 's/install-lib install-infoz /install-lib install-info /' scm/Makefile
41
42 %build
43 cd scm
44 # not autoconf-generated
45 ./configure \
46         --prefix=%{_prefix} \
47         --libdir=%{_libdir}
48
49 %{__make} scm.info Xlibscm.info hobbit.info
50
51 %{__make} scmlit \
52         CC="%{__cc} %{rpmcflags}" \
53         LD="%{__cc} %{rpmldflags} %{rpmcflags}"
54 %{__make} all \
55         CC="%{__cc} %{rpmcflags}" \
56         LD="%{__cc} %{rpmldflags} %{rpmcflags}"
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} -C scm install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 # let rpm autogenerate depecdencies
65 chmod 755 $RPM_BUILD_ROOT%{_libdir}/scm/*.so
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post   -p /sbin/postshell
71 -/usr/sbin/fix-info-dir -c %{_infodir}
72
73 %postun -p /sbin/postshell
74 -/usr/sbin/fix-info-dir -c %{_infodir}
75
76 %files
77 %defattr(644,root,root,755)
78 %doc scm/{ANNOUNCE,ChangeLog,QUICKREF,README}
79 %attr(755,root,root) %{_bindir}/scm
80 %attr(755,root,root) %{_bindir}/scmlit
81 %dir %{_libdir}/scm
82 %attr(755,root,root) %{_libdir}/scm/*.so
83 %attr(755,root,root) %{_libdir}/scm/build
84 %{_libdir}/scm/*.scm
85 %{_libdir}/scm/*.h
86 %{_libdir}/scm/COPYING
87 %{_libdir}/scm/COPYING.LESSER
88 %{_includedir}/scm.h
89 %{_includedir}/scmfig.h
90 %{_includedir}/scmflags.h
91 %{_mandir}/man1/scm.1*
92 %{_infodir}/Xlibscm.info*
93 %{_infodir}/hobbit.info*
94 %{_infodir}/scm.info*
This page took 0.058136 seconds and 3 git commands to generate.