]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
5b8c5136075c1e0906c47b02d8dee5ddad550607
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.65.0
25 %define         bootstrap_cargo %{bootstrap_rust}
26 %define         bootstrap_date  2022-11-03
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.66.1
40 Release:        1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  96b082a8b44707eafa9d696923f40c28
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  74858f078f2e16ccf2a0b5ce2cb08557
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  d5819e8f1fed42b8c4e7e996da7fba4f
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  81f3f09ab36e7b800775024d277e27fd
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  7bf66e055741fddaf3f82efe6eeb83b7
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  a4bbebeed5c0d2f79f362dd7d3619769
56 Patch0:         no-install-miri.patch
57 URL:            https://www.rust-lang.org/
58 # for src/compiler-rt
59 BuildRequires:  cmake >= 3.4.3
60 BuildRequires:  curl
61 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
62 BuildRequires:  procps
63 BuildRequires:  python3
64 BuildRequires:  python3-modules
65 BuildRequires:  rpm-build >= 4.6
66 BuildRequires:  rpmbuild(macros) >= 1.752
67 %if %{without cross}
68 BuildRequires:  curl-devel
69 BuildRequires:  libgit2-devel >= 1.4.0
70 BuildRequires:  libstdc++-devel
71 %if %{with system_llvm}
72 BuildRequires:  llvm >= 13.0
73 BuildRequires:  llvm-devel >= 13.0
74 %endif
75 BuildRequires:  openssl-devel >= 1.0.1
76 BuildRequires:  tar >= 1:1.22
77 BuildRequires:  xz
78 BuildRequires:  xz-devel
79 BuildRequires:  zlib-devel
80 %endif
81 %if %{without bootstrap}
82 BuildRequires:  %{name} >= %{bootstrap_rust}
83 BuildRequires:  cargo >= %{bootstrap_cargo}
84 BuildConflicts: %{name} > %{version}
85 %endif
86 %ifarch x32
87 BuildRequires:  glibc-devel(x86-64)
88 BuildRequires:  glibc-devel(x86-x32)
89 %if "%{_host_cpu}" == "x86_64"
90 # building on x86_64 host with --target x32-pld-linux
91 BuildRequires:  curl-devel
92 BuildRequires:  gcc-multilib-x32
93 BuildRequires:  libgit2-devel >= 1.4.0
94 BuildRequires:  libstdc++-devel
95 %{?with_system_llvm:BuildRequires:      llvm-devel >= 13.0}
96 BuildRequires:  openssl-devel >= 1.0.1
97 BuildRequires:  xz-devel
98 BuildRequires:  zlib-devel
99 %else
100 # building x86_64-hosted crosscompiler on x32 host
101 BuildRequires:  curl-devel(x86-64)
102 BuildRequires:  curl-devel(x86-x32)
103 BuildRequires:  gcc-multilib-64
104 BuildRequires:  libgit2-devel(x86-64) >= 1.4.0
105 BuildRequires:  libgit2-devel(x86-x32) >= 1.4.0
106 BuildRequires:  libstdc++-multilib-64-devel
107 %if %{with system_llvm}
108 BuildRequires:  llvm-devel(x86-64) >= 13.0
109 BuildRequires:  llvm-devel(x86-x32) >= 13.0
110 %endif
111 BuildRequires:  openssl-devel(x86-64)
112 BuildRequires:  openssl-devel(x86-x32)
113 BuildRequires:  xz-devel(x86-64)
114 BuildRequires:  xz-devel(x86-x32)
115 BuildRequires:  zlib-devel(x86-64)
116 BuildRequires:  zlib-devel(x86-x32)
117 %endif
118 %endif
119 # The C compiler is needed at runtime just for linking.  Someday rustc might
120 # invoke the linker directly, and then we'll only need binutils.
121 # https://github.com/rust-lang/rust/issues/11937
122 Requires:       gcc
123 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
124 %ifarch x32
125 Requires:       %{name}-std(x86-64) = %{version}-%{release}
126 Requires:       gcc-multilib-64
127 %endif
128 # Only x86_64 and i686 are Tier 1 platforms at this time.
129 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
130 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
131 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
132 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
133
134 %ifarch x32
135 %define         rust_triple             x86_64-unknown-linux-gnux32
136 %define         rust_host_triple        x86_64-unknown-linux-gnu
137 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
138 # libs in _libdir are x86_64 64bit
139 %define         _lib                    lib64
140 %define         _libdir                 %{_prefix}/lib64
141 %else
142 %ifarch armv6hl
143 %define         rust_triple             arm-unknown-linux-gnueabihf
144 %define         rust_host_triple        %{rust_triple}
145 %define         rust_bootstrap_triple   %{rust_triple}
146 %else
147 %ifarch armv7hl armv7hnl
148 %define         rust_triple             armv7-unknown-linux-gnueabihf
149 %define         rust_host_triple        %{rust_triple}
150 %define         rust_bootstrap_triple   %{rust_triple}
151 %define         rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
152 %else
153 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
154 %define         rust_host_triple        %{rust_triple}
155 %define         rust_bootstrap_triple   %{rust_triple}
156 %endif
157 %endif
158 %endif
159
160 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
161
162 %if %{without bootstrap}
163 %define         local_rust_root %{_prefix}
164 %else
165 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
166 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
167 %endif
168
169 # We're going to override --libdir when configuring to get rustlib into a
170 # common path, but we'll fix the shared libraries during install.
171 # Without this ugly hack, rust would not be able to build itself
172 # for non-bootstrap build, lib64 is just too complicated for it.
173 %define         common_libdir   %{_prefix}/lib
174 %define         rustlibdir      %{common_libdir}/rustlib
175
176 # once_call/once_callable non-function libstdc++ symbols
177 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
178
179 # ALL Rust libraries are private, because they don't keep an ABI.
180 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
181 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
182
183 %define         x_py { \
184         x_py() { \
185                 local cmd="$1"; \
186                 shift; \
187                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
188         }; x_py }
189
190
191 %description
192 Rust is a systems programming language that runs blazingly fast,
193 prevents segfaults, and guarantees thread safety.
194
195 This package includes the Rust compiler, standard library, and
196 documentation generator.
197
198 %description -l pl.UTF-8
199 Rust to systemowy język programowania działający bardzo szybko,
200 zapobiegający naruszeniom ochrony pamięci i gwarantujący
201 bezpieczną wielowątkowość.
202
203 %package analysis
204 Summary:        Metadata about the standard library
205 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
206 Group:          Development/Tools
207 Requires:       %{name} = %{version}-%{release}
208
209 %description analysis
210 Metadata about the standard library.
211
212 %description analysis -l pl.UTF-8
213 Metadane o standardowej bibliotece.
214
215 %package std
216 Summary:        Standard library for Rust
217 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
218 Group:          Development/Tools
219 Requires:       %{name} = %{version}-%{release}
220
221 %description std
222 Standard library for Rust.
223
224 %description std -l pl.UTF-8
225 Standardowa biblioteka Rusta.
226
227 %package analyzer
228 Summary:        Implementation of Language Server Protocol for Rust
229 Summary(pl.UTF-8):      Implementacja Language Server Protocol dla Rusta
230 Group:          Development/Tools
231 Requires:       %{name} = %{version}-%{release}
232 Obsoletes:      rust-rls < 1.65.0
233
234 %description analyzer
235 Implementation of Language Server Protocol for Rust.
236
237 %description analyzer -l pl.UTF-8
238 Implementacja Language Server Protocol dla Rusta.
239
240 %package debugger-common
241 Summary:        Common debugger pretty printers for Rust
242 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
243 Group:          Development/Debuggers
244 BuildArch:      noarch
245
246 %description debugger-common
247 This package includes the common functionality for rust-gdb and
248 rust-lldb.
249
250 %description debugger-common -l pl.UTF-8
251 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
252
253 %package gdb
254 Summary:        GDB pretty printers for Rust
255 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
256 Group:          Development/Debuggers
257 Requires:       %{name}-debugger-common = %{version}-%{release}
258 Requires:       gdb
259 BuildArch:      noarch
260
261 %description gdb
262 This package includes the rust-gdb script, which allows easier
263 debugging of Rust programs.
264
265 %description gdb -l pl.UTF-8
266 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
267 odpluskwianie programów w języku Rust.
268
269 %package lldb
270 Summary:        LLDB pretty printers for Rust
271 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
272 Group:          Development/Debuggers
273 Requires:       %{name}-debugger-common = %{version}-%{release}
274 Requires:       lldb
275 BuildArch:      noarch
276
277 %description lldb
278 This package includes the rust-lldb script, which allows easier
279 debugging of Rust programs.
280
281 %description lldb -l pl.UTF-8
282 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
283 odpluskwianie programów w języku Rust.
284
285 %package doc
286 Summary:        Documentation for Rust
287 Summary(pl.UTF-8):      Dokumentacja do Rusta
288 Group:          Documentation
289 BuildArch:      noarch
290
291 %description doc
292 This package includes HTML documentation for the Rust programming
293 language and its standard library.
294
295 %description doc -l pl.UTF-8
296 Ten pakiet zawiera dokumentację w formacie HTML do języka
297 programowania Rust i jego biblioteki standardowej.
298
299 %package -n cargo
300 Summary:        Rust's package manager and build tool
301 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
302 Group:          Development/Tools
303 Requires:       %{name}%{?_isa}
304
305 %description -n cargo
306 Cargo is a tool that allows Rust projects to declare their various
307 dependencies and ensure that you'll always get a repeatable build.
308
309 %description -n cargo -l pl.UTF-8
310 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
311 zależności i zapewniające powtarzalność procesu budowania.
312
313 %package -n bash-completion-cargo
314 Summary:        Bash completion for cargo command
315 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
316 Group:          Applications/Shells
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       bash-completion
319
320 %description -n bash-completion-cargo
321 Bash completion for cargo command.
322
323 %description -n bash-completion-cargo -l pl.UTF-8
324 Bashowe dopełnianie parametrów polecenia cargo.
325
326 %package -n zsh-completion-cargo
327 Summary:        Zsh completion for cargo command
328 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
329 Group:          Applications/Shells
330 Requires:       %{name} = %{version}-%{release}
331 Requires:       zsh
332
333 %description -n zsh-completion-cargo
334 Zsh completion for cargo command.
335
336 %description -n zsh-completion-cargo -l pl.UTF-8
337 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
338
339 %prep
340 %setup -q -n %{rustc_package}
341 %patch0 -p1
342
343 %if %{with bootstrap}
344 %ifarch %{x8664} x32
345 tar xf %{SOURCE1}
346 %endif
347 %ifarch %{ix86}
348 tar xf %{SOURCE2}
349 %endif
350 %ifarch aarch64
351 tar xf %{SOURCE3}
352 %endif
353 %ifarch armv6hl
354 tar xf %{SOURCE4}
355 %endif
356 %ifarch armv7hl armv7hnl
357 tar xf %{SOURCE5}
358 %endif
359 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
360 %{bootstrap_root}-root/install.sh \
361         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
362         --prefix=%{local_rust_root} \
363         --disable-ldconfig
364 test -f %{local_rust_root}/bin/cargo
365 test -f %{local_rust_root}/bin/rustc
366 %endif
367
368 # unbundle
369 # We're disabling jemalloc, but rust-src still wants it.
370 #%{__rm} -r src/jemalloc
371 %if %{with system_llvm}
372 %{__rm} -r src/llvm-project
373 mkdir -p src/llvm-project/libunwind
374 %endif
375
376 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
377 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
378         src/etc/rust-gdb
379
380 # cargo has hardcoded libexec path - honour rpm _libexecdir
381 %if "%{_libexecdir}" != "%{_prefix}/libexec"
382 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
383 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
384         src/bootstrap/dist.rs \
385         src/tools/cargo/src/cargo/ops/registry/auth.rs
386 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
387 %endif
388
389 # The configure macro will modify some autoconf-related files, which upsets
390 # cargo when it tries to verify checksums in those files.  If we just truncate
391 # that file list, cargo won't have anything to complain about.
392 find vendor -name .cargo-checksum.json \
393         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
394
395 %build
396 export CC="%{__cc}"
397 export CXX="%{__cxx}"
398 export AR="%{__ar}"
399 %configure \
400         --build=%{rust_bootstrap_triple} \
401         --host=%{rust_host_triple} \
402         --target="%(echo %rust_targets | tr ' ' ,)" \
403         --libdir=%{common_libdir} \
404         --disable-codegen-tests \
405         --disable-debuginfo-lines \
406 %if %{with full_debuginfo}
407         --disable-debuginfo-only-std \
408         --enable-debuginfo \
409 %else
410         --enable-debuginfo-only-std \
411         --disable-debuginfo \
412 %endif
413         --disable-jemalloc \
414         --disable-option-checking \
415         --disable-rpath \
416         --enable-extended \
417         --enable-llvm-link-shared \
418         --enable-vendor \
419         --local-rust-root=%{local_rust_root} \
420         --llvm-root=%{_prefix} \
421         --release-channel=%{channel} \
422         --set=llvm.static-libstdcpp=false
423
424 export RUST_BACKTRACE=full
425 %x_py dist --verbose
426
427 %{?with_tests:%x_py test}
428
429 %install
430 rm -rf $RPM_BUILD_ROOT
431
432 export CC="%{__cc}"
433 export CXX="%{__cxx}"
434 export AR="%{__ar}"
435 export DESTDIR=$RPM_BUILD_ROOT
436 %x_py install
437
438 # Make sure the shared libraries are in the proper libdir
439 %if "%{_libdir}" != "%{common_libdir}"
440 mkdir -p %{buildroot}%{_libdir}
441 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
442         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
443 %endif
444
445 # The shared libraries should be executable for debuginfo extraction.
446 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
447
448 # The libdir libraries are identical to those under rustlib/.  It's easier on
449 # library loading if we keep them in libdir, but we do need them in rustlib/
450 # to support dynamic linking for compiler plugins, so we'll symlink.
451 for rust_target in %rust_targets; do
452         for l in libstd libtest ; do
453                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
454                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
455                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
456                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
457                 fi
458         done
459 done
460
461 # Remove installer artifacts (manifests, uninstall scripts, etc.)
462 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
463
464 # FIXME: __os_install_post will strip the rlibs
465 # -- should we find a way to preserve debuginfo?
466
467 # Remove unwanted documentation files (we already package them)
468 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
469 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
470 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
471 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
472
473 # Sanitize the HTML documentation
474 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
475 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
476
477 # Move rust-gdb's python scripts so they're noarch
478 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
479 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
480
481 # We don't need stdlib source
482 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
483
484 # Create the path for crate-devel packages
485 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
486
487 %clean
488 rm -rf $RPM_BUILD_ROOT
489
490 %post   -p /sbin/ldconfig
491 %postun -p /sbin/ldconfig
492
493 %files
494 %defattr(644,root,root,755)
495 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
496 %attr(755,root,root) %{_bindir}/rust-demangler
497 %attr(755,root,root) %{_bindir}/rustc
498 %attr(755,root,root) %{_bindir}/rustdoc
499 %attr(755,root,root) %{_bindir}/rustfmt
500 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
501 %attr(755,root,root) %{_libdir}/libstd-*.so
502 %attr(755,root,root) %{_libdir}/libtest-*.so
503 %{_mandir}/man1/rustc.1*
504 %{_mandir}/man1/rustdoc.1*
505 %dir %{rustlibdir}
506
507 %files analysis
508 %defattr(644,root,root,755)
509 %(for rust_target in %rust_targets; do
510 echo "%{rustlibdir}/$rust_target/analysis"
511 done
512 )
513
514 %files std
515 %defattr(644,root,root,755)
516 %(for rust_target in %rust_targets; do
517 cat <<EOF
518 %dir %{rustlibdir}/$rust_target
519 %dir %{rustlibdir}/$rust_target/lib
520 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
521 %{rustlibdir}/$rust_target/lib/*.rlib
522 EOF
523 done
524 )
525
526 %files analyzer
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_bindir}/rust-analyzer
529 %attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
530
531 %files debugger-common
532 %defattr(644,root,root,755)
533 %dir %{_datadir}/%{name}
534 %dir %{_datadir}/%{name}/etc
535 %{_datadir}/%{name}/etc/lldb_commands
536 %{_datadir}/%{name}/etc/rust_types.py
537
538 %files lldb
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_bindir}/rust-lldb
541 %{_datadir}/%{name}/etc/lldb_*.py*
542
543 %files gdb
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_bindir}/rust-gdb
546 %attr(755,root,root) %{_bindir}/rust-gdbgui
547 %{_datadir}/%{name}/etc/gdb_*.py*
548
549 %files doc
550 %defattr(644,root,root,755)
551 %dir %{_docdir}/%{name}
552 %doc %{_docdir}/%{name}/html
553
554 %files -n cargo
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/cargo
557 %attr(755,root,root) %{_bindir}/cargo-clippy
558 %attr(755,root,root) %{_bindir}/cargo-fmt
559 %attr(755,root,root) %{_bindir}/clippy-driver
560 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
561 %{_mandir}/man1/cargo*.1*
562 %dir %{_datadir}/cargo
563 %dir %{_datadir}/cargo/registry
564
565 %files -n bash-completion-cargo
566 %defattr(644,root,root,755)
567 %{_sysconfdir}/bash_completion.d/cargo
568
569 %files -n zsh-completion-cargo
570 %defattr(644,root,root,755)
571 %{zsh_compdir}/_cargo
This page took 0.118568 seconds and 2 git commands to generate.