]> git.pld-linux.org Git - packages/ruby-rspec-expectations.git/blob - ruby-rspec-expectations.spec
c5f0c4710042fde2c1b3f903096c67ca79c88f52
[packages/ruby-rspec-expectations.git] / ruby-rspec-expectations.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 # test needs rspec-core, however rspec-core depends on rspec-mocks
5 # runtime part of rspec-mocks does not depend on rspec-core
6
7 %define pkgname rspec-expectations
8 Summary:        Rspec-2 expectations (should and matchers)
9 Summary(pl.UTF-8):      Oczekiwania Rspec-2 (should oraz matchers)
10 Name:           ruby-%{pkgname}
11 Version:        2.13.0
12 Release:        4
13 License:        MIT
14 Group:          Development/Languages
15 Source0:        http://rubygems.org/gems/%{pkgname}-%{version}.gem
16 # Source0-md5:  2873d31ef1f8f65d3a04ac40e27825a1
17 URL:            http://github.com/rspec/rspec-expectations
18 BuildRequires:  rpm-rubyprov
19 BuildRequires:  rpmbuild(macros) >= 1.656
20 %if %{with tests}
21 BuildRequires:  ruby-minitest
22 BuildRequires:  ruby-rspec
23 %endif
24 Requires:       ruby-diff-lcs
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 rspec-expectations adds `should` and `should_not` to every object and
30 includes RSpec::Matchers, a library of standard matchers.
31
32 %description -l pl.UTF-8
33 rspec-expectations dodaje `should` oraz `should_not` do każdego
34 obiektu oraz zawiera RSpec::Matchers - bibliotekę standardowych
35 funkcji dopasowujących.
36
37 %prep
38 %setup -q -n %{pkgname}-%{version}
39
40 %build
41 # write .gemspec
42 %__gem_helper spec
43
44 %if %{with tests}
45 ruby -rubygems -Ilib/ -S rspec spec/
46 %endif
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
51 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
52 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README.md Changelog.md License.txt
60 %{ruby_vendorlibdir}/rspec-expectations.rb
61 %{ruby_vendorlibdir}/rspec/matchers.rb
62 %{ruby_vendorlibdir}/rspec/matchers
63 %{ruby_vendorlibdir}/rspec/expectations.rb
64 %{ruby_vendorlibdir}/rspec/expectations
65 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.057097 seconds and 2 git commands to generate.