]> git.pld-linux.org Git - packages/ruby-net-ssh.git/blob - ruby-net-ssh.spec
up to 2.6.6
[packages/ruby-net-ssh.git] / ruby-net-ssh.spec
1 # TODO:
2 # - what to do with net subdir?
3 %define pkgname net-ssh
4 Summary:        Net::SSH - a pure-Ruby implementation of the SSH2 client protocol
5 Summary(pl.UTF-8):      Net::SSH - implementacja protokołu klienckiego SSH2 w czystym Rubym
6 Name:           ruby-%{pkgname}
7 Version:        2.6.6
8 Release:        1
9 License:        MIT
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
12 # Source0-md5:  1aeaa841f23f8d528ba02c2bedd6f696
13 URL:            http://github.com/net-ssh/net-ssh
14 BuildRequires:  rpm-rubyprov
15 BuildRequires:  rpmbuild(macros) >= 1.656
16 %if %(locale -a | grep -q '^en_US$'; echo $?)
17 BuildRequires:  glibc-localedb-all
18 %endif
19 Obsoletes:      ruby-Net-SSH
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Net::SSH is a pure-Ruby implementation of the SSH2 client protocol.
25
26 %description -l pl.UTF-8
27 Net::SSH to implementacja protokołu klienckiego SSH2 w czystym Rubym.
28
29 %package rdoc
30 Summary:        HTML documentation for %{pkgname}
31 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
32 Group:          Documentation
33 Requires:       ruby >= 1:1.8.7-4
34
35 %description rdoc
36 HTML documentation for %{pkgname}.
37
38 %description rdoc -l pl.UTF-8
39 Dokumentacja w formacie HTML dla %{pkgname}.
40
41 %package ri
42 Summary:        ri documentation for %{pkgname}
43 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
44 Group:          Documentation
45 Requires:       ruby
46
47 %description ri
48 ri documentation for %{pkgname}.
49
50 %description ri -l pl.UTF-8
51 Dokumentacji w formacie ri dla %{pkgname}.
52
53 %prep
54 %setup -q -n %{pkgname}-%{version}
55
56 %build
57 # UTF8 locale needed for doc generation
58 export LC_ALL=en_US.UTF-8
59 rdoc --ri --op ri lib
60 rdoc --op rdoc lib
61 rm -r ri/{OpenSSL,String}
62 rm ri/Net/cdesc-Net.ri
63 rm ri/created.rid
64 rm ri/cache.ri
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_ridir},%{ruby_rdocdir}/%{name}-%{version}}
69
70 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
71 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
72 cp -a rdoc/* $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README.rdoc CHANGES.txt THANKS.txt LICENSE.txt
80 # XXX?
81 %dir %{ruby_vendorlibdir}/net
82 %{ruby_vendorlibdir}/net/ssh.rb
83 %{ruby_vendorlibdir}/net/ssh
84
85 %files rdoc
86 %defattr(644,root,root,755)
87 %{ruby_rdocdir}/%{name}-%{version}
88
89 %files ri
90 %defattr(644,root,root,755)
91 # XXX?
92 %dir %{ruby_ridir}/Net
93 %{ruby_ridir}/Net/SSH
This page took 0.07931 seconds and 3 git commands to generate.