]> git.pld-linux.org Git - packages/ruby-berkshelf.git/blob - ruby-berkshelf.spec
new, version 1.4.0
[packages/ruby-berkshelf.git] / ruby-berkshelf.spec
1 %define pkgname berkshelf
2 Summary:        Manages a Cookbook's, or an Application's, Cookbook dependencies
3 Name:           ruby-%{pkgname}
4 Version:        1.4.0
5 Release:        0.1
6 License:        Distributable
7 Group:          Development/Languages
8 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9 # Source0-md5:  18f3049da4bb12dd90b9f51e58b7f416
10 URL:            http://berkshelf.com
11 BuildRequires:  rpm-rubyprov
12 BuildRequires:  rpmbuild(macros) >= 1.656
13 Requires:       ruby-activesupport >= 3.2.0
14 Requires:       ruby-addressable
15 Requires:       ruby-aruba
16 Requires:       ruby-cane
17 Requires:       ruby-celluloid >= 0.13.0
18 Requires:       ruby-chozo >= 0.6.1
19 Requires:       ruby-faraday >= 0.8.5
20 Requires:       ruby-hashie >= 2.0.2
21 Requires:       ruby-json >= 1.5.0
22 Requires:       ruby-json_spec
23 Requires:       ruby-minitar
24 Requires:       ruby-mixlib-config < 2
25 Requires:       ruby-mixlib-config => 1.1
26 Requires:       ruby-mixlib-shellout < 2
27 Requires:       ruby-mixlib-shellout => 1.1
28 Requires:       ruby-multi_json < 2
29 Requires:       ruby-multi_json => 1.5
30 Requires:       ruby-rake >= 0.9.2.2
31 Requires:       ruby-retryable
32 Requires:       ruby-ridley < 0.10
33 Requires:       ruby-ridley => 0.9.0
34 Requires:       ruby-rspec
35 Requires:       ruby-simplecov
36 Requires:       ruby-solve >= 0.4.2
37 Requires:       ruby-spork
38 Requires:       ruby-thor
39 Requires:       ruby-thor < 0.19
40 Requires:       ruby-thor => 0.18.0
41 Requires:       ruby-vcr < 2.5
42 Requires:       ruby-vcr => 2.4.0
43 Requires:       ruby-webmock
44 Requires:       ruby-yajl-ruby
45 BuildArch:      noarch
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Manages a Cookbook's, or an Application's, Cookbook dependencies
50
51 %prep
52 %setup -q -n %{pkgname}-%{version}
53
54 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
59 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
60 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %attr(755,root,root) %{_bindir}/berks
68 %{ruby_vendorlibdir}/%{pkgname}.rb
69 %{ruby_vendorlibdir}/%{pkgname}
70
71 # addons to thor
72 %{ruby_vendorlibdir}/thor/monkies.rb
73 %{ruby_vendorlibdir}/thor/monkies
This page took 0.088711 seconds and 3 git commands to generate.