]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
- leak less vars
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 9 Dec 2011 19:00:00 +0000 (19:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-build.sh -> 1.67

rpm-build.sh

index c481981fe709f8a1fde215908c20a02e0de3f3e8..5aec8114c04b32057e1d9c8420fdb994b756babc 100644 (file)
@@ -203,7 +203,7 @@ urldiff() {
 # makes diff from kde svn path
 # requires: wget, tee
 kdediff() {
-       local url="$1"
+       local url="$1" r1 r2
        # --- branches/KDE/3.5/kdepim/kpilot/conduits/vcalconduit/vcalRecord.cc #624744:624745
        url=${url#*--- }
        echo >&2 "Process $url"
@@ -279,7 +279,7 @@ cvslog() {
 # the diff can be applied with patch -p1
 d() {
        local file="$1"
-       local dir
+       local dir diff
        if [[ "$file" = /* ]]; then
                # full path -- no idea where to strip
                dir=.
@@ -292,8 +292,9 @@ d() {
 
        (builtin cd "$dir"; dif $diff{~,})
 }
+
 rpmb() {
-       local SPEC SPECDIR
+       local SPEC SPECDIR arg
        for arg in "$@"; do
                case "$arg" in
                        *.spec) SPEC="$arg"
This page took 0.156904 seconds and 4 git commands to generate.