]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
- py_lint: fix files counting auto/th/rpm-build-macros-1_606-1
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 23 Feb 2011 10:46:36 +0000 (10:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-build-macros.spec -> 1.288
    rpm.macros -> 1.606

rpm-build-macros.spec
rpm.macros

index f58002af1db6ae3a1e51d28ef96c00b557ee19ca..886fa04cee927100cebdafd7a2768b5ab834a16b 100644 (file)
@@ -1,4 +1,4 @@
-%define                rpm_macros_rev  1.602
+%define                rpm_macros_rev  1.606
 %define                find_lang_rev   1.34
 Summary:       PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
index f6b074a0083ed42269e7099f60185dcee8300e56..5b816901c6a35700e64b8f41b4da0c131cb9fe0a 100644 (file)
@@ -1867,13 +1867,14 @@ import compiler \
 \
 found = err = 0\
 for f in sys.stdin: \
-       fd = open(f.strip()) \
+       fd = open(f.rstrip()) \
        c = fd.read() \
        fd.close() \
+       found = found + 1 \
        try: \
                compiler.parse(c) \
        except SyntaxError, e: \
-               print "py_lint: %s: %s" % (f.strip(), e) \
+               print "py_lint: %s: %s" % (f.rstrip(), e) \
                err = err + 1\
 \
 if not found:\
@@ -1883,7 +1884,7 @@ elif err: \
        print >> sys.stderr, "\\npy_lint: ERROR: Syntax errors in %d files.\\n" % err \
        sys.exit(1) \
 else: \
-       print >> sys.stderr,  "py_lint: Found no syntax errors." \
+       print >> sys.stderr,  "py_lint: %d files scanned, found no syntax errors." % found \
 ' \
 }; __py_lint %* \
 %{nil}
This page took 0.042551 seconds and 4 git commands to generate.