]> git.pld-linux.org Git - packages/qt5-qtwebengine.git/blob - qt5-qtwebengine.spec
664bb712430b410171554af0ad3e21bd1894731d
[packages/qt5-qtwebengine.git] / qt5-qtwebengine.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtwebengine
6 %define         qtbase_ver              %{version}
7 %define         qtdeclarative_ver       %{version}
8 %define         qttools_ver             %{version}
9 %define         qtwebchannel_ver        %{version}
10 Summary:        The Qt5 WebEngine library
11 Summary(pl.UTF-8):      Biblioteka Qt5 WebEngine
12 Name:           qt5-%{orgname}
13 Version:        5.5.1
14 Release:        0.1
15 License:        LGPL v3 or GPL v2+ or commercial
16 Group:          X11/Libraries
17 Source0:        http://download.qt.io/official_releases/qt/5.5/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
18 # Source0-md5:  2a548bde706e8639cdec2cbe31d85545
19 URL:            http://www.qt.io/
20 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
21 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
22 BuildRequires:  Qt5Network-devel >= %{qtbase_ver}
23 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
24 BuildRequires:  Qt5Quick-devel >= %{qtdeclarative_ver}
25 BuildRequires:  Qt5WebChannel-devel >= %{qtwebchannel_ver}
26 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
27 %if %{with doc}
28 BuildRequires:  qt5-assistant >= %{qttools_ver}
29 %endif
30 BuildRequires:  qt5-build >= %{qtbase_ver}
31 BuildRequires:  qt5-qmake >= %{qtbase_ver}
32 BuildRequires:  rpmbuild(macros) >= 1.654
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         specflags       -fno-strict-aliasing
38 %define         qt5dir          %{_libdir}/qt5
39
40 %description
41 Qt is a cross-platform application and UI framework. Using Qt, you can
42 write web-enabled applications once and deploy them across desktop,
43 mobile and embedded systems without rewriting the source code.
44
45 This package contains Qt5 WebEngine library.
46
47 %description -l pl.UTF-8
48 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
49 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
50 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
51 źródłowego.
52
53 Ten pakiet zawiera bibliotekę Qt5 WebEngine.
54
55 %package -n Qt5WebEngine
56 Summary:        The Qt5 WebEngine library
57 Summary(pl.UTF-8):      Biblioteka Qt5 WebEngine
58 Group:          Libraries
59 Requires:       Qt5Core >= %{qtbase_ver}
60 Requires:       Qt5Network >= %{qtbase_ver}
61 Requires:       Qt5Qml >= %{qtdeclarative_ver}
62
63 %description -n Qt5WebEngine
64 Qt5 WebEngine library provides seamless integration of C++ and QML
65 applications with HTML/JavaScript clients.
66
67 %description -n Qt5WebEngine -l pl.UTF-8
68 Biblioteka Qt5 WebEngine udostępnia integrację aplikacji C++ i QML z
69 klientami w HTML-u/JavaScripcie.
70
71 %package -n Qt5WebEngine-devel
72 Summary:        Qt5 WebEngine library - development files
73 Summary(pl.UTF-8):      Biblioteka Qt5 WebEngine - pliki programistyczne
74 Group:          Development/Libraries
75 Requires:       Qt5Core-devel >= %{qtbase_ver}
76 Requires:       Qt5Network-devel >= %{qtbase_ver}
77 Requires:       Qt5Qml-devel >= %{qtdeclarative_ver}
78 Requires:       Qt5WebEngine = %{version}-%{release}
79
80 %description -n Qt5WebEngine-devel
81 Qt5 WebEngine library - development files.
82
83 %description -n Qt5WebEngine-devel -l pl.UTF-8
84 Biblioteka Qt5 WebEngine - pliki programistyczne.
85
86 %package doc
87 Summary:        Qt5 WebEngine documentation in HTML format
88 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 WebEngine w formacie HTML
89 Group:          Documentation
90 Requires:       qt5-doc-common >= %{qtbase_ver}
91 %if "%{_rpmversion}" >= "5"
92 BuildArch:      noarch
93 %endif
94
95 %description doc
96 Qt5 WebEngine documentation in HTML format.
97
98 %description doc -l pl.UTF-8
99 Dokumentacja do biblioteki Qt5 WebEngine w formacie HTML.
100
101 %package doc-qch
102 Summary:        Qt5 WebEngine documentation in QCH format
103 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 WebEngine w formacie QCH
104 Group:          Documentation
105 Requires:       qt5-doc-common >= %{qtbase_ver}
106 %if "%{_rpmversion}" >= "5"
107 BuildArch:      noarch
108 %endif
109
110 %description doc-qch
111 Qt5 WebEngine documentation in QCH format.
112
113 %description doc-qch -l pl.UTF-8
114 Dokumentacja do biblioteki Qt5 WebEngine w formacie QCH.
115
116 %package examples
117 Summary:        Qt5 WebEngine examples
118 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 WebEngine
119 Group:          X11/Development/Libraries
120 %if "%{_rpmversion}" >= "5"
121 BuildArch:      noarch
122 %endif
123
124 %description examples
125 Qt5 WebEngine examples.
126
127 %description examples -l pl.UTF-8
128 Przykłady do biblioteki Qt5 WebEngine.
129
130 %prep
131 %setup -q -n %{orgname}-opensource-src-%{version}
132
133 %build
134 qmake-qt5
135 %{__make}
136 %{?with_doc:%{__make} docs}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 %{__make} install \
141         INSTALL_ROOT=$RPM_BUILD_ROOT
142
143 %if %{with doc}
144 %{__make} install_docs \
145         INSTALL_ROOT=$RPM_BUILD_ROOT
146 %endif
147
148 # useless symlinks
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
150 # actually drop *.la, follow policy of not packaging them when *.pc exist
151 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
152
153 # Prepare some files list
154 ifecho() {
155         r="$RPM_BUILD_ROOT$2"
156         if [ -d "$r" ]; then
157                 echo "%%dir $2" >> $1.files
158         elif [ -x "$r" ] ; then
159                 echo "%%attr(755,root,root) $2" >> $1.files
160         elif [ -f "$r" ]; then
161                 echo "$2" >> $1.files
162         else
163                 echo "Error generation $1 files list!"
164                 echo "$r: no such file or directory!"
165                 return 1
166         fi
167 }
168 ifecho_tree() {
169         ifecho $1 $2
170         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
171                 ifecho $1 $2/$f
172         done
173 }
174
175 echo "%defattr(644,root,root,755)" > examples.files
176 ifecho_tree examples %{_examplesdir}/qt5/qwebengine
177 ifecho_tree examples %{_examplesdir}/qt5/webengine
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post   -n Qt5WebEngine -p /sbin/ldconfig
183 %postun -n Qt5WebEngine -p /sbin/ldconfig
184
185 %files -n Qt5WebEngine
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libQt5WebEngine.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libQt5WebEngine.so.5
189 %dir %{qt5dir}/qml/QtWebEngine
190 %attr(755,root,root) %{qt5dir}/qml/QtWebEngine/libdeclarative_webengine.so
191 %{qt5dir}/qml/QtWebEngine/plugins.qmltypes
192 %{qt5dir}/qml/QtWebEngine/qmldir
193
194 %files -n Qt5WebEngine-devel
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libQt5WebEngine.so
197 %{_libdir}/libQt5WebEngine.prl
198 %{_includedir}/qt5/QtWebEngine
199 %{_pkgconfigdir}/Qt5WebEngine.pc
200 %{_libdir}/cmake/Qt5WebEngine
201 %{qt5dir}/mkspecs/modules/qt_lib_webengine.pri
202 %{qt5dir}/mkspecs/modules/qt_lib_webengine_private.pri
203
204 %if %{with doc}
205 %files doc
206 %defattr(644,root,root,755)
207 %{_docdir}/qt5-doc/qtwebengine
208
209 %files doc-qch
210 %defattr(644,root,root,755)
211 %{_docdir}/qt5-doc/qtwebengine.qch
212 %endif
213
214 %files examples -f examples.files
215 %defattr(644,root,root,755)
216 # XXX: dir shared with qt5-qtbase-examples
217 %dir %{_examplesdir}/qt5
This page took 0.127966 seconds and 2 git commands to generate.