]> git.pld-linux.org Git - packages/qt5-qtwebchannel.git/commitdiff
- rename qch bcond to doc (all docs require qtassistant now)
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 23 May 2017 10:13:58 +0000 (12:13 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 23 May 2017 10:13:58 +0000 (12:13 +0200)
qt5-qtwebchannel.spec

index f8f573abd6a579e68b798559e94100461d353b87..8a27c727b62f81b0923b0e7682422bf34c33cd68 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Conditional build:
-%bcond_without qch     # documentation in QCH format
+%bcond_without doc     # Documentation
 
 %define                orgname         qtwebchannel
 %define                qtbase_ver              %{version}
@@ -20,7 +20,7 @@ BuildRequires:        Qt5Core-devel >= %{qtbase_ver}
 BuildRequires: Qt5Network-devel >= %{qtbase_ver}
 BuildRequires: Qt5Qml-devel >= %{qtdeclarative_ver}
 BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
-%if %{with qch}
+%if %{with doc}
 BuildRequires: qt5-assistant >= %{qttools_ver}
 %endif
 BuildRequires: qt5-build >= %{qtbase_ver}
@@ -129,15 +129,17 @@ Przykłady do biblioteki Qt5 WebChannel.
 %build
 qmake-qt5
 %{__make}
-%{__make} %{!?with_qch:html_}docs
+%{?with_doc:%{__make} docs}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-%{__make} install_%{!?with_qch:html_}docs \
+%if %{with doc}
+%{__make} install_docs \
        INSTALL_ROOT=$RPM_BUILD_ROOT
+%endif
 
 # useless symlinks
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
@@ -195,11 +197,11 @@ rm -rf $RPM_BUILD_ROOT
 %{qt5dir}/mkspecs/modules/qt_lib_webchannel.pri
 %{qt5dir}/mkspecs/modules/qt_lib_webchannel_private.pri
 
+%if %{with doc}
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/qt5-doc/qtwebchannel
 
-%if %{with qch}
 %files doc-qch
 %defattr(644,root,root,755)
 %{_docdir}/qt5-doc/qtwebchannel.qch
This page took 0.161914 seconds and 4 git commands to generate.