]> git.pld-linux.org Git - packages/qt5-qtserialport.git/blob - qt5-qtserialport.spec
up to 5.15.6
[packages/qt5-qtserialport.git] / qt5-qtserialport.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtserialport
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 SerialPort library
9 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort
10 Name:           qt5-%{orgname}
11 Version:        5.15.6
12 Release:        1
13 License:        LGPL v3 or GPL v2 or GPL v3 or commercial
14 Group:          Libraries
15 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-opensource-src-%{version}.tar.xz
16 # Source0-md5:  85f4f46c6cccd531a0b97fdbe757b07e
17 URL:            https://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
21 %if %{with doc}
22 BuildRequires:  qt5-assistant >= %{qttools_ver}
23 %endif
24 BuildRequires:  qt5-build >= %{qtbase_ver}
25 BuildRequires:  qt5-qmake >= %{qtbase_ver}
26 BuildRequires:  rpm-build >= 4.6
27 BuildRequires:  rpmbuild(macros) >= 2.016
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  udev-devel
30 BuildRequires:  xz
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         specflags       -fno-strict-aliasing
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Qt is a cross-platform application and UI framework. Using Qt, you can
38 write web-enabled applications once and deploy them across desktop,
39 mobile and embedded systems without rewriting the source code.
40
41 This package contains Qt5 SerialPort library.
42
43 %description -l pl.UTF-8
44 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
45 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
46 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
47 źródłowego.
48
49 Ten pakiet zawiera bibliotekę Qt5 SerialPort.
50
51 %package -n Qt5SerialPort
52 Summary:        The Qt5 SerialPort library
53 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort
54 Group:          Libraries
55 Requires:       Qt5Core >= %{qtbase_ver}
56 Obsoletes:      qt5-qtserialport < 5.2.0-1
57
58 %description -n Qt5SerialPort
59 Qt5 SerialPort library provides classes that enable access to a serial
60 port.
61
62 %description -n Qt5SerialPort -l pl.UTF-8
63 Biblioteka Qt5 SerialPort udostępnia klasy pozwalające na dostęp do
64 portu szeregowego.
65
66 %package -n Qt5SerialPort-devel
67 Summary:        Qt5 SerialPort library - development files
68 Summary(pl.UTF-8):      Biblioteka Qt5 SerialPort - pliki programistyczne
69 Group:          Development/Libraries
70 Requires:       Qt5Core-devel >= %{qtbase_ver}
71 Requires:       Qt5SerialPort = %{version}-%{release}
72 Requires:       udev-devel
73 Obsoletes:      qt5-qtserialport-devel < 5.2.0-1
74
75 %description -n Qt5SerialPort-devel
76 Qt5 SerialPort library - development files.
77
78 %description -n Qt5SerialPort-devel -l pl.UTF-8
79 Biblioteka Qt5 SerialPort - pliki programistyczne.
80
81 %package doc
82 Summary:        Qt5 SerialPort documentation in HTML format
83 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 SerialPort w formacie HTML
84 Group:          Documentation
85 Requires:       qt5-doc-common >= %{qtbase_ver}
86 BuildArch:      noarch
87
88 %description doc
89 Qt5 SerialPort documentation in HTML format.
90
91 %description doc -l pl.UTF-8
92 Dokumentacja do biblioteki Qt5 SerialPort w formacie HTML.
93
94 %package doc-qch
95 Summary:        Qt5 SerialPort documentation in QCH format
96 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 SerialPort w formacie QCH
97 Group:          Documentation
98 Requires:       qt5-doc-common >= %{qtbase_ver}
99 BuildArch:      noarch
100
101 %description doc-qch
102 Qt5 SerialPort documentation in QCH format.
103
104 %description doc-qch -l pl.UTF-8
105 Dokumentacja do biblioteki Qt5 SerialPort w formacie QCH.
106
107 %package examples
108 Summary:        Qt5 SerialPort examples
109 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 SerialPort
110 Group:          Development/Libraries
111 BuildArch:      noarch
112
113 %description examples
114 Qt5 SerialPort examples.
115
116 %description examples -l pl.UTF-8
117 Przykłady do biblioteki Qt5 SerialPort.
118
119 %prep
120 %setup -q -n %{orgname}-everywhere-src-%{version}
121
122 %build
123 %{qmake_qt5}
124 %{__make}
125 %{?with_doc:%{__make} docs}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         INSTALL_ROOT=$RPM_BUILD_ROOT
132
133 %if %{with doc}
134 %{__make} install_docs \
135         INSTALL_ROOT=$RPM_BUILD_ROOT
136 %endif
137
138 # useless symlinks
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
140 # actually drop *.la, follow policy of not packaging them when *.pc exist
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
142
143 # Prepare some files list
144 ifecho() {
145         r="$RPM_BUILD_ROOT$2"
146         if [ -d "$r" ]; then
147                 echo "%%dir $2" >> $1.files
148         elif [ -x "$r" ] ; then
149                 echo "%%attr(755,root,root) $2" >> $1.files
150         elif [ -f "$r" ]; then
151                 echo "$2" >> $1.files
152         else
153                 echo "Error generation $1 files list!"
154                 echo "$r: no such file or directory!"
155                 return 1
156         fi
157 }
158 ifecho_tree() {
159         ifecho $1 $2
160         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
161                 ifecho $1 $2/$f
162         done
163 }
164
165 echo "%defattr(644,root,root,755)" > examples.files
166 ifecho_tree examples %{_examplesdir}/qt5/serialport
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -n Qt5SerialPort -p /sbin/ldconfig
172 %postun -n Qt5SerialPort -p /sbin/ldconfig
173
174 %files -n Qt5SerialPort
175 %defattr(644,root,root,755)
176 %doc LICENSE.GPL3-EXCEPT dist/changes-*
177 %attr(755,root,root) %{_libdir}/libQt5SerialPort.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libQt5SerialPort.so.5
179
180 %files -n Qt5SerialPort-devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libQt5SerialPort.so
183 %{_libdir}/libQt5SerialPort.prl
184 %{_includedir}/qt5/QtSerialPort
185 %{_pkgconfigdir}/Qt5SerialPort.pc
186 %{_libdir}/cmake/Qt5SerialPort
187 %{qt5dir}/mkspecs/modules/qt_lib_serialport.pri
188 %{qt5dir}/mkspecs/modules/qt_lib_serialport_private.pri
189
190 %if %{with doc}
191 %files doc
192 %defattr(644,root,root,755)
193 %{_docdir}/qt5-doc/qtserialport
194
195 %files doc-qch
196 %defattr(644,root,root,755)
197 %{_docdir}/qt5-doc/qtserialport.qch
198 %endif
199
200 %files examples -f examples.files
201 %defattr(644,root,root,755)
202 # XXX: dir shared with qt5-qtbase-examples
203 %dir %{_examplesdir}/qt5
This page took 0.127097 seconds and 3 git commands to generate.