]> git.pld-linux.org Git - packages/qemu.git/commitdiff
upstream patch to fix build with glibc 2.27
authorJan Palus <atler@pld-linux.org>
Wed, 14 Feb 2018 23:02:35 +0000 (00:02 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 14 Feb 2018 23:02:35 +0000 (00:02 +0100)
qemu-glibc2_27.patch [new file with mode: 0644]
qemu.spec

diff --git a/qemu-glibc2_27.patch b/qemu-glibc2_27.patch
new file mode 100644 (file)
index 0000000..b1f354a
--- /dev/null
@@ -0,0 +1,55 @@
+From 75e5b70e6b5dcc4f2219992d7cffa462aa406af0 Mon Sep 17 00:00:00 2001
+From: Paolo Bonzini <pbonzini@redhat.com>
+Date: Tue, 28 Nov 2017 11:51:27 +0100
+Subject: [PATCH] memfd: fix configure test
+MIME-Version: 1.0
+Content-Type: text/plain; charset=utf8
+Content-Transfer-Encoding: 8bit
+
+Recent glibc added memfd_create in sys/mman.h.  This conflicts with
+the definition in util/memfd.c:
+
+    /builddir/build/BUILD/qemu-2.11.0-rc1/util/memfd.c:40:12: error: static declaration of memfd_create follows non-static declaration
+
+Fix the configure test, and remove the sys/memfd.h inclusion since the
+file actually does not exist---it is a typo in the memfd_create(2) man
+page.
+
+Cc: Marc-André Lureau <marcandre.lureau@redhat.com>
+Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
+---
+ configure    | 2 +-
+ util/memfd.c | 4 +---
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/configure b/configure
+index 9c8aa5a..99ccc17 100755
+--- a/configure
++++ b/configure
+@@ -3923,7 +3923,7 @@ fi
+ # check if memfd is supported
+ memfd=no
+ cat > $TMPC << EOF
+-#include <sys/memfd.h>
++#include <sys/mman.h>
+ int main(void)
+ {
+diff --git a/util/memfd.c b/util/memfd.c
+index 4571d1a..412e94a 100644
+--- a/util/memfd.c
++++ b/util/memfd.c
+@@ -31,9 +31,7 @@
+ #include "qemu/memfd.h"
+-#ifdef CONFIG_MEMFD
+-#include <sys/memfd.h>
+-#elif defined CONFIG_LINUX
++#if defined CONFIG_LINUX && !defined CONFIG_MEMFD
+ #include <sys/syscall.h>
+ #include <asm/unistd.h>
+-- 
+1.8.3.1
+
index b606eb376a5bb620cdee7c6f8b1a16115388d297..42c59ece5319fa109e21b909ad68352d3e68a906 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -64,6 +64,7 @@ Patch3:               %{name}-user-execve.patch
 Patch4:                %{name}-xattr.patch
 Patch5:                libjpeg-boolean.patch
 Patch6:                x32.patch
+Patch7:                %{name}-glibc2_27.patch
 URL:           http://www.qemu-project.org/
 %{?with_gl:BuildRequires:      OpenGL-GLX-devel}
 %{?with_gl:BuildRequires:      OpenGL-devel}
@@ -778,6 +779,7 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
This page took 0.040492 seconds and 4 git commands to generate.