]> git.pld-linux.org Git - packages/qemu.git/commitdiff
- kqemu: rename suplied .o to .o.bin so they won't be deleted in make clean
authorsparky <sparky@pld-linux.org>
Mon, 13 Nov 2006 16:31:16 +0000 (16:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    qemu.spec -> 1.64

qemu.spec

index 4e338ff404cf31db7f741aaf50bb9cb111728a8f..530d17022f8da62545d9168e8e13ff09de84fdfb 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -161,7 +161,18 @@ EOF
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
+
+mv -f kqemu-mod-i386.o{,.bin}
+mv -f kqemu-mod-x86_64.o{,.bin}
 mv -f kqemu-linux.c{,.orig}
+cat > Makefile <<'EOF'
+obj-m := kqemu.o
+kqemu-objs:= kqemu-linux.o kqemu-mod.o
+
+$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
+        cp $< $@
+EOF
+
 %build_kernel_modules -m kqemu <<'EOF'
 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
        sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
This page took 0.070942 seconds and 4 git commands to generate.