]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- kqemu: rename suplied .o to .o.bin so they won't be deleted in make clean
[packages/qemu.git] / qemu.spec
index 024897ba5f56e2d0a006e537557abd428994c522..530d17022f8da62545d9168e8e13ff09de84fdfb 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,60 +1,59 @@
 #
 # TODO:
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
+# - kqemu could be distributable if somebody bothers to contact qemu
+#   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
 #
 # Conditional build:
-%bcond_with    kqemu                   # with QEMU accelerator module
+%bcond_without kqemu                   # disable QEMU accelerator support
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
+%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
-%bcond_without kernel                  # don't build kernel modules
+%bcond_with    kernel                  # build kqemu kernel modules
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
+%define        _kqemu_version  1.3.0pre9
+%define                _rel    0.4
 Summary:       QEMU CPU Emulator
 Summary(pl):   QEMU - emulator procesora
 Name:          qemu
-Version:       0.7.2
-%define                _rel    1
+Version:       0.8.2
 Release:       %{_rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
 Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 7d69dd96edf7ae5298a9a7283a0e9fb8
-%if %{with kqemu}
-Source1:       http://fabrice.bellard.free.fr/qemu/kqemu-%{version}.tar.gz
-# NoSource1-md5:       02cfdecda90458d6393781496ec6b48b
-NoSource:      1
-%endif
+# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
+Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
+# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
 Patch0:                %{name}-nostatic.patch
-Patch1:                %{name}-DESTDIR.patch
+Patch1:                %{name}-cc.patch
 Patch2:                %{name}-longjmp.patch
 Patch3:                %{name}-dot.patch
-Patch4:                %{name}-initrd_load_addr.patch
-Patch5:                %{name}-gcc4_x86.patch
-Patch6:                %{name}-gcc4_ppc.patch
-Patch7:                %{name}-parallel.patch
-Patch8:                %{name}-nosdlgui.patch
-Patch9:                %{name}-ifup.patch
+Patch4:                %{name}-gcc4_x86.patch
+Patch5:                %{name}-gcc4_ppc.patch
+Patch6:                %{name}-nosdlgui.patch
+Patch7:                %{name}-ifup.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 BuildRequires: SDL-devel >= 1.2.1
+BuildRequires: alsa-lib-devel
+%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
 %if %{with kqemu} && %{with dist_kernel}
-BuildRequires: kernel-module-build >= 2.6.7
+BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
 %endif
-BuildRequires: rpmbuild(macros) >= 1.217
+BuildRequires: perl-tools-pod
+BuildRequires: rpmbuild(macros) >= 1.326
+BuildRequires: tetex
 BuildRequires: sed >= 4.0
 Requires:      SDL >= 1.2.1
-ExclusiveArch: %{ix86} %{x8664} ppc
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
+ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/proll.elf
-
-%if !%{with kqemu}
-%undefine      with_kernel
-%endif
+%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -67,9 +66,8 @@ CPUs. QEMU has two operating modes:
   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
 
 - Full system emulation. In this mode, QEMU emulates a full system,
-  including a processor and various peripherials. 
-  It can also be used to provide virtual hosting of several 
-  virtual PC on a single server.
+  including a processor and various peripherials. It can also be used to
+  provide virtual hosting of several virtual PC on a single server.
 
 %description -l pl
 QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
@@ -78,56 +76,62 @@ aby dzia
 
 - Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu
-  na niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
+  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
+  niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
   s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
   cele QEMU.
 
 - Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne.
-  Mo¿e byæ tak¿e u¿ywane do wirtualnego hostowania kilku wirtualnych 
-  pecetów na pojedynczym serwerze.
+  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
+  u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
+  pojedynczym serwerze.
 
-%package -n kernel-misc-kqemu
+%package -n kernel%{_alt_kernel}-misc-kqemu
 Summary:       kqemu - kernel module
 Summary(pl):   kqemu - modu³ j±dra
+Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_up}
+License:       Free to use, non-distributable
 Requires(post,postun): /sbin/depmod
+Requires:      module-init-tools >= 3.2.2-2
 
-%description -n kernel-misc-kqemu
+%description -n kernel%{_alt_kernel}-misc-kqemu
 kqemu - kernel module.
 
-%description -n kernel-misc-kqemu -l pl
+%description -n kernel%{_alt_kernel}-misc-kqemu -l pl
 kqemu - modu³ j±dra.
 
-%package -n kernel-smp-misc-kqemu
+%package -n kernel%{_alt_kernel}-smp-misc-kqemu
 Summary:       kqemu - SMP kernel module
 Summary(pl):   kqemu - modu³ j±dra SMP
+Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
+%{?with_dist_kernel:%requires_releq_kernel_smp}
+License:       Free to use, non-distributable
 Requires(post,postun): /sbin/depmod
+Requires:      module-init-tools >= 3.2.2-2
 
-%description -n kernel-smp-misc-kqemu
+%description -n kernel%{_alt_kernel}-smp-misc-kqemu
 kqemu - SMP kernel module.
 
-%description -n kernel-smp-misc-kqemu -l pl
+%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
 kqemu - modu³ j±dra SMP.
 
 %prep
-%setup -q %{?with_kqemu:-a1}
+%setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p0
-%patch6 -p1
+%if %{with gcc4}
+%patch4 -p0
+%patch5 -p1
+%endif
+%{?with_nosdlgui:%patch6 -p1}
 %patch7 -p1
-%{?with_nosdlgui:%patch8 -p1}
-%patch9 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -139,32 +143,44 @@ kqemu - modu
 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
 %endif
 
-%{?with_kqemu:echo -n > kqemu/install.sh}
+%if %{with kernel}
+echo -n > kqemu-%{_kqemu_version}/install.sh
+
+cat <<'EOF' > modprobe.conf
+# enable dynamic major
+options kqemu major=0
+# for autoloading from static dev
+#alias char-major-250 kqemu
+EOF
+
+cat <<'EOF' > udev.conf
+KERNEL=="kqemu", NAME="%k", MODE="0666"
+EOF
+%endif
 
 %build
 %if %{with kernel}
-cd kqemu
-for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
-       if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
-               exit 1
-       fi
-       rm -rf include
-       install -d include/{linux,config}
-       ln -sf %{_kernelsrcdir}/config-$cfg .config
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
-       ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg Module.symvers
-%if %{without dist_kernel}
-       ln -sf %{_kernelsrcdir}/scripts
-%endif
-       touch include/config/MARKER
-       %{__make} -C %{_kernelsrcdir} clean \
-               RCS_FIND_IGNORE="-name 'kqemu-mod-*.*' -o" \
-               M=$PWD O=$PWD
-       %{__make} -C %{_kernelsrcdir} modules \
-               M=$PWD O=$PWD
-       mv kqemu.ko kqemu-mod-$cfg.ko
-done
+cd kqemu-%{_kqemu_version}
+
+mv -f kqemu-mod-i386.o{,.bin}
+mv -f kqemu-mod-x86_64.o{,.bin}
+mv -f kqemu-linux.c{,.orig}
+cat > Makefile <<'EOF'
+obj-m := kqemu.o
+kqemu-objs:= kqemu-linux.o kqemu-mod.o
+
+$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
+        cp $< $@
+EOF
+
+%build_kernel_modules -m kqemu <<'EOF'
+if grep -q "CONFIG_PREEMPT_RT" o/.config; then
+       sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
+               kqemu-linux.c.orig > kqemu-linux.c
+else
+       cat kqemu-linux.c.orig > kqemu-linux.c
+fi
+EOF
 cd -
 %endif
 
@@ -174,8 +190,16 @@ cd -
 ./configure \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
-       %{!?with_kqemu:--disable-kqemu} \
-       --make="%{__make}"
+       --host-cc="%{__cc}" \
+       --make="%{__make}" \
+%if %{with kqemu}
+       --kernel-path=%{_kernelsrcdir} \
+%else
+       --disable-kqemu \
+%endif
+       %{?with_gcc4:--disable-gcc-check} \
+       --enable-alsa \
+       --interp-prefix=%{_libdir}/%{name}
 %{__make}
 %endif
 
@@ -198,20 +222,22 @@ EOF
 %endif
 
 %if %{with kernel}
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
-install kqemu/kqemu-mod-up.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/kqemu.ko
+%install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
+install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
+install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
 %if %{with smp} && %{with dist_kernel}
-install kqemu/kqemu-mod-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko
+install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
 %endif
+install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
 %endif
 
-# This dir is unneeded
-rm -rf $RPM_BUILD_ROOT/usr/share/doc/qemu
+# already packaged
+rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kqemu}
+%if %{with kernel}
 %post
 %banner %{name} -e <<EOF
 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
@@ -219,24 +245,16 @@ modprobe kqemu
 EOF
 %endif
 
-%post  -n kernel-misc-kqemu
+%post  -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
-%banner %{name}-module -e <<EOF
-To autoload kqemu module, add to /etc/modprobe.conf:
-alias char-major-250 kqemu
-EOF
 
-%postun -n kernel-misc-kqemu
+%postun -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
 
-%post  -n kernel-smp-misc-kqemu
+%post  -n kernel%{_alt_kernel}-smp-misc-kqemu
 %depmod %{_kernel_ver}smp
-%banner %{name}-module -e <<EOF
-To autoload kqemu module, add to /etc/modprobe.conf:
-alias char-major-250 kqemu
-EOF
 
-%postun -n kernel-smp-misc-kqemu
+%postun -n kernel%{_alt_kernel}-smp-misc-kqemu
 %depmod %{_kernel_ver}smp
 
 %if %{with userspace}
@@ -248,20 +266,22 @@ EOF
 %{_datadir}/qemu
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/qemu-img.1*
-# FIXME: maybe better moved this into dev.spec
-%if %{with kqemu}
-%dev(c,250,0) %attr(666,root,root) /dev/kqemu
-%endif
 %endif
 
 %if %{with kernel}
-%files -n kernel-misc-kqemu
+%files -n kernel%{_alt_kernel}-misc-kqemu
 %defattr(644,root,root,755)
+%doc kqemu-%{_kqemu_version}/LICENSE
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
+%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
 
 %if %{with smp} && %{with dist_kernel}
-%files -n kernel-smp-misc-kqemu
+%files -n kernel%{_alt_kernel}-smp-misc-kqemu
 %defattr(644,root,root,755)
+%doc kqemu-%{_kqemu_version}/LICENSE
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
+%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
 /lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
 %endif
 %endif
This page took 0.140479 seconds and 4 git commands to generate.