]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- documented optflags failure
[packages/qemu.git] / qemu.spec
1 Summary:        QEMU CPU Emulator
2 Summary(pl):    QEMU - emulator procesora
3 Name:           qemu
4 Version:        0.7.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Emulators
8 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
9 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
10 # Source0-md5:  234e9ace03b00259bb57dc5a9c633056
11 Patch0:         %{name}-nostatic.patch
12 Patch1:         %{name}-DESTDIR.patch
13 Patch2:         %{name}-longjmp.patch
14 Patch3:         %{name}-dot.patch
15 URL:            http://fabrice.bellard.free.fr/qemu/
16 BuildRequires:  SDL-devel >= 1.2.1
17 BuildRequires:  sed >= 4.0
18 ExclusiveArch:  %{ix86} amd64 ppc
19 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # some SPARC boot image in ELF format
23 %define         _noautostrip    .*%{_datadir}/qemu/proll.elf
24
25 %description
26 QEMU is a FAST! processor emulator. By using dynamic translation it
27 achieves a reasonnable speed while being easy to port on new host
28 CPUs. QEMU has two operating modes:
29
30 - User mode emulation. In this mode, QEMU can launch Linux processes
31   compiled for one CPU on another CPU. Linux system calls are converted
32   because of endianness and 32/64 bit mismatches. Wine (Windows
33   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
34
35 - Full system emulation. In this mode, QEMU emulates a full system,
36   including a processor and various peripherials. 
37   It can also be used to provide virtual hosting of several 
38   virtual PC on a single server.
39
40 %description -l pl
41 QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
42 t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
43 aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
44
45 - Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
46   procesy linuksowe skompilowane dla jednego procesora na innym
47   procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu
48   na niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
49   s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
50   cele QEMU.
51
52 - Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
53   w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne.
54   Mo¿e byæ tak¿e u¿ywane do wirtualnego hostowania kilku wirtualnych 
55   pecetów na pojedynczym serwerze.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62 %patch3 -p1
63
64 sed -i -e 's/sdl_static=yes/sdl_static=no/' configure
65 # cannot use optflags on x86 - they cause "no register to spill" errors
66 #sed -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
67
68 %build
69 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
70 ./configure \
71         --prefix=%{_prefix} \
72         --cc="%{__cc}" \
73         --make="%{__make}"
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README qemu-doc.html qemu-tech.html
89 %attr(755,root,root) %{_bindir}/*
90 %{_datadir}/qemu
91 %{_mandir}/man1/qemu.1*
92 %{_mandir}/man1/qemu-img.1*
This page took 0.106441 seconds and 4 git commands to generate.