]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- fix ncurses detection; enable mixemu; enable TLS in VNC support
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - update patches
4 #
5 # Conditional build:
6 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
7 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
8 %bcond_with     dosguest                # add special patch when use with DOS as guest os
9 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
10 %bcond_without  dist_kernel             # without distribution kernel
11 %bcond_without  kernel                  # build kqemu KERNEL MODULES
12 %bcond_without  userspace               # don't build userspace utilities
13
14 # no kernel kqemu module for ppc
15 %ifarch ppc
16 %undefine      with_kqemu
17 %undefine      with_kernel
18 %endif
19
20 %if %{without kernel}
21 %undefine       with_dist_kernel
22 %endif
23 %if "%{_alt_kernel}" != "%{nil}"
24 %undefine       with_userspace
25 %endif
26 %if %{without userspace}
27 # nothing to be placed to debuginfo package
28 %define         _enable_debug_packages  0
29 %endif
30
31 %define         rel     0.1
32
33 %define         kqemu_version   1.4.0pre1
34 %define         qemu_version    0.10.0
35 %define         pname   qemu
36 Summary:        QEMU CPU Emulator
37 Summary(pl.UTF-8):      QEMU - emulator procesora
38 Name:           %{pname}%{_alt_kernel}
39 Version:        %{qemu_version}
40 Release:        %{rel}%{?with_kqemu:k}
41 License:        GPL
42 Group:          Applications/Emulators
43 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
44 Source0:        http://download.savannah.gnu.org/releases/qemu/%{pname}-%{version}.tar.gz
45 # Source0-md5:  8dc50b834fa3f5f6a17d7bc3d0559e53
46 Source1:        http://www.nongnu.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
47 # Source1-md5:  d738d8ca7332211ab716ec3213d82ee1
48 Patch0:         %{pname}-ncurses.patch
49 Patch6:         %{pname}-nosdlgui.patch
50 # Proof of concept, for reference, do not remove
51 Patch8:         %{pname}-kde_virtual_workspaces_hack.patch
52 #Patch12:       %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
53 Patch13:        %{pname}-dosguest.patch
54 Patch14:        %{pname}-ppc_old_binutils.patch
55 Patch15:        %{pname}-isa-bios-ram.patch
56 # below one fixes problems with passing ram size to bios/bootloader
57 # which affects coreboot/linuxbios
58 Patch16:        %{pname}-piix-ram-size.patch
59 URL:            http://www.nongnu.org/qemu/
60 %if %{with kernel} && %{with dist_kernel}
61 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
62 BuildRequires:  rpmbuild(macros) >= 1.379
63 %endif
64 %if %{with userspace}
65 BuildRequires:  SDL-devel >= 1.2.1
66 BuildRequires:  alsa-lib-devel
67 BuildRequires:  bluez-libs-devel
68 BuildRequires:  gnutls-devel
69 BuildRequires:  ncurses-devel
70 BuildRequires:  perl-tools-pod
71 BuildRequires:  sed >= 4.0
72 BuildRequires:  tetex
73 BuildRequires:  which
74 %endif
75 Requires:       SDL >= 1.2.1
76 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
77 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 # some PPC/SPARC boot image in ELF format
81 %define         _noautostrip    .*%{_datadir}/qemu/openbios-.*
82
83 %description
84 QEMU is a FAST! processor emulator. By using dynamic translation it
85 achieves a reasonnable speed while being easy to port on new host
86 CPUs. QEMU has two operating modes:
87
88 - User mode emulation. In this mode, QEMU can launch Linux processes
89   compiled for one CPU on another CPU. Linux system calls are converted
90   because of endianness and 32/64 bit mismatches. Wine (Windows
91   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
92
93 - Full system emulation. In this mode, QEMU emulates a full system,
94   including a processor and various peripherials. It can also be used to
95   provide virtual hosting of several virtual PC on a single server.
96
97 %description -l pl.UTF-8
98 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
99 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
100 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
101
102 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
103   procesy linuksowe skompilowane dla jednego procesora na innym
104   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
105   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
106   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
107   cele QEMU.
108
109 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
110   włączając w to procesor i różne urządzenia peryferyjne. Może być także
111   używane do wirtualnego hostowania kilku wirtualnych pecetów na
112   pojedynczym serwerze.
113
114 %package -n kernel%{_alt_kernel}-misc-kqemu
115 Summary:        kqemu - kernel module
116 Summary(pl.UTF-8):      kqemu - moduł jądra
117 Version:        %{kqemu_version}
118 Release:        %{rel}@%{_kernel_ver_str}
119 Group:          Base/Kernel
120 %{?with_dist_kernel:%requires_releq_kernel}
121 License:        GPL v2
122 Obsoletes:      kernel%{_alt_kernel}-smp-misc-kqemu
123 Requires(post,postun):  /sbin/depmod
124 Requires:       module-init-tools >= 3.2.2-2
125
126 %description -n kernel%{_alt_kernel}-misc-kqemu
127 kqemu - kernel module.
128
129 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
130 kqemu - moduł jądra.
131
132 %prep
133 %setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
134 %patch0 -p0
135 %{?with_nosdlgui:%patch6 -p1}
136 #%patch8 -p1
137
138 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
139 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
140
141 # cannot use optflags on x86 - they cause "no register to spill" errors
142 %if %{with cflags_passing}
143 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
144 %else
145 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
146 %endif
147
148 %if %{with kernel}
149 echo -n > kqemu-%{kqemu_version}/install.sh
150
151 cat <<'EOF' > modprobe.conf
152 # enable dynamic major
153 options kqemu major=0
154 # for autoloading from static dev
155 #alias char-major-250 kqemu
156 EOF
157
158 cat <<'EOF' > udev.conf
159 KERNEL=="kqemu", NAME="%k", MODE="0666"
160 EOF
161
162 %if %{with dosguest}
163 %patch13 -p1
164 %endif
165 %patch14 -p1
166 #%patch15 -p1
167 %patch16 -p1
168
169 cd kqemu-%{kqemu_version}
170 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
171 %ifarch %{x8664}
172 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
173 %{__make} -C common -j1
174 mv -f kqemu-mod-x86_64.o{,.bin}
175 %else
176 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
177 %{__make} -C common -j1
178 mv -f kqemu-mod-i386.o{,.bin}
179 %endif
180
181 mv -f kqemu-linux.c{,.orig}
182 cat > Makefile <<'EOF'
183 obj-m := kqemu.o
184 kqemu-objs:= kqemu-linux.o kqemu-mod.o
185
186 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
187         cp $< $@
188 EOF
189 cd -
190 %endif
191
192 %build
193 %if %{with kernel}
194 cd kqemu-%{kqemu_version}
195 %build_kernel_modules -m kqemu <<'EOF'
196 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
197         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
198                 kqemu-linux.c.orig > kqemu-linux.c
199 else
200         cat kqemu-linux.c.orig > kqemu-linux.c
201 fi
202 EOF
203 cd -
204 %endif
205
206 %if %{with userspace}
207 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
208 # they can be passed if the cflags_passing bcond is used
209 ./configure \
210         --prefix=%{_prefix} \
211         --cc="%{__cc}" \
212         --host-cc="%{__cc}" \
213         --make="%{__make}" \
214 %if %{without kqemu}
215         --disable-kqemu \
216 %endif
217         --enable-mixemu \
218         --audio-drv-list="alsa" \
219         --interp-prefix=%{_libdir}/%{pname}
220 %{__make}
221 %endif
222
223 %install
224 rm -rf $RPM_BUILD_ROOT
225
226 %if %{with userspace}
227 %{__make} install \
228         DESTDIR=$RPM_BUILD_ROOT
229
230 install -d $RPM_BUILD_ROOT%{_sysconfdir}
231 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
232 #!/bin/sh
233
234 EOF
235 %endif
236
237 %if %{with kernel}
238 %install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
239 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
240 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
241 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
242 %endif
243
244 # already packaged
245 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
246
247 %clean
248 rm -rf $RPM_BUILD_ROOT
249
250 %if %{with kernel}
251 %post
252 %banner %{pname} -e <<EOF
253 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
254 modprobe kqemu
255 EOF
256 %endif
257
258 %post   -n kernel%{_alt_kernel}-misc-kqemu
259 %depmod %{_kernel_ver}
260
261 %postun -n kernel%{_alt_kernel}-misc-kqemu
262 %depmod %{_kernel_ver}
263
264 %if %{with userspace}
265 %files
266 %defattr(644,root,root,755)
267 %doc README qemu-doc.html qemu-tech.html
268 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
269 %attr(755,root,root) %{_bindir}/*
270 %{_datadir}/qemu
271 %{_mandir}/man1/qemu.1*
272 %{_mandir}/man1/qemu-img.1*
273 %{_mandir}/man8/qemu-nbd.8*
274 %endif
275
276 %if %{with kernel}
277 %files -n kernel%{_alt_kernel}-misc-kqemu
278 %defattr(644,root,root,755)
279 %doc kqemu-%{kqemu_version}/LICENSE
280 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
281 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
282 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
283 %endif
This page took 0.057498 seconds and 3 git commands to generate.