]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- DESTDIR patch
[packages/qemu.git] / qemu.spec
1 Summary:        QEMU CPU Emulator
2 Name:           qemu
3 Version:        0.5.2
4 Release:        0.1
5 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
6 Patch0:         %{name}-nostatic.patch
7 Patch1:         %{name}-DESTDIR.patch
8 #Patch0:                qemu-0.5.0-cvsupdates.patch.bz2
9 #Patch1:                qemu-0.1.6-glibc23-ldscripts.patch.bz2
10 #Patch2:                qemu-0.5.0-sdl-static-libs.patch.bz2
11 #Patch3:                qemu-0.5.0-DESTDIR.patch.bz2
12 #Patch4:                qemu-0.5.0-lib64.patch.bz2
13 #Patch5:                qemu-0.5.0-amd64.patch.bz2
14 #Patch6:                qemu-0.5.0-vl-amd64.patch.bz2
15 License:        GPL
16 URL:            http://fabrice.bellard.free.fr/qemu/
17 Group:          Applications/Emulators
18 BuildRequires:  SDL-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 QEMU is a FAST! processor emulator. By using dynamic translation it
23 achieves a reasonnable speed while being easy to port on new host
24 CPUs. QEMU has two operating modes:
25
26 - User mode emulation. In this mode, QEMU can launch Linux processes
27   compiled for one CPU on another CPU. Linux system calls are converted
28   because of endianness and 32/64 bit mismatches. Wine (Windows
29   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
30
31 - Full system emulation. In this mode, QEMU emulates a full system,
32   including a processor and various peripherials. Currently, it is only
33   used to launch an x86 Linux kernel on an x86 Linux system. It enables
34   easier testing and debugging of system code. It can also be used to
35   provide virtual hosting of several virtual PC on a single server.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40 %patch1 -p1
41 #%patch0 -p1 -b .cvsupdates
42 #%patch1 -p1 -b .glibc23-ldscripts
43 #%patch2 -p1 -b .sdl-static-libs
44 #%patch3 -p1 -b .DESTDIR
45 #%patch4 -p1 -b .lib64
46 #%patch5 -p1 -b .amd64
47 # needs to 64-bit clean softmmu code or MAP_32BIT physical_ram_base
48 # but other problems remain.
49 #%patch6 -p1 -b .vl-amd64
50
51 %build
52 ./configure \
53         --prefix=%{_prefix} \
54         --cc=%{__cc} \
55         --make=%{__make}
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README qemu-doc.html
69 %ifarch %{ix86}
70 %attr(755,root,root) %{_bindir}/qemu-fast
71 %endif
72 %ifarch %{ix86} ppc
73 %{_bindir}/qemu
74 %endif
75 %{_bindir}/qemu-mkcow
76 %{_bindir}/qemu-arm
77 %{_bindir}/qemu-i386
78 %{_bindir}/qemu-sparc
79 %{_bindir}/qemu-ppc
80 %{_mandir}/man1/qemu.1*
81 %dir %{_datadir}/qemu
82 %{_datadir}/qemu/bios.bin
83 %{_datadir}/qemu/vgabios.bin
This page took 0.043479 seconds and 3 git commands to generate.