]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- up to 0.10.0
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - fix ncurses detection
4 # - update patches
5 #
6 # Conditional build:
7 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
8 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
9 %bcond_with     dosguest                # add special patch when use with DOS as guest os
10 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
11 %bcond_without  dist_kernel             # without distribution kernel
12 %bcond_without  kernel                  # build kqemu KERNEL MODULES
13 %bcond_without  userspace               # don't build userspace utilities
14
15 # no kernel kqemu module for ppc
16 %ifarch ppc
17 %undefine      with_kqemu
18 %undefine      with_kernel
19 %endif
20
21 %if %{without kernel}
22 %undefine       with_dist_kernel
23 %endif
24 %if "%{_alt_kernel}" != "%{nil}"
25 %undefine       with_userspace
26 %endif
27 %if %{without userspace}
28 # nothing to be placed to debuginfo package
29 %define         _enable_debug_packages  0
30 %endif
31
32 %define         rel     0.1
33
34 %define         kqemu_version   1.4.0pre1
35 %define         qemu_version    0.10.0
36 %define         pname   qemu
37 Summary:        QEMU CPU Emulator
38 Summary(pl.UTF-8):      QEMU - emulator procesora
39 Name:           %{pname}%{_alt_kernel}
40 Version:        %{qemu_version}
41 Release:        %{rel}%{?with_kqemu:k}
42 License:        GPL
43 Group:          Applications/Emulators
44 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
45 Source0:        http://download.savannah.gnu.org/releases/qemu/%{pname}-%{version}.tar.gz
46 # Source0-md5:  8dc50b834fa3f5f6a17d7bc3d0559e53
47 Source1:        http://www.nongnu.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
48 # Source1-md5:  d738d8ca7332211ab716ec3213d82ee1
49 Patch6:         %{pname}-nosdlgui.patch
50 # Proof of concept, for reference, do not remove
51 Patch8:         %{pname}-kde_virtual_workspaces_hack.patch
52 #Patch12:       %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
53 Patch13:        %{pname}-dosguest.patch
54 Patch14:        %{pname}-ppc_old_binutils.patch
55 Patch15:        %{pname}-isa-bios-ram.patch
56 # below one fixes problems with passing ram size to bios/bootloader
57 # which affects coreboot/linuxbios
58 Patch16:        %{pname}-piix-ram-size.patch
59 URL:            http://www.nongnu.org/qemu/
60 %if %{with kernel} && %{with dist_kernel}
61 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
62 BuildRequires:  rpmbuild(macros) >= 1.379
63 %endif
64 %if %{with userspace}
65 BuildRequires:  SDL-devel >= 1.2.1
66 BuildRequires:  alsa-lib-devel
67 BuildRequires:  ncurses-devel
68 BuildRequires:  perl-tools-pod
69 BuildRequires:  sed >= 4.0
70 BuildRequires:  tetex
71 BuildRequires:  which
72 %endif
73 Requires:       SDL >= 1.2.1
74 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
75 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 # some PPC/SPARC boot image in ELF format
79 %define         _noautostrip    .*%{_datadir}/qemu/openbios-.*
80
81 %description
82 QEMU is a FAST! processor emulator. By using dynamic translation it
83 achieves a reasonnable speed while being easy to port on new host
84 CPUs. QEMU has two operating modes:
85
86 - User mode emulation. In this mode, QEMU can launch Linux processes
87   compiled for one CPU on another CPU. Linux system calls are converted
88   because of endianness and 32/64 bit mismatches. Wine (Windows
89   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
90
91 - Full system emulation. In this mode, QEMU emulates a full system,
92   including a processor and various peripherials. It can also be used to
93   provide virtual hosting of several virtual PC on a single server.
94
95 %description -l pl.UTF-8
96 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
97 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
98 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
99
100 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
101   procesy linuksowe skompilowane dla jednego procesora na innym
102   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
103   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
104   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
105   cele QEMU.
106
107 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
108   włączając w to procesor i różne urządzenia peryferyjne. Może być także
109   używane do wirtualnego hostowania kilku wirtualnych pecetów na
110   pojedynczym serwerze.
111
112 %package -n kernel%{_alt_kernel}-misc-kqemu
113 Summary:        kqemu - kernel module
114 Summary(pl.UTF-8):      kqemu - moduł jądra
115 Version:        %{kqemu_version}
116 Release:        %{rel}@%{_kernel_ver_str}
117 Group:          Base/Kernel
118 %{?with_dist_kernel:%requires_releq_kernel}
119 License:        GPL v2
120 Obsoletes:      kernel%{_alt_kernel}-smp-misc-kqemu
121 Requires(post,postun):  /sbin/depmod
122 Requires:       module-init-tools >= 3.2.2-2
123
124 %description -n kernel%{_alt_kernel}-misc-kqemu
125 kqemu - kernel module.
126
127 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
128 kqemu - moduł jądra.
129
130 %prep
131 %setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
132 %{?with_nosdlgui:%patch6 -p1}
133 #%patch8 -p1
134
135 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
136 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
137
138 # cannot use optflags on x86 - they cause "no register to spill" errors
139 %if %{with cflags_passing}
140 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
141 %else
142 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
143 %endif
144
145 %if %{with kernel}
146 echo -n > kqemu-%{kqemu_version}/install.sh
147
148 cat <<'EOF' > modprobe.conf
149 # enable dynamic major
150 options kqemu major=0
151 # for autoloading from static dev
152 #alias char-major-250 kqemu
153 EOF
154
155 cat <<'EOF' > udev.conf
156 KERNEL=="kqemu", NAME="%k", MODE="0666"
157 EOF
158
159 %if %{with dosguest}
160 %patch13 -p1
161 %endif
162 %patch14 -p1
163 #%patch15 -p1
164 %patch16 -p1
165
166 cd kqemu-%{kqemu_version}
167 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
168 %ifarch %{x8664}
169 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
170 %{__make} -C common -j1
171 mv -f kqemu-mod-x86_64.o{,.bin}
172 %else
173 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
174 %{__make} -C common -j1
175 mv -f kqemu-mod-i386.o{,.bin}
176 %endif
177
178 mv -f kqemu-linux.c{,.orig}
179 cat > Makefile <<'EOF'
180 obj-m := kqemu.o
181 kqemu-objs:= kqemu-linux.o kqemu-mod.o
182
183 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
184         cp $< $@
185 EOF
186 cd -
187 %endif
188
189 %build
190 %if %{with kernel}
191 cd kqemu-%{kqemu_version}
192 %build_kernel_modules -m kqemu <<'EOF'
193 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
194         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
195                 kqemu-linux.c.orig > kqemu-linux.c
196 else
197         cat kqemu-linux.c.orig > kqemu-linux.c
198 fi
199 EOF
200 cd -
201 %endif
202
203 %if %{with userspace}
204 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
205 # they can be passed if the cflags_passing bcond is used
206 ./configure \
207         --prefix=%{_prefix} \
208         --cc="%{__cc}" \
209         --host-cc="%{__cc}" \
210         --make="%{__make}" \
211 %if %{without kqemu}
212         --disable-kqemu \
213 %endif
214         --audio-drv-list="alsa" \
215         --interp-prefix=%{_libdir}/%{pname}
216 %{__make}
217 %endif
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221
222 %if %{with userspace}
223 %{__make} install \
224         DESTDIR=$RPM_BUILD_ROOT
225
226 install -d $RPM_BUILD_ROOT%{_sysconfdir}
227 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
228 #!/bin/sh
229
230 EOF
231 %endif
232
233 %if %{with kernel}
234 %install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
235 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
236 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
237 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
238 %endif
239
240 # already packaged
241 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %if %{with kernel}
247 %post
248 %banner %{pname} -e <<EOF
249 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
250 modprobe kqemu
251 EOF
252 %endif
253
254 %post   -n kernel%{_alt_kernel}-misc-kqemu
255 %depmod %{_kernel_ver}
256
257 %postun -n kernel%{_alt_kernel}-misc-kqemu
258 %depmod %{_kernel_ver}
259
260 %if %{with userspace}
261 %files
262 %defattr(644,root,root,755)
263 %doc README qemu-doc.html qemu-tech.html
264 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
265 %attr(755,root,root) %{_bindir}/*
266 %{_datadir}/qemu
267 %{_mandir}/man1/qemu.1*
268 %{_mandir}/man1/qemu-img.1*
269 %{_mandir}/man8/qemu-nbd.8*
270 %endif
271
272 %if %{with kernel}
273 %files -n kernel%{_alt_kernel}-misc-kqemu
274 %defattr(644,root,root,755)
275 %doc kqemu-%{kqemu_version}/LICENSE
276 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
277 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
278 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
279 %endif
This page took 0.050095 seconds and 3 git commands to generate.