]> git.pld-linux.org Git - packages/qbittorrent.git/blob - qbittorrent.spec
- fix moc problems on boost 1.57.0
[packages/qbittorrent.git] / qbittorrent.spec
1 #
2 # Conditional build:
3 %bcond_without  qsa             # build with bundled QtSingleApplication
4
5 %define         qtver   4.5
6 Summary:        qbittorrent - Qt4-based torrent client
7 Summary(hu.UTF-8):      qbittorrent - Qt4-alapĂș torrent kliens
8 Summary(pl.UTF-8):      qbittorrent - graficzny klient torrenta oparty na Qt4
9 Name:           qbittorrent
10 Version:        3.1.11
11 Release:        2
12 License:        GPL v2+
13 Group:          X11/Applications
14 Source0:        http://downloads.sourceforge.net/qbittorrent/%{name}-%{version}.tar.gz
15 # Source0-md5:  fcdcb9c0d42d040ead66d1a9cf33cd28
16 Patch0:         lang-hu-2.3.0.patch
17 Patch1:         cxx.patch
18 Patch2:         boost-moc.patch
19 URL:            http://qbittorrent.sourceforge.net/
20 BuildRequires:  GeoIP-devel
21 BuildRequires:  QtCore-devel >= %{qtver}
22 BuildRequires:  QtDBus-devel >= %{qtver}
23 BuildRequires:  QtGui-devel >= %{qtver}
24 BuildRequires:  QtNetwork-devel >= %{qtver}
25 %{?with_qsa:BuildRequires:      QtSingleApplication-devel >= 2.6-5}
26 BuildRequires:  QtSvg-devel >= %{qtver}
27 BuildRequires:  QtXml-devel >= %{qtver}
28 BuildRequires:  boost-devel >= 1.36.0
29 BuildRequires:  libnotify-devel >= 0.4.2
30 BuildRequires:  libtorrent-rasterbar-devel >= 1:0.15.9
31 BuildRequires:  libtorrent-rasterbar-devel <= 1:0.16.17
32 BuildRequires:  pkgconfig
33 BuildRequires:  qt4-build >= %{qtver}
34 BuildRequires:  qt4-linguist >= %{qtver}
35 BuildRequires:  qt4-qmake >= %{qtver}
36 BuildRequires:  rpmbuild(macros) >= 1.129
37 BuildRequires:  which
38 Requires:       desktop-file-utils
39 Requires:       libtorrent-rasterbar >= 1:0.15.9
40 Requires:       python >= 1:2.3
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 qTorrent - Qt4-based torrent client.
45
46 %description -l hu.UTF-8
47 qBittorrent - Qt4-alapĂș torrent kliens
48
49 %description -l pl.UTF-8
50 qTorrent - graficzny klient torrenta oparty na Qt4.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57
58 %if %{with qsa}
59 %{__rm} -r src/qtsingleapp
60 %endif
61
62 %build
63 # NOTE: not autoconf based configure
64 ./configure \
65         --verbose \
66         --prefix=%{_prefix} \
67         %{?with_qsa:--with-qtsingleapplication=system}
68
69 %{__make} \
70         CXX="%{__cxx}"
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install \
75         INSTALL_ROOT=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 %update_desktop_database
82
83 %files
84 %defattr(644,root,root,755)
85 %doc NEWS AUTHORS TODO Changelog
86 %attr(755,root,root) %{_bindir}/qbittorrent
87 %{_mandir}/man1/qbittorrent.1*
88 %{_iconsdir}/hicolor/*/apps/qbittorrent.png
89 %{_desktopdir}/qBittorrent.desktop
90 %{_pixmapsdir}/qbittorrent.png
This page took 0.163911 seconds and 3 git commands to generate.