]> git.pld-linux.org Git - packages/python3-pygments.git/commitdiff
- updated to 1.3.1
authorArtur Frysiak <artur@frysiak.net>
Sat, 27 Mar 2010 16:11:52 +0000 (16:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- build python3 version too

Changed files:
    python-pygments.spec -> 1.4

python-pygments.spec

index 636f3488d60ad090e65a59a1bea6bac2a0949cc9..2a7bb7f9ca9ee5740866a461345db1c0953d506e 100644 (file)
@@ -1,13 +1,15 @@
-
-%define module pygments
+%bcond_without python2
+%bcond_without python3
+%define module pygments
+#
 Summary:       Generic syntax highlighter
 Name:          python-%{module}
-Version:       1.1.1
+Version:       1.3.1
 Release:       1
 License:       BSD
 Group:         Development/Languages/Python
 Source0:       http://pypi.python.org/packages/source/P/Pygments/Pygments-%{version}.tar.gz
-# Source0-md5: 80ac64669a75e2d6647822b2778e38c8
+# Source0-md5: 54be67c04834f13d7e255e1797d629a5
 URL:           http://pygments.org/
 BuildRequires: python-devel
 %pyrequires_eq python-modules
@@ -27,27 +29,82 @@ prettify source code. Highlights are
 - it is usable as a command-line tool and as a library
 - ... and it highlights even Brainf*ck!
 
+%package -n python3-%{module}
+Summary:       Generic syntax highlighter
+Group:         Development/Languages/Python
+
+%description -n python3-%{module}
+Pygments is a generic syntax highlighter for general use in all kinds of
+software such as forum systems, wikis or other applications that need to
+prettify source code. Highlights are
+- a wide range of common languages and markup formats is supported
+- special attention is paid to details that increase highlighting quality
+- support for new languages and formats are added easily; most languages
+  use a simple regex-based lexing mechanism
+- a number of output formats is available, among them HTML, RTF, LaTeX and
+  ANSI sequences
+- it is usable as a command-line tool and as a library
+- ... and it highlights even Brainf*ck!
+
 %prep
 %setup -q -n Pygments-%{version}
 
 %build
-%{__python} setup.py build
+%if %{with python2}
+%{__python} setup.py build -b build-2
+%endif
+
+%if %{with python3}
+%{__python3} setup.py build -b build-3
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__python} setup.py install \
-               --optimize=2 \
-               --root=$RPM_BUILD_ROOT
+%if %{with python2}
+%{__python} setup.py \
+       build -b build-2 \
+       install \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+mv $RPM_BUILD_ROOT%{_bindir}/pygmentize{,-2}
 
 %py_postclean
+%endif
+
+%if %{with python3}
+%{__python3} setup.py \
+       build -b build-3 \
+       install \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+mv $RPM_BUILD_ROOT%{_bindir}/pygmentize{,-3}
+
+%py3_postclean
+%endif
+
+ln -s pygmentize-2 $RPM_BUILD_ROOT%{_bindir}/pygmentize
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(644,root,root,755)
 %doc PKG-INFO TODO AUTHORS
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/pygmentize
+%attr(755,root,root) %{_bindir}/pygmentize-2
 %{py_sitescriptdir}/%{module}
 %{py_sitescriptdir}/*Pygments*.egg*
+%endif
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%doc PKG-INFO TODO AUTHORS
+%attr(755,root,root) %{_bindir}/pygmentize-3
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/*Pygments*.egg*
+%endif
This page took 0.093514 seconds and 4 git commands to generate.