]> git.pld-linux.org Git - packages/python-unicodedata2.git/blob - python-unicodedata2.spec
- new
[packages/python-unicodedata2.git] / python-unicodedata2.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Unicodedata backport/updates to Python 2.x
7 Summary(pl.UTF-8):      Uaktualnienia danych Unicode dla Pythona 2.x
8 Name:           python-unicodedata2
9 Version:        10.0.0.post2
10 Release:        1
11 License:        Apache v2.0
12 Group:          Libraries/Python
13 Source0:        https://files.pythonhosted.org/packages/source/u/unicodedata2/unicodedata2-%{version}.tar.gz
14 # Source0-md5:  8d5e55787a4b89502ac0cb460564fd2b
15 URL:            https://pypi.python.org/pypi/unicodedata2
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 %if %{with python2}
19 BuildRequires:  python-devel >= 2.0
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-devel >= 1:3.2
24 BuildRequires:  python3-setuptools
25 %endif
26 Requires:       python-libs >= 2.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Unicodedata backport/updates to Python 2.x.
31
32 Additionally this module backports named aliases and named sequences
33 support to Python 2.
34
35 %description -l pl.UTF-8
36 Uaktualnienia danych Unicode dla Pythona 2.x.
37
38 Dodatkowo ten moduł zawiera backport nazwanych aliasów i nazwanych
39 sekwencji do Pythona 2.
40
41 %package -n python3-unicodedata2
42 Summary:        Unicodedata backport/updates to Python 3.x
43 Summary(pl.UTF-8):      Uaktualnienia danych Unicode dla Pythona 3.x
44 Group:          Libraries/Python
45 Requires:       python3-libs >= 1:3.2
46
47 %description -n python3-unicodedata2
48 Unicodedata backport/updates to Python 3.x.
49
50 %description -n python3-unicodedata2 -l pl.UTF-8
51 Uaktualnienia danych Unicode dla Pythona 3.x.
52
53 %prep
54 %setup -q -n unicodedata2-%{version}
55
56 %build
57 %if %{with python2}
58 %py_build
59 %endif
60
61 %if %{with python3}
62 %py3_build
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %if %{with python2}
69 %py_install
70
71 %py_postclean
72 %endif
73
74 %if %{with python3}
75 %py3_install
76 %endif
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %files
83 %defattr(644,root,root,755)
84 %doc README.md
85 %attr(755,root,root) %{py_sitedir}/unicodedata2.so
86 %{py_sitedir}/unicodedata2-%{version}-py*.egg-info
87 %endif
88
89 %if %{with python3}
90 %files -n python3-unicodedata2
91 %defattr(644,root,root,755)
92 %doc README.md
93 %attr(755,root,root) %{py3_sitedir}/unicodedata2.cpython-*.so
94 %{py3_sitedir}/unicodedata2-%{version}-py*.egg-info
95 %endif
This page took 0.14052 seconds and 3 git commands to generate.