]> git.pld-linux.org Git - packages/python-pympler.git/blob - python-pympler.spec
f103c4ae7a7bda9cf8a4c8b5bce86aca5ee97413
[packages/python-pympler.git] / python-pympler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Tool to measure, monitor and analyse the memory behaviour of Python 2 objects
8 Summary(pl.UTF-8):      Narzędzie do pomiaru, monitorowania i analizy zachowania pamięciowego obiektów Pythona 2
9 Name:           python-pympler
10 Version:        0.5
11 Release:        1
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/pympler/
15 Source0:        https://files.pythonhosted.org/packages/source/P/Pympler/Pympler-%{version}.tar.gz
16 # Source0-md5:  831d12beca2ff2ea56407c5ed8ffc4b0
17 URL:            https://pythonhosted.org/Pympler/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.6
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules >= 1:3.2
25 %endif
26 Requires:       python-modules >= 1:2.6
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Pympler is a development tool to measure, monitor and analyse the
32 memory behaviour of Python objects in a running Python application.
33
34 %description -l pl.UTF-8
35 Pympler to narzędzie programistyczne do pomiaru, monitorowania i
36 analizy zachowania pamięciowego obiektów Pythona w działającej
37 aplikacji.
38
39 %package -n python3-pympler
40 Summary:        Tool to measure, monitor and analyse the memory behaviour of Python 3 objects
41 Summary(pl.UTF-8):      Narzędzie do pomiaru, monitorowania i analizy zachowania pamięciowego obiektów Pythona 3
42 Group:          Libraries/Python
43 Requires:       python3-modules >= 1:3.2
44
45 %description -n python3-pympler
46 Pympler is a development tool to measure, monitor and analyse the
47 memory behaviour of Python objects in a running Python application.
48
49 %description -n python3-pympler -l pl.UTF-8
50 Pympler to narzędzie programistyczne do pomiaru, monitorowania i
51 analizy zachowania pamięciowego obiektów Pythona w działającej
52 aplikacji.
53
54 %prep
55 %setup -q -n Pympler-%{version}
56
57 %build
58 %if %{with python2}
59 %py_build
60
61 %if %{with tests}
62 PYTHONPATH=$(pwd) \
63 %{__python} test/runtest.py -post-install -verbose 3
64 %endif
65 %endif
66
67 %if %{with python3}
68 %py3_build
69
70 %if %{with tests}
71 PYTHONPATH=$(pwd) \
72 %{__python3} test/runtest.py -post-install -verbose 3
73 %endif
74 %endif
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %if %{with python2}
80 %py_install
81
82 %py_postclean
83 %endif
84
85 %if %{with python3}
86 %py3_install
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %if %{with python2}
93 %files
94 %defattr(644,root,root,755)
95 %doc NOTICE README.md
96 %{py_sitescriptdir}/pympler
97 %{py_sitescriptdir}/Pympler-%{version}-py*.egg-info
98 %endif
99
100 %if %{with python3}
101 %files -n python3-pympler
102 %defattr(644,root,root,755)
103 %doc NOTICE README.md
104 %{py3_sitescriptdir}/pympler
105 %{py3_sitescriptdir}/Pympler-%{version}-py*.egg-info
106 %endif
This page took 0.124757 seconds and 2 git commands to generate.