]> git.pld-linux.org Git - packages/python-pyatspi.git/blob - python-pyatspi.spec
8201d7acd75cfb3d2d07e5f958f237eeb28c3a73
[packages/python-pyatspi.git] / python-pyatspi.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5 #
6 %define         module  pyatspi
7 Summary:        AT-SPI Python bindings
8 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona
9 Name:           python-%{module}
10 Version:        2.16.0
11 Release:        2
12 License:        LGPL v2
13 Group:          Development/Languages/Python
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pyatspi/2.16/%{module}-%{version}.tar.xz
15 # Source0-md5:  76a3dc0ec2d3cb0ae1a77ab6c43a3099
16 URL:            https://www.linuxfoundation.org/en/AT-SPI_on_D-Bus
17 BuildRequires:  pkgconfig
18 BuildRequires:  python-pygobject3-common-devel >= 3.0.0
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 %if %{with python2}
23 BuildRequires:  python-devel >= 1:2.6
24 BuildRequires:  python-distribute
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-devel >= 3.2
28 %endif
29 Requires:       at-spi2-core >= 2.12.0
30 Requires:       gobject-introspection
31 Requires:       python-modules
32 Requires:       python-pygobject3 >= 3.0.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This package provides AT-SPI Python bindings.
37
38 %description -l pl.UTF-8
39 Ten pakiet dostarcza wiązania AT-SPI dla Pythona.
40
41 %package -n python3-%{module}
42 Summary:        AT-SPI Python 3 bindings
43 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona 3
44 Group:          Development/Languages/Python
45 Requires:       at-spi2-core >= 2.12.0
46 Requires:       gobject-introspection
47 Requires:       python3-modules
48 Requires:       python3-pygobject3 >= 3.0.0
49
50 %description -n python3-%{module}
51 This package provides AT-SPI Python 3 bindings.
52
53 %description -n python3-%{module} -l pl.UTF-8
54 Ten pakiet dostarcza wiązania AT-SPI dla Pythona 3.
55
56 %prep
57 %setup -q -n %{module}-%{version}
58
59 %build
60 %if %{with python3}
61 mkdir py3
62 cd py3
63 ../%configure \
64         --with-python="/usr/bin/python3"
65 %{__make}
66 cd ..
67 %endif
68
69 %if %{with python2}
70 mkdir py2
71 cd py2
72 ../%configure \
73         --with-python="%{__python}"
74 %{__make}
75 cd ..
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python3}
82 %{__make} -C py3 install \
83         DESTDIR=$RPM_BUILD_ROOT
84 %endif
85
86 %if %{with python2}
87 %{__make} -C py2 install \
88         DESTDIR=$RPM_BUILD_ROOT
89 %endif
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %if %{with python2}
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS NEWS README
98 %{py_sitescriptdir}/pyatspi
99 %endif
100
101 %if %{with python3}
102 %files -n python3-%{module}
103 %defattr(644,root,root,755)
104 %doc AUTHORS NEWS README
105 %{py3_sitescriptdir}/pyatspi
106 %endif
This page took 0.072123 seconds and 2 git commands to generate.