]> git.pld-linux.org Git - packages/python-pyatspi.git/blob - python-pyatspi.spec
- python3 epoch; no python-distribute BR
[packages/python-pyatspi.git] / python-pyatspi.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5 #
6 %define         module  pyatspi
7 Summary:        AT-SPI Python bindings
8 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona
9 Name:           python-%{module}
10 Version:        2.18.0
11 Release:        1
12 License:        LGPL v2
13 Group:          Development/Languages/Python
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pyatspi/2.18/%{module}-%{version}.tar.xz
15 # Source0-md5:  63784b21c759452e6506e1f7a4d7913e
16 URL:            https://www.linuxfoundation.org/en/AT-SPI_on_D-Bus
17 BuildRequires:  pkgconfig
18 BuildRequires:  python-pygobject3-common-devel >= 3.0.0
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 %if %{with python2}
23 BuildRequires:  python-devel >= 1:2.6
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-devel >= 1:3.2
27 %endif
28 Requires:       at-spi2-core >= 2.12.0
29 Requires:       gobject-introspection
30 Requires:       python-modules
31 Requires:       python-pygobject3 >= 3.0.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This package provides AT-SPI Python bindings.
36
37 %description -l pl.UTF-8
38 Ten pakiet dostarcza wiązania AT-SPI dla Pythona.
39
40 %package -n python3-%{module}
41 Summary:        AT-SPI Python 3 bindings
42 Summary(pl.UTF-8):      Wiązania AT-SPI dla Pythona 3
43 Group:          Development/Languages/Python
44 Requires:       at-spi2-core >= 2.12.0
45 Requires:       gobject-introspection
46 Requires:       python3-modules
47 Requires:       python3-pygobject3 >= 3.0.0
48
49 %description -n python3-%{module}
50 This package provides AT-SPI Python 3 bindings.
51
52 %description -n python3-%{module} -l pl.UTF-8
53 Ten pakiet dostarcza wiązania AT-SPI dla Pythona 3.
54
55 %prep
56 %setup -q -n %{module}-%{version}
57
58 %build
59 %if %{with python3}
60 mkdir py3
61 cd py3
62 ../%configure \
63         --with-python="/usr/bin/python3"
64 %{__make}
65 cd ..
66 %endif
67
68 %if %{with python2}
69 mkdir py2
70 cd py2
71 ../%configure \
72         --with-python="%{__python}"
73 %{__make}
74 cd ..
75 %endif
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %if %{with python3}
81 %{__make} -C py3 install \
82         DESTDIR=$RPM_BUILD_ROOT
83 %endif
84
85 %if %{with python2}
86 %{__make} -C py2 install \
87         DESTDIR=$RPM_BUILD_ROOT
88 %endif
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %if %{with python2}
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS NEWS README
97 %{py_sitescriptdir}/pyatspi
98 %endif
99
100 %if %{with python3}
101 %files -n python3-%{module}
102 %defattr(644,root,root,755)
103 %doc AUTHORS NEWS README
104 %{py3_sitescriptdir}/pyatspi
105 %endif
This page took 0.063791 seconds and 3 git commands to generate.