]> git.pld-linux.org Git - packages/python-pyPgSQL.git/blob - python-pyPgSQL.spec
58c2707f75398954a5074bf4d1fc48dada1f98ef
[packages/python-pyPgSQL.git] / python-pyPgSQL.spec
1 %define         module  pyPgSQL
2
3 Summary:        Python DB-API 2.0 PostgreSQL module
4 Summary(pl.UTF-8):      Moduł PostgreSQL dla Pythona zgodny z DB-API 2.0
5 Name:           python-%{module}
6 Version:        2.5.1
7 Release:        3
8 License:        GPL
9 Group:          Libraries/Python
10 Source0:        http://dl.sourceforge.net/pypgsql/%{module}-%{version}.tar.gz
11 # Source0-md5:  82670f6f1652aa4766fdaec2cb43debd
12 URL:            http://pypgsql.sourceforge.net/
13 BuildRequires:  postgresql-devel >= 7.0
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  rpm-pythonprov
16 Requires:       postgresql-libs
17 %pyrequires_eq  python-modules
18 Requires:       python-mx-DateTime
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 pyPgSQL is a package of two modules that provide a Python DB-API 2.0
23 compliant interface to PostgreSQL databases. The first module, libpq,
24 exports the PostgreSQL C API to Python. This module is written in C
25 and can be compiled into Python or can be dynamically loaded on
26 demand. The second module, PgSQL, provides the DB-API 2.0 compliant
27 interface and support for various PostgreSQL data types, such as INT8,
28 NUMERIC, MONEY, BOOL, ARRAYS, etc. This module is written in Python.
29
30 %description -l pl.UTF-8
31 pyPgSQL to pakiet dwóch modułów dostarczających zgodny z Python DB-API
32 2.0 interfejs do baz danych PostgreSQL. Pierwszy moduł, libpq,
33 eksportuje API C PostgreSQL-a do Pythona. Ten moduł jest napisany w C
34 i może być wkompilowany w Pythona lub ładowany dynamicznie na
35 żądanie. Drugi moduł, PgSQL, dostarcza zgodny z DB-API 2.0 interfejs
36 oraz wsparcie dla różnych typów danych PostgreSQL-a, takich jak INT8,
37 NUMERIC, MONEY, BOOL, ARRAYS itp. Ten moduł jest napisany w Pythonie.
38
39 %prep
40 %setup -q -n %{module}-%{version}
41
42 %build
43 %{__python} setup.py build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__python} setup.py install \
49         --optimize=2 \
50         --root=$RPM_BUILD_ROOT
51
52 find $RPM_BUILD_ROOT%{py_sitedir} -type f -name "*.py" | xargs rm
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Announce ChangeLog README examples/*.py
60 %{py_sitedir}/*.egg-info
61 %dir %{py_sitedir}/%{module}
62 %{py_sitedir}/%{module}/*.py[co]
63 %dir %{py_sitedir}/%{module}/libpq
64 %{py_sitedir}/%{module}/libpq/*.py[co]
65 %attr(755,root,root) %{py_sitedir}/%{module}/libpq/*.so
This page took 0.078089 seconds and 2 git commands to generate.